WordPress.org

Ready to get started?Download WordPress

Forums

3.4.2 erases audio tags 3.4.1 allowed (5 posts)

  1. ryansatterfield
    Member
    Posted 1 year ago #

    I have been using the html 5 audio tags for my podcast in 3.4.1 without a problem. I updated to 3.4.2 and it immediately removes any audio tag I insert. I don't want to use a plugin since I have to read over each plugins code to check for flaws. I find flaws and fix them. Any help is appreciated!

  2. David Gard
    Member
    Posted 1 year ago #

    What is it exactly that is removing the tag? Helping us identify where the tags are being removed will help us find what is doing it.

    Do you mean that you are adding them when writing a post, but when you click on 'Publish' they are being removed?

    Or is it that they are being removed when you call the post content using either get_post_content() or post_content()?

  3. ryansatterfield
    Member
    Posted 1 year ago #

    I am sorry I wasn't clear. I meant when I push publish they automatically disappear.

  4. David Gard
    Member
    Posted 1 year ago #

    I do remember seeing somthing in the past, about an older version of WP, where there was a problem with only Admins being able to use certain tags. If you were not an admin they were stripped when you published the post.

    Are you an admin on your site, or something other (editor, author, etc.)?

  5. ryansatterfield
    Member
    Posted 1 year ago #

    Yes, I am an admin. I realized that some code I put in the wp-config.php to stop XSS from editors also stopped valid code.

Topic Closed

This topic has been closed to new replies.

About this Topic