WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3.3.1 breaks image upload and insert (9 posts)

  1. sturmey
    Member
    Posted 2 years ago #

    When I use firefox10, IE8 or google chrome I can't get the insert image link to work. If I right click and select open in new tab, or new window, then the uploader opens and I can access the images.

    clearly the link is broken in this update This isn't the real problem though.

    The real problem is that once the uploader shows the file complete on the server the button to insert into a post doesn't work in Firefox or Chrome. In Internet Explorer 8 the picture does insert into the post. In Firefox or in Chrome the page goes blank, the code appears to be partially there, but the info is never inserted into the post.

    This was not a problem with 3.2. The update to 3.3.1 is causing this problem. Is there a patch?

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Have you tried:
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    - switching to the Twenty Eleven theme to rule out any theme-specific problems.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    clearly the link is broken in this update

    It works just fine for me using Firefox 10, IE9, Opera 11.6 and Chrome 17.0.963.46 on multiple sites.

    The real problem is that once the uploader shows the file complete on the server the button to insert into a post doesn't work in Firefox or Chrome.

    Again, it works fine for me. and for the vast majority of WordPress users given the lack of report of this "error". This suggests that the issue is specific to your site. Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  4. Cronycs
    Member
    Posted 2 years ago #

    Hi,
    I get exactly the same problem. Since I have upgraded to 3.3.1, when I click on the Upload Image link nothing happens. I also can't use the HTML view.
    I have tried all that you suggest. I have also tried to use a fresh wp-content with nothing more than default inside, but I get the problem either. I'm using a french version of WP, so I also tried to move to the english version. But I get the same problem.
    Do you have any idea of what I can try to resolve this problem?

  5. fredlet
    Member
    Posted 2 years ago #

    Same thing here, the file says it is being uploaded to "/uploads/2011/07" despite today being 3/1
    Moreover, when I go look at the dir via FTP, the file isnt' there.

  6. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    @Cronycs and @fredlet You do not have the same problem as the OP. You will have much better results if you start your own thread's.

  7. fredlet
    Member
    Posted 2 years ago #

    will do.

  8. JaySilver21
    Member
    Posted 2 years ago #

    I'm having the same problem. I click the insert/upload button and it doesn't load.

  9. sturmey
    Member
    Posted 2 years ago #

    OK, this is solved, well sort of...
    I tried the default theme and managed to get everything to work, except that the site now looks like (well insert whatever bad word you want)

    The theme I had does have an update, but the update breaks all the customization and will NOT let me make changes like it did before. (add another expletive)

    I'm getting a reference to a file that doesn't exist and an error that doesn't match the code that it references. Time for a different theme and an image upgrade I guess.

    Thanks all.
    consider this closed
    Sturmey

Topic Closed

This topic has been closed to new replies.

About this Topic