WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3.3 HTML editor shows white-on-white text in code only (30 posts)

  1. lostinbrooklyn
    Member
    Posted 2 years ago #

    OK, next 3.3 upgrade issue. All of the functionality seems to be working except one major component: the HTML editor.

    When I attempt to edit an existing post or create a new one, the text, now monospace, is white-on-white and in html code not WYSIWYG.

    The only way I can see the text/code is if I select it.

    Any clues as to what is going on?

  2. Have you tried turning off all your plug-ins, then reactivating them one by one to see if there's a conflict?

    If that doesn't help, you could try installing the Hotfix plugin, which fixes a few issues in 3.3 before the next release:

    http://wordpress.org/extend/plugins/hotfix/

    You can read more here - see #2 in particular. Not sure if this is what's happening in your case but it's worth a try:

    http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list?replies=5#post-2496392

    Let us know if this fixes it.

  3. lostinbrooklyn
    Member
    Posted 2 years ago #

    Nope. And deactivated/activated all one by one. Still the same issue :(

    Additional thoughts?

  4. lostinbrooklyn
    Member
    Posted 2 years ago #

    And installed the Hotfix plug in as well.

  5. One more thing to try is a manual reinstall of WordPress, fist deleting the wp-admin & wp-includes folders, as well as the files in the root folder via FTP, and then re-uploading these from a freshly downloaded copy of WordPress. Perhaps a file was corrupted during upload or did not get fully uploaded. Do not, of course, replace the wp-content folder or wp-config.php file, or any other custom files or folders. If you want to be really safe, back up the entire site's files first, and take all other backup precautions first.

  6. lostinbrooklyn
    Member
    Posted 2 years ago #

    Deleted all files except wp-content and wp-config.php uploaded all new files (except the above) for a 3.3 install downloaded this morning.

    Here's the latest error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@postclassical.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.64 (Unix) mod_ssl/2.0.64 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.postclassical.com Port 80

    Now not only is the admin down, but the entire site.

    Help!

  7. Did you delete your .htaccess file?

  8. Sounds like you might be missing one or more files, or perhaps your FTP program is corrupting files as you upload. You will need to reupload the files again - very, very, carefully.

  9. lostinbrooklyn
    Member
    Posted 2 years ago #

    Nope. Or rather I did not call it out and physically delete it.

  10. lostinbrooklyn
    Member
    Posted 2 years ago #

    it's a sftp client Cyberduck on OSX. Went in deleted all files manually, then manually uploaded them.

  11. lostinbrooklyn
    Member
    Posted 2 years ago #

    Checking with the hosting company to see if there are any know server issues.

  12. Went in deleted all files manually

    ALL files?

    You did remember this:

    Do not, of course, replace the wp-content folder or wp-config.php file, or any other custom files or folders.

    Right?

  13. lostinbrooklyn
    Member
    Posted 2 years ago #

    Yes, left wp-content and wp-config.php and other non-WP related files alone.

    Seems there "might" be a server issue. Fortunately we do have back-ups, but what a pita to go back via a restore and start this all over again.

  14. Nothing you did should have affected the database, so you should not have to start anything over. Did you back up the site files before starting this process as I suggested above?

  15. lostinbrooklyn
    Member
    Posted 2 years ago #

    Yes, they were backed up yesterday.

    They rebooted the server. Site is back up, but now I'm back to the same white-on-white text issue. :(

  16. The other thing you could try is ruling out a theme issue. You'd do that by temporarily switching to a default theme like Twenty Ten or Twenty Eleven and seeing if the problem is still there. However, I can't guarantee that in doing so you may not lose custom settings when you return to your original theme, such as widgets, menus, and any other custom theme settings, so please be aware of this.

  17. Just to double-check, you turned off all plug-ins and the issue remained? Could you try again, turn off all your plug-ins but also clear your cache and cookies for the domain in question? Log out and back in and see if the issue is still there, with all plug-ins off.

  18. May as well toss in a DB repair while you're at it. That's pretty safe.

  19. lostinbrooklyn
    Member
    Posted 2 years ago #

    OK, it was a permissions issue, sftp'ing in with the root, not cPanel. Can now reupload w/ the proper permissions.

    Any new strategy, or follow the same steps as above?

  20. Are you saying that your previous upload of a freshly-downloaded copy of wp-content, wp-admin & root files did not work correctly? If so, then yes, I'd try doing that again. Be sure you have backups first. :-)

    You can also follow our other advice just above.

  21. lostinbrooklyn
    Member
    Posted 2 years ago #

    Turned off all plug-ins, same issue. I'd prefer to not go the theme change route as we have done a lot of work within the widgets and menus.

    I'll back up the wp-content and wp-config.php, delete everything else and upload everything again, sans those two things.

    And report back...

  22. lostinbrooklyn
    Member
    Posted 2 years ago #

    Are you saying that your previous upload of a freshly-downloaded copy of wp-content, wp-admin & root files did not work correctly?

    Yes, forgot to add.

  23. OK, good luck. Leave your .htaccess untouched, as well.

  24. lostinbrooklyn
    Member
    Posted 2 years ago #

    Yippy, it worked! And with all my orig. plug-ins. So it must have been a permissions issue w/ the server that was corrupting the files or the like.

    Thanks for all the help.

  25. Good stuff, glad it's solved. :-)

  26. lostinbrooklyn
    Member
    Posted 2 years ago #

    Except now I was playing with plug ins (on and off) to make sure of no 3.3 bugs and this happened:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home/postclas/public_html/wp-admin/includes/menu.php on line 38

    Any ideas? Can I hit the plug ins folder and remove/add to see if I can lose the error?

    What a fun day :(

  27. esmi
    Forum Moderator
    Posted 2 years ago #

  28. lostinbrooklyn
    Member
    Posted 2 years ago #

    The WP-config hack and removing a few plug ins worked. Thanks.

  29. nocturnmidnight
    Member
    Posted 2 years ago #

    I had the same problem.

    I was going thru the settings and under general "WordPress Address (URL)" I had "/blog".

    I changed that to the full "http://www.rcogop.com/blog". and the visual editor worked again. I hope this helps someone else.

  30. pmmartino2
    Member
    Posted 1 year ago #

    Had the same issue (white visual editor showing only html with white text only visible when highlighted). It was also a permission error, I accidentally changed permission on the wp_admin directory to 0777. When I changed it back to 0755 the visual editor restored to normal.

Topic Closed

This topic has been closed to new replies.

About this Topic