WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3.2 Upgrade - Database Update Failure (9 posts)

  1. Gillian
    Member
    Posted 3 years ago #

    I tried to do the upgrade to Version 3.2 for my domain this morning.

    The upgrade appeared to be successful. I was then presented with the notice:
    "Database Update Required
    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version."

    I clicked the "Update WordPress Database" button and very soon after got this error message: "ERROR: WordPress 3.2 requires MySQL 5.0 or higher".

    I checked my host server and found it is running these versions
    PHP Version 5.2.6-1+lenny9
    and
    MySQL Version 5.0.51a
    which both appear to meet the upgrade requirements.

    My website is still working (as far as I can tell with the checking I have done so far) but I have no access to the Dashboard because it always brings up the "Database Update Required" notice (and the update always fails as noted above).

    At this stage, I don't know if my website is running 3.1.4, or 3.2, or something in between.

    Any assistance to get back into my Dashboard, and complete the upgrade as required, will be greatly appreciated. If I need to disable plug-ins first, how do I do this without Dashboard access?

  2. shovenose
    Member
    Posted 3 years ago #

    I got the same :="database update required" message but now my site is messed up.

  3. Gillian
    Member
    Posted 3 years ago #

    Further to my first post, I found on another thread the instructions for deactivating all plugins (go to the wp_option table in your WordPress database, and look for the row with option_name 'active_plugins'. Then empty this row's 'option_value' field. This should deactivate all plugins.).

    I don't want to try this yet, however, until I find out if this will help with my particular issue with the Version 3.2 Upgrade - no-one else posting so far has come up with the exact issue I have described.

    Looking forward to some expert advice :-)

  4. Gillian
    Member
    Posted 3 years ago #

    Sorry for the multiple posts, but I then found this reference to deactivating all plugins:
    http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    I chose the FTP option (renamed the plugins folder to plugins.hold and created an empty plugins folder) because it was easier to reverse if it didn't resolve the issue.

    Having effectively disabled all plugins, I then tried updating the database again (by simply accessing the Dashboard) but got the same error message as before: "ERROR: WordPress 3.2 requires MySQL 5.0 or higher".

    I have now reverted to using my installed plugins because it appears that one of them isn't causing the issue - my website looks dreadful without its plugins :-)

    I think I really have expended all my ideas now - waiting patiently for some expert assistance :-)

  5. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    I checked my host server and found it is running these versions
    PHP Version 5.2.6-1+lenny9
    and
    MySQL Version 5.0.51a
    which both appear to meet the upgrade requirements.

    That does sound strange. Is the site in question polioaustralia.org.au (which i note is running 3.2) or another one?

    If the MySQL version is not compatible, you should be locked out of the front end of the blog as well as the backend, not one or the other..

    Are you able to do some basic PHP debugging? (add a bit of code into the wp-includes/wp-db.php file to test a few things out)

  6. Gillian
    Member
    Posted 3 years ago #

    Hi Dion

    Many thanks for your reply and advice :-)

    Yes, that is the correct site. I have some good news though! Since my last post I have got a response from the support ticket I put into my web host this morning - he wrote:

    "The local webserver for polioaustralia.org.au runs the required PHP version and an instance of MySQL that is high enough but your database was initially setup on the central MySQL database server which is an earlier version.

    I have now migrated your MySQL database from the remote central server to the local server and changed the database section of your wp-config.php to access the localhost server."

    I am now up and running again and about to explore 3.2 in more depth :-)

  7. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Ah all good then, Thanks for updating us on the issue :)

  8. prodentite
    Member
    Posted 3 years ago #

    Ridgididgi- you, my friend,just saved me a melt down.

    Thanks!

  9. Gillian
    Member
    Posted 3 years ago #

    Hi prodentite

    I'm glad that posting about my little drama yesterday, and its solution, helped someone else :-)

Topic Closed

This topic has been closed to new replies.

About this Topic