WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] 3.1.8.2 Captcha doesn't work for me (34 posts)

  1. brianism
    Member
    Posted 1 year ago #

    I updated to 3.1.8.2 and Captcha stopped working, giving the message that the entered characters were incorrect. I reverted back to 3.1.8.1 and now it's working fine.

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Ausy
    Member
    Posted 1 year ago #

    Same happened on my site after upgrade to latest version!

  3. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry you are having trouble, I can help you figure out the cause, it might be a simple setting or a simple fix.

    When asking for help, please post a URL to your page with the form. I might have been able to figure out the cause already if you had.

    Please post the URL for help.
    And answer this question: Is this a single site or multi-site install?

    I do have a couple ideas, so with your help, I can help you, then make a FAQ page about it.

    Upgrade to the latest version,
    Cookies do not work across different domain names, so test for this condition:
    Look at the domain name your form is on, then right click where the CAPTCHA is, click “View Image” to make the image open in a page by itself. Or view the HTML source of the page. Now look at the domain name the CAPTCHA image is on. They are supposed to be the same domain name, even the www. part is important as it can be on both or not on not but not on just one. Is it different?
    If the domains are different, try solution 1 on this page:
    http://www.fastsecurecontactform.com/problem-captcha-image

    If that was not the problem:
    Here is how to begin finding the cause. Let me know what you find.
    http://www.fastsecurecontactform.com/troubleshoot-errors-in-wordpress

    Mike

  4. brianism
    Member
    Posted 1 year ago #

    Yes, I should have included the URL.

    So, I upgraded back to the 3.1.8.2. Here are the results.
    This is a single site install. http://brianleetest.com/contact/
    The URL of the CAPTCHA is:
    http://brianleetest.com/wp-content/plugins/si-contact-form/captcha/securimage_show.php?ctf_form_num=1
    I'm using the Zend theme. I changed back to 2012 and the behavior and URLs are the same with both themes.

    This error message appears: "That CAPTCHA was incorrect. Try again."

    Thanks,
    Brian

  5. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    The URLs are ok.
    I suspect it could be a session not working because of a server misconfiguration (sessions are broken)? Sometimes error display is turned off, so you would have to turn on WordPress debugging to see if you get a error, then it can be known if it is a session error or not.

    This page tells you how to turn on debugging temporarily to test
    http://www.fastsecurecontactform.com/troubleshoot-errors-in-wordpress

    Let me know if that reveals it, if not
    You should also try the other suggestions on the help page to rule out plugin or theme causes.

    If you cannot find anything, I would still like to try helping because maybe I can fix something

    Mike

  6. brianism
    Member
    Posted 1 year ago #

    Hi Mike,

    I don't know php error codes very well. I am leaving debugging on for a bit while I have lunch. Would you like to take a look at it?

    brianleetest.com/contact/

    In case you don't get to see it for yourself, here's what happens when the page loads:

    At the top of the page:
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /hsphere/local/home/c183717/brianleetest.com/wp-includes/functions.php on line 2959 Warning: session_start(): open(pass/sess_5q03g6mshbj6k6fo4kknkl67t6, O_RDWR) failed: No such file or directory (2) in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/si-contact-form/si-contact-form.php on line 1997 Notice: Undefined variable: config in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/functions.php on line 435 Notice: Undefined variable: data in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/header.php on line 19 Notice: Undefined index: defaults in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 506 Notice: Undefined variable: sb in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 98 Notice: Undefined index: bg_type in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/admin/functions/functions.php on line 131

    At the bottom of the page:
    Warning: Unknown: open(pass/sess_5q03g6mshbj6k6fo4kknkl67t6, O_RDWR) failed: No such file or directory (2) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (pass) in Unknown on line 0

    And here's what happens when I fill in the fields and hit Submit:

    At the top of the page:
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /hsphere/local/home/c183717/brianleetest.com/wp-includes/functions.php on line 2959 Warning: session_start(): open(pass/sess_5q03g6mshbj6k6fo4kknkl67t6, O_RDWR) failed: No such file or directory (2) in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/si-contact-form/si-contact-form.php on line 1997 Notice: Undefined index: fsc_shortcode_email_to_1 in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/si-contact-form/si-contact-form-process.php on line 182 Notice: Undefined variable: config in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/functions.php on line 435 Notice: Undefined variable: data in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/header.php on line 19 Notice: Undefined index: defaults in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 506 Notice: Undefined variable: sb in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 98 Notice: Undefined index: bg_type in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/admin/functions/functions.php on line 131

    At the bottom of the page:
    Warning: Unknown: open(pass/sess_5q03g6mshbj6k6fo4kknkl67t6, O_RDWR) failed: No such file or directory (2) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (pass) in Unknown on line 0

    Thanks,
    Brian

  7. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    It is a session problem, fix that then turn off debugging
    http://www.fastsecurecontactform.com/session-start-error

  8. brianism
    Member
    Posted 1 year ago #

    Thanks Mike, I'm learning things from you!

  9. Sean Donovan
    Member
    Posted 1 year ago #

    I just upgraded and have a similar problem, the captchas stopped working and/or the entire page goes blank. The settings page of the plugin is also blank.

    I am running the latest version of WordPress and cleared the W3 Total Cache and my browsers cache. Tried it in FF, Chrome and Safari.

    I will play with it in my development environment, but for now have switched back to the older version.

    I have had no trouble with FSC before.

  10. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    It is most likely sessions are broken on your server.
    Easy to fix

    Here is how to begin finding the cause. Let me know what you find.
    http://www.fastsecurecontactform.com/troubleshoot-errors-in-wordpress

    How to fix broken sessions
    http://www.fastsecurecontactform.com/session-start-error

    Mike

  11. brianism
    Member
    Posted 1 year ago #

    I put in a ticket with my hose and they have gotten the session start error to stop. The CAPTCHA error is still there though. "That CAPTCHA was incorrect. Try again."

    There is now no debug code at the bottom of the page, just on the top:
    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /hsphere/local/home/c183717/brianleetest.com/wp-includes/functions.php on line 2959 Notice: Undefined variable: config in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/functions.php on line 435 Notice: Undefined variable: data in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/header.php on line 19 Notice: Undefined index: defaults in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 506 Notice: Undefined variable: sb in /hsphere/local/home/c183717/brianleetest.com/wp-content/plugins/custom-sidebars/customsidebars.php on line 98 Notice: Undefined index: bg_type in /hsphere/local/home/c183717/brianleetest.com/wp-content/themes/zend/admin/functions/functions.php on line 131

    I will need to turn off debug soon to show the client some things.

    Thanks for your help.
    - Brian

  12. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    If you turn off debug now, the CAPTCHA might work

  13. brianism
    Member
    Posted 1 year ago #

    Unfortunately it didn't. I switched back to the previous version for my dog and pony show for the client tomorrow.

  14. rl7greg
    Member
    Posted 1 year ago #

    Same issue as http://wordpress.org/support/topic/captcha-code-always-incorrect?replies=9 - I see brianism is still using 3.1.8.1 to get captcha to work - I had 3.1.7.? and captcha was working as well. I'm going to follow up on the other thread

  15. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    This problem does not effect everybody, nor is is a WP 3.5.1 issue.
    The only reason you would always get "That CAPTCHA was incorrect. Try again." would be a PHP sessions issue.

    There is more than one possible cause and it requires a few minutes of troubleshooting, so I made a help page for this:
    http://www.fastsecurecontactform.com/captcha-always-incorrect

  16. algpres
    Member
    Posted 1 year ago #

    Hi Mike - I'm a big fan of your work (and a contributor). I'm having the same problem as the others in this thread. I moved my site to two other hosts as a test, and the Captcha still isn't working. I reverted back to 3.1.8.1 and it began working.

    I've spent three hours trying your fixes and still no success. I'm really not trying to give you a hard time about this, but because of all the trouble that some people (like me) are having is there any way you can change back to the way it used to work in the last version?

    Best,

    - Cary

  17. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Cary, It might be something simple I can help you with. Would you let me log into your site and take a look?
    contact me here (the page says to donate, but you do not have to)
    http://www.fastsecurecontactform.com/support

  18. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    For Cary: I fixed it, and I updated my help page. Your fix was Case Study 3, read that to see how I fixed it for you
    http://www.fastsecurecontactform.com/captcha-always-incorrect

    Your theme was the problem, specifically the google_map.php file was setting a session variable without starting a session first. This caused all PHP session variables to be deleted before each page load. This was easy to confirm by temporarily activating a WordPress default theme, then the problem immediately went away. This could also happen the same way with a plugin.

    You should notify your theme support about this bug in their theme. Anybody who has the issue should see the help page to resolve the problem.

  19. algpres
    Member
    Posted 1 year ago #

    Thank you Mike!!! Everything is working now.

    You were right all along, that the problem was not with your FS Contact Form. It was with my theme (case #3 in your list). I have contacted the theme developer and asked them to make the correction.

    You went way above and beyond the call of duty on this one - by fixing someone else's problem... and for a terrific plugin that you offer for free! I made a donation this morning for your time and for one of my favorite WordPress plugins.

    Thanks,

    - Cary

  20. brianism
    Member
    Posted 1 year ago #

    Hi Mike,

    I'm a long-time user of the plugin and a contributor, but this begs the question of why 3.1.8.2 is vulnerable to this bad coding practice of others, when previous versions were not. I feel like I have to go on an Easter egg hunt to find this problem which occurs in different themes and different combinations of plugins on my customers' sites. A couple hours' work so far does not corroborate any of the Case Studies yet.

    But it is great that you found the root of the problem, thanks.

    - Brian

  21. brianism
    Member
    Posted 1 year ago #

    Post above looks bitchy now. Not intended! The addition to wp-config.php was great. Make sure there is a semicolon after the last curly brace, and it works like a charm. Wish I could tell which plugin it is, and which of the plugin files to search. Perhaps I'll get that figured out someday. One that I tend to use across all sites is Custom Sidebars. I'll let y'all know if I find it.

    Thanks, Mike!

    - Brian

  22. satriosubroto
    Member
    Posted 1 year ago #

    i use this plugin for harisbali.com , it cannot send email to yahoo and gmail. But sending to custom domain webmail are no problem. please help.

  23. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    satriosubroto,

    Here is the email help page
    http://www.fastsecurecontactform.com/email-does-not-send

    If you need any more help. Please start your own topic.

  24. spottydog
    Member
    Posted 1 year ago #

    Hi.

    I'm having the same issue and I don't think it's a Server Setting problem because the 30 other websites I have on the same Server don't exhibit the issue, so I think it's a Theme Template issue as you mentioned in Case Study 3.

    I tried adding the following to the wp-config.php file:

    if( !isset( $_SESSION ) ) { // start a PHP session, but only if one is not already started
    session_start();
    }

    But I don't know if I have placed it in the right place and a previous commenter made the statement, "Make sure there is a semicolon after the last curly brace, and it works like a charm.", but I'm not sure exactly what that means.

    So my questions are:

    Where would I put the code mentioned above in the wp-config.php, and

    Is the code shown above correct, or is there a missing semi-colon?

    Oh, and one other thing, the SI-Captcha on the WordPress Log-in works just fine.

    Regards
    Iain

  25. brianism
    Member
    Posted 1 year ago #

    What I meant was that I thought there should be a ; at the end, but I guess it doesn't matter. I put the code snippet at the end of my wp-config.php like this:

    if( !isset( $_SESSION ) ) { // start a PHP session, but only if one is not already started
    session_start();
    };

    I'm not a php expert. I was just going on my belief that all php statements are supposed to end with a ; I just tried it without and it seems OK. Sorry to confuse.

  26. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

  27. spottydog
    Member
    Posted 1 year ago #

    Well that didn't work :-(
    I added the line of code in the suggested area, so it would seem that my particular circumstances are not the same as Case Study 3.
    But if it is a Server Sessions Configuration issue, I would have thought that it would affect all the websites I have hosted there.

  28. brianism
    Member
    Posted 1 year ago #

    3.1.8.2 didn't work on any of 6 sites hosted on the same server. I started a new one from a fresh WP install and kept the 2012 theme and 3.1.8.2 worked. But I think that was after I started adding the code above to wp-config, so maybe once the session thing was cleared up, it wouldn't appear on any of my sites until something triggered it again?

    Is it possible that code on one of my other sites or another site on my shared server messes it up for all the sites?

    The themes I'm using are:
    Zend
    Sonar
    Zee synergie
    Brunelleschi (2 sites)
    Zend
    2012

  29. marktab7
    Member
    Posted 1 year ago #

    Upgrading from 3.1.8.1 to 3.1.8.2 did NOT work for me with 3.5.1. Thus, I removed 3.1.8.2 and went back to 3.1.8.1, which worked. In my case, the aborted installation was still showing a message on the upgrade screen that a partial install had not completed: I did an entire refresh of WordPress 3.5.1 to respond to that message. Then, I experimented by removing 3.1.8.1 altogether, and manually downloading and installing the unzipped 3.1.8.2 files using FTP. After activation, the plugin worked.

    As a best practice: I recommend only upgrading 3.1.8.2 alone, even if other plugins are asking to be upgraded. You could choose to upgrade other plugins first (and maybe you have a reason to do those other upgrades after). However, isolating installation to this one plugin should help debug installation problems.

    Though I was able to solve my issue, I believe that others will similarly have problems on this particular 3.1.8.2 version. Do not give up: Please post exactly what is happening in your case, so that you can get your installation working like it does for me. During these installation attempts, keep a copy of 3.1.8.1 to use so that your website still works.

  30. alex80ks
    Member
    Posted 1 year ago #

    I have few websites on same host and i have 2 websites on different host and different account....it doesnt work on any of these so i think new version is the problem and i will return to old becouse it is impossible on different servers to have same problems on host side....Plugin is great but this update is messed up :)
    thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic