WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 3.1. RC2 not getting Page Templates on the theme folder (8 posts)

  1. gabidavila
    Member
    Posted 3 years ago #

    I'm not able to user Page Templates on 3.1.

    I am using a completely new install with the default theme of wordpress.

    I created a file called servicos.php and put at the beginning:

    `

    <?php
    /*
    Template Name: Servicos

    */
    ?>

    I put the same file on a install of 3.0.4 and worked fine.

    My doubt: The way of creating template files changed on 3.1? If not, did anyone try to use Page template on this version?

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I use many..... with headers just like you have... 3.1RC2

    <?php
    /*
    Template Name: Archives
    */

    for instance..... not sure why you would be having trouble?

  3. gabidavila
    Member
    Posted 3 years ago #

    I do not know why I am having trouble with that, Yesterday I was on the IRC channel and the boys told me that maybe was a file permission. I reseted the permission and still do not appear to me!

  4. Subhajit
    Member
    Posted 3 years ago #

    Me too facing this problem for couple of weeks, did lots of RND, not yet found any solution. This problem is occurring only for version 3.1.

    Anyone have any idea to fix this please......

    Thanks
    Subhajit

  5. excalabyte
    Member
    Posted 3 years ago #

    Also try deactivating the theme and reactivating

  6. neilscott
    Member
    Posted 3 years ago #

    Yep, deactivating and reactivating the theme worked for me. Cheers!

  7. Grant Bivens
    Member
    Posted 3 years ago #

    I'm also having this issue on 3.1.2

    Deactivating and reactivating does not do anything.

    Custom page template doesn't show up for normal posts or custom post types.

    I've even copied the snarfer example directly from the codex with no luck.

  8. rgbivens - Make a new topic in the troubleshooting section. This is for alpha/beta testing, which is on 3.2 now.

    (And I would start with turning off ALL your plugins first.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags