WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 301 home redirection to newly created page (15 posts)

  1. mariostella
    Member
    Posted 3 years ago #

    Weird problem here! I have NO clue where the mess is coming from.

    So I have this blog, always created pages no prob. I have selected a list of posts as my index. I just changed the template from kubrik to travelogue. Hardly believe this is the issue.

    I installed the flattr plugin and the CSS and widget plugins.

    Then I created a new page, not a post. And when I went to the homepage a permanent 301 redirect was there. Tried disabling all the flattr plugins, nothing. Deleted the page also from the trash, nothing. So I went into the DB and deleted the DB redirect (there I saw it was a 301).
    SO I did a couple of tests. Created a new page, then another one. The home was redirected to the first page, but after DB removal it was redirected to the secondly created page.

    By the way: No change at all in the permalink, htaccess or redirection plugin whatsoever.

    I need to create pages. Please land a hand, as I am totally clueless.

    Thanks in advance.

  2. mariostella
    Member
    Posted 3 years ago #

    I forgot to mention that the 301 redirects to the firstly created page. So if I create a new page, the 301 goes to that page. If I delete the page, the 301 give a 404 error, meaning the redirect is still in place.

  3. Michael Adams (mdawaffe)
    Member
    Posted 3 years ago #

    From where in the DB are you deleting these redirects?

    This doesn't sound like a core WordPress issue to me.

    Do you have Urban Giraffe's Redirection plugin installed?

    http://urbangiraffe.com/plugins/redirection/

    If so, your problem sounds similar to one reported here:

    http://urbangiraffe.com/support/topic/home-page-is-redirecting-to-another-wp-page-without-my-instruction-to-do-so

    Does the solution there help?

  4. ladysham
    Member
    Posted 3 years ago #

    I had this happen to me tonight. I had to go into the database through PHPAdmin and look at the redirects in the "Redirection" plugin. There was my culprit. Redirecting the home page to another page URL. Once I deleted that, I was good to go again.

    If I didn't have the Redirection plugin installed, it probably wouldn't have happened.

    Hope this helps.

    Kelly Ling

  5. 2is3
    Member
    Posted 3 years ago #

    Yup, I'm having the same issue on a couple of sites I work with. Anytime a new page or new custom post type is created (does not occur with new posts).

    A new row is added to the wp_redirection_items table where the 'URL' is '/' and the 'action data' is the slug to the new page.

  6. 2is3
    Member
    Posted 3 years ago #

    <strike>Update: If you go to 'Tools > Redirection > Modules' and completely delete that WordPress module, it seems to fix the bug.</strike>

    Nevermind, that didn't work really. Now you can't create redirects... bah!

  7. mariostella
    Member
    Posted 3 years ago #

    Edit: @mdawaffe sorry I had not seen your solution earlier. Yes that did help it, I found it through other ways, but thanks a lot.

    I found a solution. I am just gonna refer you to the Urban Giraffe's dev site with the solution page. Hope that is gonna stay for future ref

    http://urbangiraffe.com/support/topic/home-page-is-redirecting-to-another-wp-page-without-my-instruction-to-do-so

    Cheers

  8. jmabe
    Member
    Posted 3 years ago #

    Hey guys, I fixed this on two sites. If you go, from the Redirections settings menu, click on [Groups] then [Modified posts] you'll probably see a 301 in there for just "/". Remove it. I don't know how or why it got added, but it seemed to be around the time I upgraded to 3.0

  9. KerriM
    Member
    Posted 3 years ago #

    jmabe, thanks for your update. This was exactly the issue that I site I'm working on had. An extra redirect in the Modified Posts group that redirected the root url to one of the posts my client modified. Deleted it and all is well again!

  10. gibni
    Member
    Posted 3 years ago #

    same issue here! the solution with the module stuff is working, thanks!

    To recall the solution:
    "Go to the Redirection settings in your admin area (under tools),
    Go to Modules section of the plugin, then check for the entry with "/" value, once you find it, you can select, and then delete it. Your home page should appear again correctly."

    Amir,
    Gibni.com

  11. ericdaams
    Member
    Posted 3 years ago #

    The redirect will keep being added when you add a new post or page. There's a fairly simple fix to the plugin you can make though, which I posted in another thread: http://wordpress.org/support/topic/422148?replies=14#post-1617309

    Hope it helps someone. This issue was a major pain for me!

    Cheers,
    Eric

  12. mariostella
    Member
    Posted 3 years ago #

    Hey all!
    There are two things you need to do to get rid of the issue.

    1. Go here http://urbangiraffe.com/support/topic/home-page-is-redirecting-to-another-wp-page-without-my-instruction-to-do-so and follow the easy instructions.

    2. Go into your database and delete the redirect. You have no DB management knowledge and want to avoid messing things up? No prob, back up the DB, do a search for your problem-page slug (or pages, as any new page will create the issue) and delete any entry that is listed in the redirect table.

    Done, your homepage is up again, and new pages will not create the issue.

  13. nickiler
    Member
    Posted 3 years ago #

    I had a similar problem and did not have to edit any MySQL tables to fix it. I think that disabling the feature that generates the problem until the publisher patches it would be best.
    http://www.ilertech.com/wordpress/whats-wrong-with-the-wordpress-redirection-plugin/

  14. mariostella
    Member
    Posted 3 years ago #

    Yes, but if the plugin created a permanent 301 redirect in the DB disabling the feature will not be enough. It was not for me at least.

  15. KathleenH
    Member
    Posted 3 years ago #

    Thanks for the link to the Urban Giraffe site - following the instructions there solved my problem in seconds! Thanks, mdawaffe!

Topic Closed

This topic has been closed to new replies.

About this Topic