WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] 3.0 Plugin Upgrade Bug? Could Not Create Directory (100 posts)

  1. D M
    Member
    Posted 3 years ago #

    After searching for this upgrade problem, I applied the following:

    - disabled all plugins
    - deleted upgrade folder and changed permissions to 777
    result : this error : Could not copy file.:/public_html/blog/wp-admin/css/theme-editor.dev.css

    Then...
    - all plugins still disabled
    - deleted upgrade folder and changed permissions to 755
    result : this error : Could not copy file.:/public_html/blog/wp-admin/css/theme-editor.dev.css
    Installation Failed

    Then...
    - all plugins still disabled
    - added this to wp-config.php as suggested in this thread : http://wordpress.org/support/topic/installer-cannot-create-upgrade-directory?replies=15

    putenv('TMPDIR=' . ini_get('upload_tmp_dir'));
    define('FS_CHMOD_DIR', (0755 & ~ umask()));
    define('FS_CHMOD_FILE', (0644 & ~ umask()));

    result again : this error : Could not copy file.:/public_html/blog/wp-admin/css/theme-editor.dev.css
    Installation Failed

    Then...
    - all plugins still disabled
    - changed permissions on "wp-admin/css/theme-editor.dev.css" to 755
    result this time : this error : Could not create directory.: /public_html
    Installation Failed

    Then...
    - all plugins still disabled
    - changed permissions on my "public.html" to 755 (...they are originally 750)
    result this time : this error : Could not create directory.: /public_html
    Installation Failed

    Then...
    - all plugins still disabled
    - changed permissions on my "public.html" to 777
    result this time : this error : Could not create directory.: /public_html
    Installation Failed

    So my question is : why is the WordPress upgrade trying to create a "/public_html" file when one already exists?

    I don't think this is a problem with anyones server, but a problem with the upgrade mechanism in WordPress 3+, as I have never had this particular problem with WordPress upgrades prior to #3.

    Comments? Solutions?

  2. JSkole
    Member
    Posted 3 years ago #

    Exact same problem as you Elegant Bohemian. Only I have liquid web as well and so I logged into WHM and changed from Pure-FTP to ProFTP.

    New result:
    Unable to locate WordPress Root directory.
    Installation Failed

    Now I am completely baffled.

  3. Roy
    Member
    Posted 3 years ago #

    I have the same problem on my own Multi-install, but I just upgraded two plugins and WP on a single site install on another server in about 5 seconds. It does seem to be server-related or perhaps multi-related?

  4. maiself
    Member
    Posted 3 years ago #

    Hi,

    If u installed via autoinstaller like Fantastico or someting.. try reinstalled manually, download from wordpress.org then upload to webhost.

    I tried on my newly wordpress site via fantastico and giving me same error like you received. Tried delete /upgrade and recreate and its only work for a while.

    I delete everything and installed manually, no problem there after..

    its indeed a prob with permission like some of u explained before...

  5. jonscottweaver
    Member
    Posted 3 years ago #

    Hi,
    I tried resetting the directory permissions. Didn't work.
    I tried deleting the upgrade folder. Didn't work.
    I tried fixing the php function mkdir(). Didn;t work.
    I asked my host about PHP settings or file ownership. No go.

    THEN, my host learned that the WP updater has a conflict with CPanel FTP settings. Thru CPanel he was using PureFTP and changed it to ProFTP.
    IT WORKED!

    I appreciate everyone's posts searching for answers. Thanks JON

  6. mudthirsty
    Member
    Posted 3 years ago #

    I am having the EXACT same problem as EloquentBohemian. Im trying to do a few things. Install a plugin, install a new theme, and upgrade WP. All of them are giving me Could not create directory.: /public_html. When I delete the upgrade folder and re-set the permissions and try again, I get Could not copy file.:/public_html/blog/wp-admin/css/theme-editor.dev.css. Driving me nuts!

  7. onepursuit
    Member
    Posted 3 years ago #

    If your WordPress is running on a server that uses CPanel/WHM, WordPress is probably NOT the issue. It's most likely your FTP server.

    The default CPanel installation uses Pure-ftpd as its ftp server. I haven't dug around enough to figure out why/where, but there appears to be some sort of bug with its handling of permissions.

    If you are your own server administrator, you can change from Pure-FTP to ProFTP with a few simple clicks in your WHM (root) interface. From the main screen, under "Service Configuration", click on "FTP Server Selection", choose the first option (proftp), then click save. After it is installed, scroll down to the bottom and click on the configuration link to double-check the options (you may want to disable anonymous FTP).

    If you are not your server's administrator (if you do not have access to the superuser WHM account), you will want to to pass this info along to your admin so he/she could make the change for you. Once this is done, both WordPress updates and plugin updates should work without having to keep your permissions dangerously open.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    If your WordPress is running on a server that uses CPanel/WHM, WordPress is probably NOT the issue. It's most likely your FTP server.

    I'm currently running at least 8 WP sites on servers that use cPanel and I've never had this problem. So I doubt that it's a generic cPanel issue.

  9. onepursuit
    Member
    Posted 3 years ago #

    Then what I said doesn't apply to you. I said that IF you had this issue AND you were running CPanel, try proftp :P

    Besides, your WHM admin might already be running proftp and you don't even know it, in which case you would not have had the problem to begin with.

    There might be some other things in the mix... so far, every site I've encountered with this issue on a CPanel server has been "fixed" by changing the FTP server. Also, every site I've "fixed" so far was originally installed via fantastico, not manually. Every site has multiple additional plugins in the mix. Every site has customized themes. All or none of those variables might or might not have anything to do with the specific conditions that cause the error to show up.

    So, IF you have this error, AND you are running CPanel, it wouldn't hurt to try proftp.

  10. maiself
    Member
    Posted 3 years ago #

    I will try to change from pureftp to proftp... will give feedback once i tested the wordpress upgrade/direct plugin installation and such.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Then what I said doesn't apply to you. I said that IF you had this issue AND you were running CPanel, try proftp :P

    Fairy 'nuff. :-) I'll see if I can find out what those hosts are using for FTP and post back. It might help to clarify the problematic set of apps.

  12. mudthirsty
    Member
    Posted 3 years ago #

    Mine is on a Cpanel server. Can I change the ftp server from Cpanel?
    I will let you know if this fixes it.

  13. maiself
    Member
    Posted 3 years ago #

    mudthirsty

    you need an admin access on WHM to change the ftp server type.

  14. mudthirsty
    Member
    Posted 3 years ago #

    Thanks Maiself.. Just sent your instructions to my admin. I will let you, and everyone else, know if this works!

  15. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Just got answer back from the host:

    We run Pure-ftpd on our servers for FTP, the most likely cause of these errors is file/folder permissions.

    So it's got a be something deeper than just a cPanel/Pure-ftpd issue. I wonder if it's something in the server configs? Perhaps an allowed path setting?

  16. maiself
    Member
    Posted 3 years ago #

    Another way to check which FTP your cpanel using:-

    Connect to your ftp server using FTP client, check the welcome message:-

    [12/31/2010 12:59:15 AM] Socket connected. Waiting for welcome message...
    [12/31/2010 12:59:15 AM] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 00:59. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    STATUS:> [12/31/2010 12:59:15 AM] Connected. Authenticating...

    Hope that help...

  17. mudthirsty
    Member
    Posted 3 years ago #

    Cool, just checked, my welcome message states Pure-FTPd! Thanks, im glad I could confirm that.

  18. onepursuit
    Member
    Posted 3 years ago #

    esmi - Would changing the ftp server change the path settings? I didn't make any specific adjustments to the path, but on my servers, installing proftp definitely works, and using pure-ftpd definitely doesn't.

    Are your installations manual or do you use fantastico? I wonder if fantastico-installed file permissions/ownerships might be different from the "default".

    It would be interesting to find out what all the folks having issues have in common... fantastico? a certain OS? a certain plug-in? etc...

  19. maiself
    Member
    Posted 3 years ago #

    I have wordpress running on 4 different server/location. All server using pureFTP but only 1 host giving me that kind of problem.

    so i guess, its more to configuration/setting problem on the server.

    i just installed another wordpress on cpanel pureftp via softaculous and working great!

  20. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    so i guess, its more to configuration/setting problem on the server.

    That's my best guess too. Had a little chat with my hosts and they're convinced that it's going to be a folder/file permissions or owner problem.

  21. zota
    Member
    Posted 3 years ago #

    I just tried two auto-upgrades, different cPanel accounts, same configuration, same VPS.

    From 2.9.2 to 3.0.4 (yeah yeah, i know) - it zinged right through, no pauses, no errors.

    From 3.0.2 to 3.0.4 - after the usual 2 minute hang on "Installing," it died at the usual spot (wp-admin/css/theme-editor.dev.css)

    I realize this is just one data point, but almost every thread on this issue seems to describe a 3.x to 3.x upgrade. Is there any way we can definitively confirm/deny that this is not some aspect of the version 3 upgrade process or file structure?

    And has anyone taken a good hard look at theme-editor.dev.css? Cause I am starting to develop an irrational hatred that file.

  22. doulos70
    Member
    Posted 3 years ago #

    And has anyone taken a good hard look at theme-editor.dev.css? Cause I am starting to develop an irrational hatred that file.

    I am too having this problem. And no solutions yet, many are waiting solutions for this issue as they do automatic upgrade.

  23. burakco
    Member
    Posted 3 years ago #

    i changed the pureftp to proftp in whm panel ftp server sellection page. all problem are fixed

  24. doulos70
    Member
    Posted 3 years ago #

    My hosting guy said that in shared hosting changing to proftp is not possible.
    Any ideas

  25. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    @oulos70: Are you using the WHM within cPanel?

  26. doulos70
    Member
    Posted 3 years ago #

    @esmi Yes. I have WHM and cpanel accounts

  27. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    I'm beginning to think that the issue may lie within WHM and Pure-ftpd.

  28. zota
    Member
    Posted 3 years ago #

    I ran two more auto-upgrades on the same server (LiquidWeb VPS, running pureFTP) with installs in separate cPanels:

    2.9.1 -> 3.0.4 = upgraded with no error
    3.0.1 -> 3.0.4 = death file (theme-editor.dev.css)

    On this server at least, the pattern is consistent. Plugin updates run fine. 2.9.x updates run fine. 3.0.x upgrades fail in exactly the same way.

  29. paularovena
    Member
    Posted 3 years ago #

    Has someone fix the WP auto update problem with pureftp (is it the problem?)
    Regards Paula

  30. lemieux
    Member
    Posted 3 years ago #

    Success! I tried almost all of the solutions (including recreating the upgrade folder and changing permissions) but none of them worked.

    The solution that worked for me was to change from PureFTP to ProFTP inside of the Web Host Manager (root) interface. This can be changed in WHM Main >> Service Configuration >> FTP Server Selection.

    If you are on a shared server and do not have access to WHM, try contacting your hosting company. I also have a WordPress install on a shared server for another site I run, but the auto update worked fine there. I was having problems on my own server at a different hosting company.

Topic Closed

This topic has been closed to new replies.

About this Topic