WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] 3.0 Plugin Upgrade Bug? Could Not Create Directory (100 posts)

  1. victorytrader
    Member
    Posted 4 years ago #

    Figured it out...

    You need to have your server administrator change your PHP upload limit. Right now with CPanel it is automatically set at 2MB limit and so when it goes to update WP 3 it can't complete and keeps the install files in the folder... hence why you cannot install anything else. This solution worked for me.

  2. Brandon Hann
    Member
    Posted 4 years ago #

    I tried the "delete and CHMOD the upgrade folder" fix and it didn't work for me, so here's what I did:

    1. Delete the upgrade folder
    2. CHMOD the wp-content folder to 777
    3. Run auto-updater through admin again

    This will allow admin to write the upgrade folder to the wp-content folder and install...or at least it worked in my case!

  3. Reine Marge
    Member
    Posted 4 years ago #

    Hmm... ledfrog I tried what you suggest and alas it still didn't work ... I am beginning to wonder if I should just bite the bullet and try a manual install despite my lack of techie know how?

  4. freelancemom
    Member
    Posted 3 years ago #

    VictoryTrader -- that sounds logical. Any idea how much the upload limit needs to be increased to? I've changed mine to 8M and am still getting errors :-/

  5. Sue
    Member
    Posted 3 years ago #

    I have both changed my php limits (to unlimited) and permissions on the upgrade folder. I still can not update one of my sites from 3.0 to 3.0.1. Even the manual update option does not work.

    Any additional suggestions?

  6. eschaa00
    Member
    Posted 3 years ago #

    A bit of a techie response, but many web sites run PHP (when under *NIX) as the user nobody or some user other than yours. So if you install WP or a module directly (as you) then later try to update via the WP admin area, the file ownerships are wrong.

    A chmod 777 wp-content is not enough of a fix because the folders and files beneath may still be wrong. This is also a security concern.

    And "yes", the PHP upload limit for your host must be at least as large as the update you wish to upload. PHP has a post limit and an upload limit ... and if your host cannot manage to set reasonable limits then consider hosting with 10types.com. (I did not start this response to promote, but it now strikes me that any host still deploying with a 2mb upload default does not expect their customers to do much at all.)

    I think the "Could not create directory ./public_html" (or the like) is misleading because the issue is likely the wp-content/plugins or wp-content/upgrade folders.

    Any host admin with root privileges should be able to fix the permissions / ownerships on your WP files. For WP deployments where I don't have root, I:

    1. Make certain that under wp-content, the cache, plugins, themes, upgrade, and uploads directories are chmod 777.
    2. Make certain that the wp-content directory is chmod 755 or 750 (depending on your host) ... do not make this world writeable!

    If you attempt to upgrade a plugin and still get the "Could not create ..." error after the 2 steps above, this means that file ownership of the plugins is wrong. To fix, use whatever file browser is available on your host to traverse to the wp-content/plugins directory and then remove the folder holding the older version of the plugin ... and then use the WP admin to install the newer version.

    As always ... it's a good idea to make backups of your files before attempting changes.

  7. kvcindia
    Member
    Posted 3 years ago #

    Amazing, don;t know the reason, but it worked in that way.

    Deleted upgrade folder >> created again >> given 777
    and it worked.

    Before that it was not working even I had all my folders with 777 blog/wp-content/upgrade.

    Ok, At last it worked

  8. kvcindia
    Member
    Posted 3 years ago #

    Here's something new !
    It fixed and update the old plug in but can't install new plug in always says, "The plugin does not have a valid header.".

    Any comment ?

  9. Steve@316
    Member
    Posted 3 years ago #

    @kvcindia - May I suggest another/new thread for that particular problem? Still working on my "Could not create directory." error

    Thx

  10. Steve@316
    Member
    Posted 3 years ago #

    I'm getting the same error messages, tried to upload an image and add a plugin:

    "“imagename.jpg” has failed to upload due to an error
    Unable to create directory /wp-content/uploads. Is its parent directory writable by the server?"

    "Could not create directory. /httpdocs/wp-content/upgrade"

    Tried everything suggested so far, except waiting on server administrator change your PHP upload limit.

    Steve

  11. Steve@316
    Member
    Posted 3 years ago #

    Update: It seems I have the upload image problem solved. I tried changing the permissions on the upload l=folder and it worked this time.

    But! Still getting the "Could not create directory. /httpdocs/wp-content/upgrade/,... Error

    Does anyone have an answer/solution?

  12. Steve@316
    Member
    Posted 3 years ago #

    Update: It seems we have solved the problem. I modified the ownership of the uploads directory to apache:apache.

    Since you're using a web interface to upload and work with the file system, the web interface runs as the apache user, not your ftp user.

  13. lldanj
    Member
    Posted 3 years ago #

    CHMOD 777 for the Upgrade folder worked for me.

  14. guguwpblog
    Member
    Posted 3 years ago #

    delete, recreate and CHMOD 777 for the Upgrade folder worked for me.

  15. richardobbo
    Member
    Posted 3 years ago #

    I just upgraded to 3.0.1 today. And I am having the problem which many here have mentioned which is I am unable to auto install plugins or themes. When I click install, all I get is this message:

    "Installing Plugin: Contact Form 7 2.3.1
    Downloading install package from http://downloads.wordpress.org/plugin/contact-form-7.2.3.1.zip"

    I have tried just about every solution in this and other threads except that I have not tried to delete the upgrade folder. And still nothing has worked. Not being a techie I found it curious that the folder was empty. Should it be? If not, what should the contents be? Any other thoughts on how to fix this issue?

  16. esmi
    Forum Moderator
    Posted 3 years ago #

    Try adding AddType x-mapp-php5 .php to the top of your WordPress .htaccess file.

  17. richardobbo
    Member
    Posted 3 years ago #

    Tried it. No go. I am beginning to think I should give up, maybe roll back to the 2.9 version since I cant get past this issue.

  18. GnFgr
    Member
    Posted 3 years ago #

    I am running a self installed wordpress on an IIS server. Today i started to see this problem.
    The error appears after the old content of the folder is erased so you will have to remember the name of the addon to reinstall it.

    I have 256Mb limit here and the folders are permitted fine. The problem must be in the update engine wordpress uses. Just my 2 cents

    Deleting the old folder (its empty by the way) and reinstalling does the trick. I am not sure everybody are in such easy place to do that or they do know how. Also downloading the addon and upload and install generates this problem again sometimes.
    This should be fixed asap. Till then i am stopping auto updating (i recommend that) and just use the message of new updates to know what to update manually. At least that way i had no problems

  19. meaganleigh
    Member
    Posted 3 years ago #

    Hi guys, i've been having trouble with this for a while and have given up! I get the same error when trying to install the backup program.

    I do not understand how to change the permissions to 777. I use ClassicFTP on a MAC OSX and i have searched and searched on the FTP client to find where it gives you the option to do this.

    I even emailed the software company that makes ClassicFTP to ask them because I couldn't find anything on any forums about it, everyone just acts like its so obvious! They stated that I have to change the permission on my actual hard-drive, not through the FTP client. But I don't know where any of the WP folders are located on my computer... I thought they were created through the FTP client and not on my hard-drive.

    Can someone PLEASE help me, I'm pulling my hair out!! Baby steps please!

  20. riggie11
    Member
    Posted 3 years ago #

    I found a way to upgrade the WordPress Plugins without any errors. I use WordPress 3.01.

    My webhost is Liquidweb and this is how we solved the WordPress upgrade problem:

    Step 1: Let your webhost switch your FTP Server from Pure-FTP(or similar FTP) to ProFTP. For some reason WordPress doesn't agree with the FTP server that cPanel uses by default.

    Step 2: CHMOD 777 these folders in your wp-content folder: Gallery, Plugins (and all plugins in your Plugins folder), themes, upgrade, uploads.

    Step 3: Delete the upgrade folder, make a new upgrade folder and CHMOD it to 777.

    Step 4: CHMOD wp-content folder to 755 or 750, depending on your webhost.

    At least at Liquidweb, the upgrades of the plugins are real fast and without any errors now.

    -Riggie

  21. jbosari
    Member
    Posted 3 years ago #

    This is going to make some of you nuts (it did me). None of these solutions worked for me. I spent all day on this and it turns out it happened because of a bonehead mistake.

    Turns out that if you forget to deactiveate all plugins before an upgrade, this problem is the result. downgraded my wp installation to 2.9. Deactivated all plugins then upgraded back to 3.0.1. Now all is working fine!

    Let me know if this works for you. It took me 8 hours to figure it out. Thanks to the awesome guys at bluehost who really went above and beyond in helping me!

  22. riggie11
    Member
    Posted 3 years ago #

    Yes, you have to de-activate plugins, but this simple step did not work for most of us.

    If you still have problems after to de-activating your plugins, check my steps above...

  23. ScrapGirlsRo
    Member
    Posted 3 years ago #

    I deactivated all of my plug-ins, installed the upgrades, and then activated them again. It worked like a charm. I am so glad I found this string!

  24. alxsavu
    Member
    Posted 3 years ago #

    Same for me, I couldn't upgrade nothing but after I had delete upgrade folder in wp-content, recreated a new one and I switch the folder permissions to 777.
    No problem, it worked very fine!

    Thank you.

  25. Terence
    Member
    Posted 3 years ago #

    If you simply set permissions without knowing if you're on a DSO or suPHP machines, you could be in a world of pain. If you set 755 under SuPHP, the permission used is "7" and 777 under DSO the permission used is "7" so in the case of 755 on SuPHP verses 777 on DSO, it is exactly the same thing! If you want to set something to 777, you set it to 755 on SuPHP. If you actually set it to 777, you instead actually set it to 000 ---- NO ACCESS --- oops!

  26. Terence
    Member
    Posted 3 years ago #

    If you simply set permissions without knowing if you're on a DSO or suPHP machines, you could be in a world of pain. If you set 755 under SuPHP, the permission used is "7" and 777 under DSO the permission used is "7" so in the case of 755 on SuPHP verses 777 on DSO, it is exactly the same thing! If you want to set something to 777, you set it to 755 on SuPHP. If you actually set it to 777, you instead actually set it to 000 ---- NO ACCESS --- oops! And this doesn't solve the problem for everyone, especially those on suPHP machines like me.

  27. Sreejesh
    Member
    Posted 3 years ago #

    I had the same issue, then i deleted "Upgrade" folder and recreated it wil CMOD 777 but now i get enew error message Could not copy file.: /public_html/wp-admin/css/theme-editor.dev.css

  28. Terence
    Member
    Posted 3 years ago #

    srj.cooldude -- is it a DSO or suPHP machine?

  29. notfarnow
    Member
    Posted 3 years ago #

    Worked for me:
    1. Login to your web host control panel:
    http://www.mysite.com/cpanel (if you have cpanel)
    FTP DIDN'T WORK
    2. open the file manager
    3. navigate to the wp-content folder
    4. delete the upgrade folder
    5. create a new folder called upgrade
    6. change permissions to: chmod 777
    7. go back to wordpress admin and upgrade plugins.

    Ta da!

  30. Terence
    Member
    Posted 3 years ago #

    @notfarnow -- if its a DSO server, it may help, if its an SuPHP server, it won't help at all, in fact it will make it worse.

Topic Closed

This topic has been closed to new replies.

About this Topic