WordPress.org

Ready to get started?Download WordPress

Forums

3 problems with new WP (12 posts)

  1. dudzislaw
    Member
    Posted 6 years ago #

    hello everybody!

    I have a problem with my WP after upgrading 2.3.3 WP to 2.5 or 2.5.1 (the same database and problems):

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /wp-includes/widgets.php on line 1337
    
    Warning: Invalid argument supplied for foreach() in /wp-includes/widgets.php on line 1337
    
    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/widgets.php:1337) in /wp-includes/pluggable.php on line 694

    Does anyone have any suggestions how can I resolve my problems? :)

  2. adam-s
    Member
    Posted 6 years ago #

    I would check your RSS widget in admin->design->widgets to make sure the settings are right or there period. You could also try turning this widget off to see if it helps.

  3. dudzislaw
    Member
    Posted 6 years ago #

    You're right, maybe this is it <->

    Fatal error: Cannot use string offset as an array in /wp-includes/widgets.php on line 1023

    but this widget was turned off...

  4. adam-s
    Member
    Posted 6 years ago #

    Is it totally removed from the side bar?

  5. dudzislaw
    Member
    Posted 6 years ago #

    before You've asked it was turned off (this RSS 1 widget)

    any sidebar, widget and plugin is working now.

  6. adam-s
    Member
    Posted 6 years ago #

    A possible fix might be http://wordpress.org/support/topic/169107?replies=6

    "Stick this in your theme's functions.php file:
    delete_option('widget_text');"

    "After you can see the blog and login again, remove the above line"

    You might give it a shot as it looks alot like the problems you are having.

  7. dudzislaw
    Member
    Posted 6 years ago #

    nothing better.

    maybe I'll try to do completely new install? ;)

  8. Joni
    Member
    Posted 6 years ago #

    No need to throw the baby out with the bathwater. Just do another UPGRADE but this time, delete the unwanted files from your server first. THEN upload the fresh files. That way there's no chance of file corruption. (Well, there's LESS chance of it.)

    So:

    delete these folders on your server:
    /wp-admin
    /wp-includes

    delete all the *.php files from your WP root, EXCEPT
    wp-config.php

    Also DO NOT DELETE:
    .htaccess
    robots.txt

    Rename your /plugins folder so WP can't find the plugins .. you can rename it back after the upgrade.

    Point your browser to the upgrade script (located at /wp-admin/upgrade.php) and all should be fine.

  9. dudzislaw
    Member
    Posted 6 years ago #

    It doesn't work :]

    Maybe I should manualy change some "autoload" values from "yes" to "no" in my database in the table "wp_options"? What do You think about this solution?

  10. lionel1
    Member
    Posted 6 years ago #

    I've been trying to upgrade to the latest WordPress 2.5.1.

    I've tried the Automatic upgrade that didn't work.

    So now I'm tying the manually upgrade. But I got stuck on this part:-

    "The wp-content folder requires special handling, as do the plugins and themes folders. You must copy over the contents of these folders, not the entire folder. Copying the entire folder overwrites all your customizations and added content. Also take care to preserve the content of the wp-config.php file in the root directory."

    Anyone out there who can give me a more detail explanation about this? Thanks.

  11. gaulix
    Member
    Posted 6 years ago #

    Hello, sorry for my bad english. Same error in my blog after upgrade to 2.5.1. I resolve the problem with these steps :

    - connect admin
    - go to theme->widgets
    - remove all widgets of side bar
    - save

    The error disapears.
    The new value of "wp_options->widget_rss" is now : a:0:{}

    Hope helps you...

  12. Mattnh
    Member
    Posted 6 years ago #

    I tried all these steps but can not even log into my admin.
    Re-installed the whole thing again and still no luck.
    This is what I get:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in \wp-includes\widgets.php on line 1337
    
    Warning: Invalid argument supplied for foreach() in \wp-includes\widgets.php on line 1337
    
    Warning: Cannot modify header information - headers already sent by (output started at \wp-includes\widgets.php:1337) in \wp-includes\pluggable.php on line 690

    Help?

Topic Closed

This topic has been closed to new replies.

About this Topic