WordPress.org

Ready to get started?Download WordPress

Forums

2.9.1 upgrade failed and Fatal Error Memory Messages (10 posts)

  1. lotusflwr
    Member
    Posted 4 years ago #

    Hi All,

    I had a problem upgrading to wp 2.9.1, I was doing an automatic upgrade and I didn't disable my plugins first. I kept getting all of the memory error messages. I changed the size of php.ini file to 64 MB and added a line: php_value memory_limit 12M to the .htaccess file. Now I keep getting messages like below, but the line # keeps changing. I can't access my admin area.

    Is it still possible to do a backup and a manual install? Or how else can this problem be fixed? Thanks for a reply.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in public_html/blog/wp-admin/includes/user.php on line 663

  2. jonradio
    Member
    Posted 4 years ago #

    If your 12M number in .htaccess had actually worked, you would really be in trouble as that restricts WordPress to 12MB, and you were failing on 32MB!

    From the Codex FAQ @ http://codex.wordpress.org/FAQ_Working_with_WordPress

    Increase the amount of memory a PHP script may consume. Note: If using a shared hosting service, you may need to ask your host to increase the limit.

    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define('WP_MEMORY_LIMIT', '64MB');)

  3. lotusflwr
    Member
    Posted 4 years ago #

    Thanks for the suggestions, I'll give them a try.

  4. lotusflwr
    Member
    Posted 4 years ago #

    Why is there all of a sudden a need to increase the memory?

  5. lotusflwr
    Member
    Posted 4 years ago #

    Well, that didn't work. Same error message/problem. Any other suggestions out there?

  6. jonradio
    Member
    Posted 4 years ago #

    Did you try:

    If using a shared hosting service, you may need to ask your host to increase the limit.

  7. lotusflwr
    Member
    Posted 4 years ago #

    Thanks for all your help. My web hosting service helped me finally resolve the issue...yea!

  8. bechte
    Member
    Posted 4 years ago #

    What was the result, how did they fix it?

    I have the same problem and would like to know about the resolution.

    EDIT: Raising memory_limit to 64M has fixed the problem. Thanks!

  9. indimag
    Member
    Posted 4 years ago #

    I haver the same issue too and would love to know how to resolve this . Plugin author is not much of a help. I have disabled this plugin but it still causes issues in my RSS feed

    Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 55444149 bytes) in /nfs/c02/.../indimag.com....plugins/wordpress-backup/WordpressBackup.php on line 159

  10. Icethrill
    Member
    Posted 4 years ago #

    define('WP_MEMORY_LIMIT', '96M');

    Put this in your wp-config.php

Topic Closed

This topic has been closed to new replies.

About this Topic