WordPress.org

Ready to get started?Download WordPress

Forums

[closed] 2.8 Problems and Solutions (FAQ) (112 posts)

  1. rolandbaker
    Member
    Posted 4 years ago #

    I agree that the 2.8 download should be removed from the WordPress site and especially the "upgrade available" from the admin. control panel.

    I'm working on a new install. So far the main issue is Tags not being available when I create a Post. I get "No Tags Found!", even though they've been created.

    I see the mention of HyperDB as a possible culprit. How do I check for this? I'm hosting on GoDaddy, problem is consistent with latest versions of FireFox, Safari & Opera (Mac). Hopefully this can get worked out.

  2. jockoe
    Member
    Posted 4 years ago #

    I can get drag n drop to work, but only if I change the screen options setting EVERY time I want to use it.

    I need to click "Disable accessibility mode" for drag n drop to work. If I click "Enable accessibility mode", I can no longer drag n drop.

    Question #1: Is this backwards? It seems I would want to "enable" to use it.

    Question #2: Is there a way to save this setting so I don't need to manually set it every time?

  3. Jonas Grumby
    Member
    Posted 4 years ago #

    @ jockoe

    "Enable Accessibility Mode" is supposed to disable drag and drop. Why you have to disable it every time is something I can't help you with.

  4. Ale Urrutia
    Member
    Posted 4 years ago #

    Hi, I have a big problem since 2.8 update:
    When I add a new post this doesn't shows on the home page, just shows the previous post (while use 2.71), now you can access to post pages, but not trough my home blog.

    You can view the last two posts clicking on post 1 and Post 2, but if you check the home page it doesn't shows.

    Any idea? thanks

  5. YOUAREtehSCENE
    Member
    Posted 4 years ago #

    its my categories that are going away automaticaly, I retype them to what bands go where, and they go thru, then all of a sudden they go away again!

  6. Jonas Grumby
    Member
    Posted 4 years ago #

    Well I think all you can do is try the instructions on page 1 of this thread, or try downgrading, which is something I haven't tried.

  7. rjhayton
    Member
    Posted 4 years ago #

    I've tried as many of these things as I am (technically) able to... The problem for me is that I CAN add pages or posts, but I CAN'T add any content to them via the editor... any suggestions welcome.

    I'm getting this same problem which no one answered for djd above. I have no plugins activated either. This is not an upgrade issue as I installed 2.8 for my first wp install at my new site. I blogged at wp.com for years before and have pretty much completed my import from my wp.com blog.

    Any suggestions when there is no box to type in at all for adding posts? I can't see a list of my posts either under Posts > edit.

  8. xing7
    Member
    Posted 4 years ago #

    Thank you, finally my drag and drop widget works now....

  9. rjhayton
    Member
    Posted 4 years ago #

    So I tried this: "3. Delete wp-admin and wp-includes directories and upload fresh copies from a new(important) install package or reinstall automatically" that didn't help. I have no plugins activated. I still have the following issues:

    1) No posts display under Posts > Edit. I get post counts of how many published, draft, etc., but no post titles that I can edit.

    2) Trying to Add a new post gives me no edit box HTML or WYSIWYG, nothing.

    3) No categories show up under Posts > Categories. I get category counts but no titles that I can click on to edit.

    I do see Post tags, and I also can see and edit pages just fine. I've tried IE and Firefox to no avail. I recently installed 2.8 on my site. I never had wp.org before so this isn't an upgrade to 2.7.

    I've tried automatically reinstalling but that never completes. I then manually deleted wp-includes and wp-admin and from a fresh wp download I copied all the files from those folders back in to my site. Same problems as before. I am not using any plugins.

    What else can I do? I'm a newbie to using wp.org, but have been using wp.com for years.

  10. rjhayton
    Member
    Posted 4 years ago #

    Okay I figured out my issue the one similar to djd's issue back on page 2. I have 1&1 as my host, and there was a fix mentioned at this link: http://codex.wordpress.org/Core_Update_Host_Compatibility which solved my problems. This particular issue is explained in more detail here. If you don't have 1&1 still see if there is some other issue with your host and its compatibility with the new WP.

  11. Smashingkris
    Member
    Posted 4 years ago #

    If all that fails try this link http://tinyurl.com/ntml96
    Worked fine for me.
    I'm with 1and1, they said it's a problem on my end. After couple of hours, i deleted the wp-folder and wp-includes folder and re-uploaded them back. Worked fine :D

    follow this link for step by step details http://tinyurl.com/ntml96

  12. Jonas Grumby
    Member
    Posted 4 years ago #

    1and1 gives you a modified version of WordPress, which in my opinion was screwed up before the release of 2.8. A friend asked me to help with his site on 1and1 months ago, and it was so different from a normal WordPress installation that I advised him to switch hosts, which he did, and now his site is fine.

    The people at 1and1 should listen to the old adage "If something isn't broken, don't try to fix it."

  13. qsch
    Member
    Posted 4 years ago #

    When I try updating automatically I am getting errors...

    Warning: Cannot modify header information - headers already sent by (output started at /home5/theoldfo/public_html/bequiablog/wp-config.php:47) in /home5/theoldfo/public_html/bequiablog/wp-includes/pluggable.php on line 391

    Warning: Cannot modify header information - headers already sent by (output started at /home5/theoldfo/public_html/bequiablog/wp-config.php:47) in /home5/theoldfo/public_html/bequiablog/wp-includes/pluggable.php on line 391

    Don't know what to do. Any advice would be much appreciated...I think it best to fix whats causing those errors before I try updating.

  14. qsch
    Member
    Posted 4 years ago #

    I checked on the pluggable page and on the 391 line it states

    "status_header($status); // This causes problems on IIS and some FastCGI setups
    header("Location: $location");"

    Please help! I think I am supposed to change the location there for header or something were it says location as it says it gives problems.

  15. Jonas Grumby
    Member
    Posted 4 years ago #

    Have you tried the suggestions on the first page (deactivate all plugins, etc.)?

  16. Ale Urrutia
    Member
    Posted 4 years ago #

    My cache problem was fixed just commenting on my wp-config.php the following line:

    define( 'WP_CACHE', true );
  17. qsch
    Member
    Posted 4 years ago #

    yes I deactivated all pluggins before I tried to upgrade! Should I maybe reinstall the includes from the current version I am running before I upgrade? Where can I get current version wordpress 2.3.2? Any suggestions?

  18. qsch
    Member
    Posted 4 years ago #

    Ok I reinstalled the includes from a new version of 2.3.2 WP. Now I am getting

    Fatal error: Class 'Translations' not found in /home5/theoldfo/public_html/bequiablog/wp-includes/l10n.php on line 408

    I am lost what to do and put back all the includes from my backup so that I could get the site back up.

  19. Jonas Grumby
    Member
    Posted 4 years ago #

    @qsch I think you should do a manual install of the latest version.

  20. dianelevin
    Member
    Posted 4 years ago #

    FYI, I'm using the Thesis theme and was able to resolve my own drag-and-drop issue with widgets by upgrading to the latest version of Thesis. In my case the plugins were all just fine; the necessary change was to the theme I'm using.

  21. WraithKenny
    Member
    Posted 4 years ago #

    This isn't showing up as sticky for some reason, and it took me 4 weeks to find it.

    This should be stickied under trouble shooting also.

  22. rshartist
    Member
    Posted 4 years ago #

    Any suggestion about unable to edit in quick edit fix. 2.8.1 version have same problem. I can't use quick edit.

  23. mrmist
    Forum Janitor
    Posted 4 years ago #

    Since this seems to be the 2.8 stickypost, I'll add to this that the editing of comments in 2.8.2 will cause author urls to vanish. The bug has been patched and the fix will appear in 2.8.3 (or 2.9 whichever is first.)

    Meanwhile it may be safest to avoid editing comments.

  24. brianan
    Member
    Posted 4 years ago #

    seems more or less, Oops more not less people are having problem with 2.8., believe wp.org should look into this before they release any upgrade in future. i am also going to downgrade to 2.7 series which i found more stable and reliable.

    cheers to all bloggers
    BRIAN

  25. bishopj
    Member
    Posted 4 years ago #

    Not sure where to post this, so I am putting it in couple of spots as the issues this post addresses are popping up all over the place.

    Firstly, for those that can't drag and drop widgets, and can't get the screen options menu to respond, you can turn on the accessibility mode manually by logging into the admin panel and entering (your equivalent of):

    http://myblog.com/wp-admin/widgets.php?widgets-access=on

    Secondly, I have been doing some debugging of WP2.8.3 because my fresh (non upgrade) out of the box install of WP 2.8.3 on W2003/IIS6/MySQL 5/PHP 5 with no plugins and default theme and Gears NOT installed in any browser, failed to display a fully functional admin panel for a number of screens. Somethings like Edit worked in FireFox, but not in IE 7 and IE 8. Worse, the screen options menu would not display on any screen, so the option of setting up widgets using the add link was not available.

    In IE7, if you deleted the browsing cache of all files (noting else), the post edit panel, for example, would display correctly (with all the tiny MCE buttons) but once you publish the post, the post content became white space and the MCE buttons would vanish. This then became a permananent problem for new posts and editted old posts. Delete the history again, and you get one ok post edit, then the problems returns after publishing/updating.

    Analysing what was happening showed that when the error occurred an object or function defined in a script referenced by the load-scripts.php call was seemingly not present.

    Various other behaviours on other screens showed similar causes...So I turned on the debuggers on the server and one of the PC's on my network and loaded the pages through the debuggers and took snapshots of the browser cache in IE7 before and after various operations to see what was going on.

    In summary I ended up fixing everything (except the drag and drop widgets), including the non-displaying screen-options menus by changing the caching rule in the header of the page generated by load-scripts.php to "no-store". As follows:

    1. Locate the file "\wordpress\wp-admin\load-scripts.php"
    2. Open it in a text editor visual studio or equivalent is preferred, but notepad will do. DO NOT USE MS_WORD or similar word processing tool.
    3. Locate the following line:
    header("Cache-Control: public, max-age=$expires_offset");
    4. Comment this line out so it looks like this:
    /* header("Cache-Control: public, max-age=$expires_offset");
    */
    5. Add in the following line
    header("Cache-Control: public, no-store");
    6. Double check that you have written the above line EXACTLY as shown.
    7. Save the file
    8. Now go to your browser and delete all browser file history (sorry, but this is essential or you won't see the fix.). On IE 7 you do this by:
    a. From the menu bar: Tools/Internet Options
    b. Select the General tab
    c. Under browsing history choose "delete"
    d. On the window that opens, choose "Delete Files"
    e. Confirm and close windows
    f. Close ALL open browsers and restart the browser.

    So what is going on?

    Well first it seems to me that the load-scripts header is wrong anyway (but that should not be causing the problem). As far as I can see, the code that generates the load-scripts line always adds a random string so that in theory the file reference is unique each time. Hence there is no need to set the browser cache to store the scripts until sometime in 2010, as the scripts reference is different with every call. Having said that, the scripts are pretty small anyway, so compared to an image, the performance gain from caching them is pretty marginal.

    BUT given the reference is unique, it should not be causing the problem that the above solution fixes - but it is definately the case
    that the IE 7 and 8 are caching the script as instructed in original the header, but NOT getting new copies of the scripts when the same page is executed, even though the calling line is notionally different because of the random string added to the ver parameter. Directly instructing the browser NOT to store the scripts file under any circumstances solves the problem.

    Miraculously this fixes practically every display problem in the admin-panel (except for the dragging and dropping of the widgets) - but since the screen options menu is now available you can use the add link instead.

    I will post this in the dev blog as well so that someone who know what they are doing (ie. from the dev team), rather than me who is not really a PHP programmer can look into it.

    Regards
    Jonathan Bishop
    Bishop Bhillips Consulting

  26. littlecuriosity
    Member
    Posted 4 years ago #

    I keep getting this warning when I try to upgrade wordpress, and some plugins don't be activated like they used to like wp-navi

    Warning: copy(/home/artygirl/public_html/wp-content/upgrade/wordpress-mu-2.8.4a/wordpress/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: No such file or directory in /home/artygirl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 131

    Please help I really don't want to reinstall wordpress, I've tried everything, but can't figure out whats gone wrong? This a fresh install too!

    Thanks
    Judi

  27. littlecuriosity
    Member
    Posted 4 years ago #

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2482873 bytes) in /home/artygirl/public_html/wp-includes/http.php on line 1327

  28. efolgate
    Member
    Posted 4 years ago #

    I am having an issue with the widgets, but it's not the "drag and drop" issue. My text box widget is completely gone from my list of widgets in the dashboard. I think it disappeared when I upgraded from 2.7 to 2.8. But since then, i've upgraded to 2.8.4.

    Does anyone know how to get it back? I am running the Thesis theme. I went to default theme, no luck. Disabled all of my plugins, no luck. I have heard that it's a database issue, and it's being hidden, but I am not good with MYSQL and i wouldnt know the command to get it back. Any help would be really appreciated.

  29. Li-An
    Member
    Posted 4 years ago #

    My experience with upgrading WP 2.7.1 > 2.8.4
    As for a lot of people, Tags don't work any more (there are not shown and it's impossible to add one). The RSS from WordPress.org in the admin page do not work. This update was made with all plugin desactivated.

    If I try a fresh installation of 2.8.4, everything works good. So it's the update that fails...

  30. aerodi
    Member
    Posted 4 years ago #

    Mi Widgets are all scrambled up, impossible to use: screen capture

    I have tried enabling accessibility mode in Screen options directly or by using http://www.myblog.com/wp-admin/widgets.php?widgets-access=on

    I have not solution and I am quite baffled. This also happened to me on another WP blog I updated.

Topic Closed

This topic has been closed to new replies.

About this Topic