WordPress.org

Ready to get started?Download WordPress

Forums

2.8 loading slow. Times out. (32 posts)

  1. Mobster
    Member
    Posted 5 years ago #

    Anyone else experiencing time outs and/or slow load times with 2.8?

    Edit: I have tried everything here http://wordpress.org/support/topic/279132?replies=59

  2. DragonDreamz
    Member
    Posted 5 years ago #

    YES. And it seems to be getting worse as time goes on. Today it's taking me three or four refreshes to get any page to load at all, and admin/dashboard is agonizing as well.

    When I first upgraded, all seemed fine. It seems that as time progresses, however, this problem continues to get worse.

    I've also checked with my host to see if they're having server issues, or whatever, that might affect the mySQL end of things, but I really don't think so, as I'm seeing others report the same problem with 2.8.

    http://www.gazehound.com , should anyone like to check things from their own ISP.

  3. philonous
    Member
    Posted 5 years ago #

    I'm experiencing this also. I "upgraded" to 2.8.1 beta2 and the problem persists. It gets only slightly alleviated when I turn off all plugins.

    I do get slow mysql errors, but I cannot find any particular pattern to them. My hosting company, bluehost.com, insists that the mysql server is running fine, and at this point, I find it difficult to refute their point.

    I have analyzed and optimized all tables, but both admin and the blog itself are still running very slowly.

    This started happening very suddenly last week, about three weeks after I upgraded to 2.8.

    I did the upgrade automatically via the dashboard. I upgraded to 2.8.1 b2 manually.

  4. DragonDreamz
    Member
    Posted 5 years ago #

    For the past hour or so, in three different browsers, I've been disabling one plugin at a time. The only one that seems to have made SOME difference is WP-Stats-Dashboard. The pages are still slower than "normal" to load, but at least they are loading in all three browsers.

    Does anyone else have that plugin installed, and if so, do you find it makes any difference?

    Philonous, I also received a reply back from my host company that their mySQL platform is working fine. The tech who emailed me, in fact, has a WordPress 2.8 site running on the same server that is not having any speed problems.

    I have not tried either of the beta versions, I'm still running on "straight eight". :-) It sounds like the bog-down happened right around the same time for both of us.

  5. philonous
    Member
    Posted 5 years ago #

    I do not have WP-Stats_Dashboard installed. This seems to be totally independent of widgets at this point, frankly. After all, my admin pages are loading very slowly, too.

    I noticed that my wp_options table is rather large at 1.2 Mb. Examining it, I saw A LOT of option entries like this one:
    rss_2d92202fd484b4462333995613f40f74_ts

    I have also noticed that the WordPress RSS feed entries on the dashboard front page are loading VERY slowly.

    Furthermore, the plugin edit page either fails to load or reports an error when I try to edit a plugin's source.

  6. philonous
    Member
    Posted 5 years ago #

    I should add that I also noticed that my dashboard reports 268 blog entries while phpmyadmin reports 795 entries in the wp_posts table. (I do not have 500 drafts.)

  7. DragonDreamz
    Member
    Posted 5 years ago #

    I've also certainly got various issues playing against the site speed, but disabling that one plugin did seem to help "some". It may be more because it calls out to post data from another server than anything. ??

    I'm also now getting "Error establishing a database connection" errors intermittently.

    I think I may be experiencing a double whammy -- both something in WP 2.8 and something on my host server acting against each other.

  8. DragonDreamz
    Member
    Posted 5 years ago #

    AND at around 3pm eastern time my site went down completely, the Error Establishing thing now appears complete.

    I've got a support ticket in to my host.

    Good luck, all!

  9. andrewacomb
    Member
    Posted 5 years ago #

    I upgraded to WordPress 2.8 and I am also experience extremely slow load times in the dashboard and on the web site.

    I disabled ALL plugins, but I really didn't see a noticeable increase in speed.

    Seriously thinking about downgrading. Just wish I could fix this!

  10. bh_WP_fan
    Member
    Posted 5 years ago #

    Try increasing your memory_limit, changing your theme to the default theme, renaming your plugins folder, make sure you're running PHP 5 and MySQL 5 as older versions of these can make WordPress run slow. (Do all of this at the same time, it won't do to rename your plugins folder, and then rename it back, then change your theme, etc., your theme should be default and your plugins should be renamed at the same time, etc.)

    Also run a repair and optimization on each of your tables in your database(s): http://helpdesk.bluehost.com/kb/index.php/kb/article/000496

    Ways to increase your memory limit:
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define('WP_MEMORY_LIMIT', '64MB');)

    For any who haven't looked into this: http://wordpress.org/support/topic/279132?replies=59 look into it.

    You can also try browsing these forums for what others who had this problem did.

    If all of the above fails, contact your host or revert back to 2.7 for the time being.

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I should add that I also noticed that my dashboard reports 268 blog entries while phpmyadmin reports 795 entries in the wp_posts table. (I do not have 500 drafts.)

    Not unusual. Revisions take a post. So do any uploaded images or files (anything in the Media library). So do Pages.

    wp_posts holds lots of things that are not "posts".

  12. philonous
    Member
    Posted 5 years ago #

    None of the above worked for me. I tried increasing memory to 64 Mb, and the server refused it. (26 Mb is the limit allowed.)

    I am now almost certain that there is some detritus in either my .htaccess files or in my config file that is causing the problem. I am also wondering if this is a problem with the automatic upgrade feature introduced in 2.6. I have upgraded automatically from 2.6 to 2.7 and to 2.8.

    These are the slow mysql query logs that were generated yesterday:

    # Mon Jun 29 17:15:02 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    UPDATE <code>wp_usermeta</code> SET <code>meta_value</code> = 'classic' WHERE <code>user_id</code> = 2 AND <code>meta_key</code> = 'admin_color'
    
    # Mon Jun 29 15:08:44 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT post_modified_gmt FROM wp_posts WHERE post_status = 'publish' AND post_type = 'post' ORDER BY post_modified_gmt DESC LIMIT 1
    
    # Mon Jun 29 12:00:02 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (854,770,833,630,419,758,812,619,772,810,806,800,795,791,785,751$
    
    # Mon Jun 29 12:19:54 2009
    # Query_time: 18  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT *,
      <code>TABLE_SCHEMA</code>       AS <code>Db</code>,
      <code>TABLE_NAME</code>         AS <code>Name</code>,
      <code>ENGINE</code>             AS <code>Engine</code>,
      <code>ENGINE</code>             AS <code>Type</code>,
      <code>VERSION</code>            AS <code>Version</code>,
      <code>ROW_FORMAT</code>         AS <code>Row_format</code>,
      <code>TABLE_ROWS</code>         AS <code>Rows</code>,
      <code>AVG_ROW_LENGTH</code>     AS <code>Avg_row_length</code>,
      <code>DATA_LENGTH</code>        AS <code>Data_length</code>,
      <code>MAX_DATA_LENGTH</code>    AS <code>Max_data_length</code>,
      <code>INDEX_LENGTH</code>       AS <code>Index_length</code>,
      <code>DATA_FREE</code>          AS <code>Data_free</code>,
      <code>AUTO_INCREMENT</code>     AS <code>Auto_increment</code>,
      <code>CREATE_TIME</code>        AS <code>Create_time</code>,
      <code>UPDATE_TIME</code>        AS <code>Update_time</code>,
      <code>CHECK_TIME</code>         AS <code>Check_time</code>,
      <code>TABLE_COLLATION</code>    AS <code>Collation</code>,
      <code>CHECKSUM</code>           AS <code>Checksum</code>,
      <code>CREATE_OPTIONS</code>     AS <code>Create_options</code>,
      <code>TABLE_COMMENT</code>      AS <code>Comment</code>
      FROM <code>information_schema</code>.<code>TABLES</code>
      WHERE BINARY <code>TABLE_SCHEMA</code> IN ('minoofar_wrdp1')
      LIMIT 250 OFFSET 0

    Are there any clues in here? Or, should I just wipe it out and start from scratch? I have exported the blog as an xml file. I guess all I got to do is make sure that I keep the uploads folder.

  13. bh_WP_fan
    Member
    Posted 5 years ago #

    Bluehost will allow you to increase the memory_limit up to at least 128 last I heard (Which was about 2 weeks ago). If it isn't updating, you may want to submit a help request to Bluehost support and see if they can help you figure out why. From my experience it has been a problem with the php.ini file not existing where it should be or, if you are using the single php.ini mode (Through PHPConfig in the cPanel), there is often a conflicting .htaccess file in a subdirectory.

  14. philonous
    Member
    Posted 5 years ago #

    Well, I regenerated a php.ini file from the cpanel for fastcgi php configuration, I changed the memory limit to 64M, I copied the file to the root wp folder, but absolutely nothing changed. It's still slow!

  15. philonous
    Member
    Posted 5 years ago #

    This is today's slow sql log:

    '# Tue Jun 30 12:00:16 2009
    # Query_time: 3 Lock_time: 0 Rows_sent: 0 Rows_examined: 0
    use minoofar_wrdp1;
    SELECT YEAR(post_date) AS year, MONTH(post_date) AS month, count(ID) as posts FROM wp_posts WHERE post_type = 'post' AND post_status = 'publish' GROUP BY YEAR(post_date), MONTH(post_date) ORDER BY post_date DESC'

  16. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Query_time: 3

    Why don't you look for queries that are actually taking a long time? 3 seconds is nothing. If that is even in "seconds" there.

  17. bh_WP_fan
    Member
    Posted 5 years ago #

    Most queries happen very quickly, taking even less than a second. Though longer queries aren't necessarily a problem, they can become one. I see one with a query time of 18. If you are on a php5 and mysql5 server I don't see how any version of wordpress from 2.6.x to 2.8.x could run so much slower in and of itself. A little slower, maybe, but not a lot.
    Have you tried all the above given suggestions?

    Take a look at some of these, too:
    http://codex.wordpress.org/WordPress_Optimization/Cheat_Sheet
    http://wordpress.org/support/topic/197243?replies=2
    http://wordpress.org/support/topic/165238/page/3?replies=80#post-898872
    http://www.graysonadams.com/?p=238

  18. philonous
    Member
    Posted 5 years ago #

    I am left to conclude that the problem is php optimization because even if the longest mysql query took 2 seconds yet the page took 10 seconds to load, then there is a problem processing all the scripts.

    I have tried just about everything: changing themes, deactivating all plugins, repairing and optimizing all database tables and even resetting php settings from my control panel. All to no avail.

    I'll upgrade manually to 2.8.1 final. If that doesn't fix the problem, I'll export my database, wipe out the wp directory and do a fresh install. If that doesn't work, I guess, I'll be looking for another hosting company.

  19. bh_WP_fan
    Member
    Posted 5 years ago #

    Try a fresh install in a different directory and see what happens with that, too. I'm just curious if it is something in the database that is causing the slowdowns.

  20. philonous
    Member
    Posted 5 years ago #

    So, it looks like the problem is that my php scripts are taking a long time to load. Here is what firebug captured when I entered my dashboard. I just disabled google gears (turbo), to no effect.

    You can see the firebug screen cap here:
    http://minoofar.com/long_get.png

  21. AndrewBanchich
    Member
    Posted 5 years ago #

    YES! I've been seeing this for a while now and was wondering what the problem is! I have been using http://www.webpagetest.org/ like crazy constantly disabling one plugin testing, disabling another, retesting, repeating. It seemed to be working for a day and my site was taking about 10-13 seconds to load, but then i added a couple more plugins and it's back to anywhere from 20-50 seconds to load, even with WP-Super Cache (w/ Gzip), and several other load time decreasing plugins running.

    I called GoDaddy many times thinking there was something wrong with the server and I got many different answers, from "you have too many http requests" to "too many images" to "you have to optimize your database." I am getting fed up with this. I just want WP to load like any other site!!!

    My admin pages also take a very long time to load, sometimes over a minute! What do I do???

    I would try to do a clean install but I am not familiar with backing up wordpress so I don't want to attempt to do that and then restore all my posts and content, because I am too afraid it would not work and everything would be gone...

  22. bh_WP_fan
    Member
    Posted 5 years ago #

    philonous, try enabling fast cgi for your php or, if it is already enabled, try disabling and see if it changes your site for the better one way or the other. Also, how did test installs work?

  23. philonous
    Member
    Posted 5 years ago #

    Ok. After some testing the patience of the wonderful folks at Bluehost, I found the culprit: the Google Adsense Manager widget
    http://wordpress.org/extend/plugins/adsense-manager/

    As the page says, we are well advised to upgrade to Advertising Manager.

    I discovered this purely by a fluke. I rebuild my blog in a test folder, and activated this plugin first. Everything was fine, until about the third pass through the admin pages. It's very bizarre, but the effect is not really immediate, which is why no one could seem to pin point it.

    This is not my final answer, but I have a feeling it will be.

    Best of luck.

  24. AndrewBanchich
    Member
    Posted 5 years ago #

    I had slow loading problems too and used Advertising Manager when I did. When I deactivated it the site seemed to load extremely fast, and seems to still load very fast even after I activated it again. Very strange.

  25. sb@freerbutler-gds.co.uk
    Member
    Posted 5 years ago #

    i've been using WP2.7 and have been having major performance issues. Loaded Google Analytics which really slowed things down and added tons of entries to the wp_options table in the database within a few hours. I deleted the plugin and also had to manually removed all the rows of data left over the wp_options table and the site sped up again.
    I then tried out the wordpress stats plugin and this also slowed things down significantly and placed a bit of javascript in the footer which screwed up the formatting. So i've since deleted this plugin as well.
    Still on the look out for a basic stats plugin that doesn't impede performance!
    Anyway, its worth browsing your wp_options table to delete any unrequired rows of data that are slowing the site down. Be sure to make a quick backup of the wp_options tables first though (just in case!)
    Hope this helps, apologies if i'm merely "pointing out the obvious", i'm fairly new to all this and learning the hard way most of the time :-)

  26. delectual
    Member
    Posted 5 years ago #

    I was having the same problem. No pages would load.

    I deleted all the cookies, logged in and it worked for about 1 minute and then no pages would load again. I renamed the plugins folder and suddenly everything started zipping right along. I renamed the plugins folder back to "plugins" and all plugins were deactivated. Pages still loaded.

    I came to the conclusion that the problem was WP Stats. I am really bummed because I like that program and use it all the time. I hope they come out with a fix for it soon...

  27. salmanager
    Member
    Posted 5 years ago #

    I have experienced similar issues with intermittent performance and researched many such other cases with users. Almost all the time it is the related to a plugin not being compatible with the new upgrade, with the remainder being hosting issues.

    For my own case, I have discovered that the change in default transport type in wordpress 2.8 from CURL to FSOCKOPEN was causing conflicts with some plugins (wp-forecst) in my case. I resolved it by first upgrading the plugin (which now offers a choice of transport) as well as upgrading to 2.8.1 which takes the default transport back to CURL.

    It is possible that some of your plugins use CURL and are thus causing timeouts on your db occasionally.

    Read more here including a workaround for "mysql has gone away" messages: http://wordpress.org/support/topic/281079?replies=3

  28. philonous
    Member
    Posted 5 years ago #

    As plugins become essential to the success of WP, WP really needs to do a better job of imparting awareness of such issues to plugin developers.

    Alternately, we users must delay upgrading until we are sure that every single plugin we have has been certified to be compatible with the latest WP version. Unfortunately, there seems to be no tool that allows us to get this information at a glance in our dashboard.

    What salmanager mentions seems to be the issue. After a lot of back and forth with tech support at Bluehost, this seems to be the only issue. I am now on 2.8.1, upgraded to Advertising Manager, and now enjoy tolerable load times.

    And, I really have to hand it to tech support at Bluehost. They were extremely patient and went beyond due diligence to follow this problem along with me until it was solved this past week.

  29. Marlimant
    Member
    Posted 4 years ago #

    Hey:
    I had been tested all the alternatives, and the plugin "No Blog Clients" fix 80% my problem. This plugin removes link elements from your WordPress header for Windows Live Writer and other blog clients using the WordPress XML-RPC interface. After this plugin, the Admin Panel of WordPress loads more fast.

    I added this: extension=curl.so in php.ini (line 597 aprox.) and help some too.

    Regards.

  30. pigneckring
    Member
    Posted 4 years ago #

    Would using the No Blog Clients plug-in cause problems if you use Feedburner with your own domain?

    In General I think the best advice is to rarely upgrade WordPress. Have an automated backup system that backs up your WordPress directory, images (probably separately), and database. A cron job shell script using mysqldump and tar works well. Have the backup run daily or weekly, depending on how active your blog is. But don't upgrade WordPress.

    When your site is hacked (if it ever is ... it's less common than you'd expect from reading the hysterical blog and forum posts on the internet), you recreate the database from the MySQL dump and then do a clean install of WordPress with the latest version (*this* is the upgrade) and copy your various settings and images in. WordPress will update the database schema if necessary. And you're done. Not much harder than doing a WordPress upgrade, but you only have to do it every two or three years, if ever.

Topic Closed

This topic has been closed to new replies.

About this Topic