WordPress.org

Ready to get started?Download WordPress

Forums

2.8 is evil (78 posts)

  1. kalin12351
    Member
    Posted 5 years ago #

    It wiped my website completely and it wiped 3 more website hosted on my server. Now really, do you test these things ? And why is it still available for auto upgrade if you see what problems people have here ?

  2. MichaelH
    Member
    Posted 5 years ago #

    Almost all problems with the 2.8 upgrade have been a result of plugins, themes, and lack of memory allocated to PHP.

    If you have backups, restore those backups.

    If necessary follow the Upgrading WordPress procedures to upgrade your blogs.

  3. figaro
    Member
    Posted 5 years ago #

    It wiped my website completely and it wiped 3 more website hosted on my server.

    No it didn't...if your sites were there and you properly upgraded, you may have problems and you may not be able to see your content until the problems are cleared, but it didn't "wipe" your sites.

  4. wolfdogg
    Member
    Posted 5 years ago #

    Actually.. it may as well have wiped mine. It blew up halfway in the middle of the install and left countless orphans in my database.

    However.. I blame my host. I got a timeout error in the middle and I believe they don't allocate the proper memory to their servers at times and that causes things like this. Easy to fix though.. blew my database away, created another.. did the install fresh.. uploaded old content. Voila.

  5. figaro
    Member
    Posted 5 years ago #

    However.. I blame my host.

    Yes...as you properly point out...that's not a 2.8 issue...that's a host issue. Personally, I would look for another host if this is a common occurrence.

  6. michaelmccarthy007@gmail.com
    Member
    Posted 5 years ago #

    I don't know about "evil" but quirky, for sure.

    Odd things don't function: preview doesn't work; I can load an image, but not resize it once it's been loaded; peculiar formatting appears in the text that has to be stripped out ....

    Being a user (a content-type person and not a coder) I think I'll sit back--take the weekend off--and watch the forums for a while before I try to do anything more on my Web site.

  7. jgbutler
    Member
    Posted 5 years ago #

    I can confirm a "wiping out" of a Website by the 2.8 auto-upgrade, and I find it hard to believe that it can be blamed on "plugins, themes, and lack of memory allocated to PHP."

    Here's what my experience was:

    1. I initiated the auto-update (from 2.7.1 to 2.8) on a WP installation in this directory (not the document root):

    /srv/www/htdocs/jbutler/tvstylebook

    2. The update stalled at the "installing files" point.

    3. All files in the following sub-directories of the document root (/srv/www/htdocs) were deleted:

    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:36 gallery2
    drwxrwxr-x+ 2 jbutler www 6 Jun 11 16:37 aspapodcast
    drwxr-xr-x 2 wwwrun www 6 Jun 11 16:37 wp-admin
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 screenlex
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 screenpedia
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 slgallery
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 ssitejoomla
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 tcfgallery
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 tvcritgallery
    drwxr-xr-x+ 2 wwwrun www 6 Jun 11 16:37 vsc
    drwxr-xr-x 2 wwwrun www 6 Jun 11 16:37 wpmu
    drwxr-xr-x 3 wwwrun www 19 Jun 11 16:37 wp-content
    drwxr-xr-x 2 wwwrun www 6 Jun 11 16:37 wp-includes

    As you can see, most of those directories have nothing to do with this particular WP installation, but they were all deleted at 16:36 to 16:37. In short, any directory with a MySQL connection was targeted! A Joomla installation, a MediaWiki installation, and so on...

    Could this rampant destruction be due to a theme or a plug-in? If so, then it seems to me that the auto-upgrade system needs to install some significant safeguards immediately.

    I should note that I am using the Atahualpa 3.3.2 theme and that I did NOT de-activate plug-ins. The plug-ins I have installed are:

    Akismet 2.2.4
    Contact Form 7 1.10.0.1
    DM Albums 1.9.1
    Exec-PHP 4.9
    Flexible Navigation 0.09
    GD Pages Navigator 3.8.1
    GLM's Category Magic Plugin 0.9.1
    NextGEN Gallery 1.3.3
    Random Image Widget 1.5
    Really Simple CAPTCHA 1.0
    WP-reCAPTCHA

    I've already posted some of this here:

    http://wordpress.org/support/topic/279130?replies=1

    There have been no response to that forum topic.

    I do NOT feel that WordPress 2.8 is evil. I have been a strong advocate of WP and have created 5 or 6 sites with it, but I was severely disappointed by the destructive power of this upgrade. If I didn't have a full-system back-up to rely on I would have been totally screwed.

  8. kalin12351
    Member
    Posted 5 years ago #

    If it's not a 2.8 issue it is definetly a 2.7.1 issue that i hope is not continued in 2.8. The websites are wiped, be sure of that. The database is ok. I don't have complete backups and I did do some modifications to the template through the web editor. The database is ok, though. But no plugins should affect a upgrade. Seriously, why would you allow such a design ? Yes, it won't have perfect OOP, with no duplicate code but this situation wouldn't happen. It's also important to have some real data safety. And I can't imagine what plugin can delete in cascade everything.

  9. rickbakas
    Member
    Posted 5 years ago #

    I don't care if it's a plugins thing or a theme thing, each time there's an upgrade we should all have to deal with so many problems. The experience should be one where we upgrade and go on with our life without having to take so much time to make it work.

    2.8 isn't evil, but it sure has made my life miserable since upgrading. It shouldn't be like this.

  10. MichaelH
    Member
    Posted 5 years ago #

    Next update, it might be wiser for users with lots of plugin installed, to read and follow Upgrading WordPress instead of doing the automatic upgrade.

  11. figaro
    Member
    Posted 5 years ago #

    I'm not yet convinced that WP is deleting other source code, but if it is, then I don't think it matters for future upgrades whether you have "lots of plugins" or just one plugin...if you have "the" plugin, or one of the plugins that causes this problem, then you've got a big problem.

  12. kalin12351
    Member
    Posted 5 years ago #

    It might be wise from you not to offer the automatic upgrade. Last time it worked fine. Or try making that kind of upgrade safe. But instead you use the same functions that are affected by plugins. At least add one transmitting boolean variablefor the downloading, unpacking, deleting, moving, etc in order not to ask plugins are asked if they have something to say during its steps. Plugins musn't be allowed to affect everything.

  13. vegasrenie
    Member
    Posted 5 years ago #

    This thread and my own past experiences with upgrading with the first and fresh release of the upgrade is exactly why I'm going to wait until 2.8.1+ before I even think about it. I've learned my lesson!

  14. Rhonda Johnson
    Member
    Posted 5 years ago #

    Oh When, oh when is 2.8.1 going to come out?

  15. miguelnetto
    Member
    Posted 5 years ago #

    just waiting for 2.8.1 - 2.7.1 back to me...

  16. ashdav
    Member
    Posted 5 years ago #

    The 2.8 upgrade firstly wiped my themes. I restored the backups and went back to 2.7.
    I made a few changes to my file structure and tried the 2.8 upgrade again, taking all appropriate action such as deactivating all plugins.
    2.8 upgraded and my home page looked fine, but every other page showed up as raw text.
    I restored the backups again, but somehow the pages were still corrupt. I looked into the files and about 10 new .php files had been added which weren't there before. All of my html tags, head tags and body tags were missing.
    I could not fix it, no matter what i did. I tried restoring the backups again but somehow my original backups of the theme was still broken.
    I ended up upgrading to 2.8 and rebuilding my whole site.
    Very annoying process.

  17. MileHighFan
    Member
    Posted 5 years ago #

    I use Atahualpa 3.3.3 by BFA WebDesign -

    None of the items below were issues previously. 2.8 is a miserable offer from WP. It not what I've come to expect. I STRONLY suggest that if you have not upgraded... don't! WP should immediately (like right now!) pull 2.8 from it's offering. I feel fortunate that I didn't have many of the problems others have reported. But none the less WP dropped the ball big time on releasing 2.8.

    - First of all 2.8 is MUCH SLOWER! With the exact same content on 2.7.1 I had page loads of less than 1 second. Now with the same content I see 10's and sometimes 20's. Only by cutting down my page content drastically was I able to obtain reasonable load times.

    - Widget Page on 2.8 lets you add widgets, but not 'insert' in between. It looks like it's going to work, but does not and an 'empty' widget holder appears at the bottom of the sidebar.

    - Left sidebar will not collapse.

    - Attempts to edit plug-ins worked once. Now any attempt to even scroll the code will cause screens to lock. You must then manually remove the widget to regain any control.

    - Widget Zip/Browse install was 'moved' (hidden) at the top of the page. Useless 'feature' to move it from where it was.

    - PHP Code which worked fine in 2.7.1 now causes memory errors.

    - The ONLY positive thing I've found in 2.8 is that they corrected the huge inability to cut/paste within widgets. This if of little use of course since the Widget Page is basically unusable.

  18. Elpie
    Member
    Posted 5 years ago #

    I had the same experience with two of my blogs. It seems that this has been identified as a bug in 2.8 and a fix has been submitted. http://core.trac.wordpress.org/ticket/10140

  19. MileHighFan
    Member
    Posted 5 years ago #

    Update: By going one at a time, deactivate and then activate I've found the following plugins don't play well with 2.8 for multiple reasons. Deactivating them allows the Widget page on 2.8 to function as in drag/drop, expand/collapse, insert. I've not yet test against the issue of total lockup when trying to view/scroll/edit plugins and/or themes. I performed no other changes but deactivating the below items. I use the theme Atahualpa 3.3.3.

    Edit: 12:20pm - Sorry I was not clear earlier. BOTH Plugin and Appearance Editors when attempted to be used locked up.

    Automatic SEO Links
    Collapsing Links
    DMSGuestbook widget - (Just the sidebar widget, NOT the whole plugin)
    Easy AdSense
    Exec-PHP
    Fun with Sidebar Tabs
    TinyMCE Advanced

    Edit: 12:13pm MST -

    I just attempted to use the 'Editor' in 2.8 after deactivating the above plugins. It still does not work. A simple attempt to 'scroll' the theme's CSS file caused an almost instant lockup of the page. A Ctrl/Alt/Del and killing the IE 7 process allowed reentry to login.

    Edit: 12:21pm MST -

    All in One SEO Pack - When this plugin was deactivated the editor for the plugin page began to work, with some delay. I reactived SEO Pack and it locked completely. Killed it again and the editor functioned again. The Appearance editor still does not function/scroll after killing the SEO Pack.

  20. SleepW
    Member
    Posted 5 years ago #

    WordPress has some quirks that can be a real PITA.

    1. After backing up, I upgraded automatically to 2.8 and had a major issue due to my existing Google Analytics plugin. I could no longer login! Thankfully I wasn't on the road so I was able to rename the plugins folder with my FTP client, this allowed me to login and then deactivate it.
    2. Not a 2.8 issue per say, but I changed my WordPress address in General Settings to test something and it basically destroyed everything - no login, no CSS, my site rendered like it was 1995. How can you allow the user to destroy his blog so easily from General Settings. Not even a warning? Why is that option there in the first place since it is so faulty? And the fix? I had to go into the table and change the record - that's totally ridiculous.
    Better error trapping would help.

    As for performance...everything works fine. Pages load very well. Please take the criticism as constructive, WordPress is a wonderful product.

  21. MileHighFan
    Member
    Posted 5 years ago #

    Update: 12:59pm MST -

    I deactivated ALL plugins and found that the Appearance Editor is still broken, not allowing you to scroll/edit. It locks up WP completely.

    I no longer have the patience to figure out what does and does not work with 2.8...

    I can only guess that if a plugin does not specifically say it works with 2.8+... don't use it.

    I think WP needs to seriously rethink the process by which they allow plugins to be developed and offered to WP users.

  22. snorky
    Member
    Posted 5 years ago #

    Well, I'm also using 2.8 and Atahualpa 3.3.3
    Fortunately for us the upgrade went well. My pages still look in tact. Apparantly although using about 20 plugins, non of them seem lethal.

    However, I can confirm that the widget section if messed up. At first the right column wouldn't unfold, but a click on the little arrow made it appear. However, if I try to add new widgets to the side bar, when picking them up and trying to drag them, the widget-title bar stretches itself horizontally over my screen, in full width. So, you can only moce it up and down but not drag it to the sidebar.

    Interesting enough the disabled plugins seem to do that correctly.

    I waited a few days before upgrading, thinking that any bad repsonses would make them decide to quickly disable the upgrade. Maybe an idea for next time?

  23. Revka Stearns
    Member
    Posted 5 years ago #

    Upgraded two blogs with no problems using the automatic upgrade button. The third blog I tried to upgrade ended up being a disaster.

    Upgrade got stuck installing files
    Ended up deleting both websites hosted in this account (they were two separate distinct websites using different URLs) - the upgrade deleted all directories and files, leaving me only cgi-bin and www folders. Thankfully, my database was spared.

    The good news is that both websites were new and in progress, but this should never have happened. Whatever is wrong, WP needs to fix ASAP and pull the upgrade until it is. I would have been furious if this had happened with my other two sites that have been around for years and have tons of content.

    As it is, I'm only angry, not furious.

  24. ashdav
    Member
    Posted 5 years ago #

    Well something rather shocking has occurred with my blog.
    You can first read about my mishaps on my post just above

    The day after this my whole web hosting account was suspended!
    I had no idea why, but after hours of waiting i got a reply to my dispute saying i was using excessive resources.
    This wasnt true. I'd done nothing out of the ordinary so i asked to see further details.
    This is what they replied with...

    You'll see from the below server log that it was WordPress on your account using excessive resources,
    photoguides.net 0.30 0.54 0.5
    Top Process %CPU 35.0 [php]
    Top Process %CPU 25.0 /usr/bin/php /home/photogui/public_html/index.php
    Top Process %CPU 10.5 /usr/bin/php /home/photogui/public_html/wp-admin/update.php

    The above shows your account using 25% of the overall CPU on the server, which is why the account was suspended.

    25% of the whole web hosts server my account was using!
    and all because of the corrupt update which broke my site.

    It's fixed now, but somethings VERY wrong with this.

  25. figaro
    Member
    Posted 5 years ago #

    No it didn't...if your sites were there and you properly upgraded, you may have problems and you may not be able to see your content until the problems are cleared, but it didn't "wipe" your sites.

    Quoting myself above...my apologies. I was very skeptical about the upgrade deleting files (other than WP files), but I'm seeing too many reports of this happening when the auto-upgrade is interrupted to simply discount it. So, I'm with others here with a call to someone at WP to:

    1. Verify whether this is a bug or not.
    2. If it is, note whether it has been fixed or not.
    3. If it has been fixed, then fine...things happen...that's the nature of technology
    4. If it is a bug and hasn't been fixed, then remove the auto upgrade link in 2.8 until it is fixed.

    This needs to be acknowledged and commented on by someone in an "official capacity" here...it's too serious a problem (again, assuming it is a WP problem) to ignore.

    Just my 2 cents.

  26. webspaceunlimited
    Member
    Posted 5 years ago #

    can anyone post me a link to a 2.7.1 download for wordpress please?

  27. figaro
    Member
    Posted 5 years ago #

    All previous releases are here:

    http://wordpress.org/download/release-archive/

  28. webspaceunlimited
    Member
    Posted 5 years ago #

    wonderful thank you :)

  29. glennhall144
    Member
    Posted 5 years ago #

    I updated to 2.8 last week. With 2.7 I was able to paste Word documents directly onto my posts and all of the colors, italics, etc. always showed up perfectly. Now, regardless of how I do it (even using the new Word paste feature), everything is black and white. Any ideas?

  30. glennhall144
    Member
    Posted 5 years ago #

    Figaro, is there a way for me to just go back to 2.7 without causing a problem?

Topic Closed

This topic has been closed to new replies.

About this Topic