WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 2.7 upgrade - Redirect Loop error (23 posts)

  1. Soulgirl
    Member
    Posted 5 years ago #

    I have just upgraded my blog at http://www.thesoulgirl.com and am receiving this error. My other blogs upgraded brilliantly...

    [quote]Redirect Loop
    Redirection limit for this URL exceeded. Unable to load the requested page. This may be caused by cookies that are blocked.

    The browser has stopped trying to retrieve the requested item. The site is

    redirecting the request in a way that will never complete.

    * Have you disabled or blocked cookies required by this site?

    * NOTE: If accepting the site's cookies does not resolve the problem, it is probably a server configuration

    issue and not your computer.[/quote]

    I have tried turning off all the plugins to no avail. Any idea what's gone wrong?

  2. Soulgirl
    Member
    Posted 5 years ago #

    As other upgrades went smoothly it may well be a permissions error with my host. I've contacted them and will update if I get it working.

    Incidentally, another upgrade failed due to a cron error... again, possible host permission problem.

    Karen x

  3. Soulgirl
    Member
    Posted 5 years ago #

    Update.. it was a permissions error. How great are Midphase for support! Sorted in 30 minutes! Go midphase :o)

    Karen x

  4. inventright
    Member
    Posted 5 years ago #

    Did they tell you what permissions they fixed? I am getting a loop as well and my Hosting company is not as helpful.

    Thanks,
    James

  5. Branch
    Member
    Posted 5 years ago #

    I have had this problem, too, with the fourth installation I upgraded (all on the same server, which makes it especially vexing), and am also waiting on very slow help from my host. Does anyone have any ideas how to fix it?

    Aside from deactivating plugins (tried) or flushing my .htaccess files (tried) or erasing and re-installing files (tried) or checking the blog url in my options table (just as it should be) or using default urls (already do).

  6. Bernard Bos
    Member
    Posted 5 years ago #

    While waiting on your host, you could try this plugin, it helped for me

    Disable Canonical Redirection
    (save as php and upload it in your /wp-content/plugins directory, then activate it)

  7. Branch
    Member
    Posted 5 years ago #

    Update: Apparently there was something in my .htaccess files that I could not edit with the interface I was using. I think the lesson here is to copy .htaccess files so as not to actually lose anything and then just delete the suckers. If it works, then rules can be added back in one at a time to make sure they're not causing any problems.

  8. Soulgirl
    Member
    Posted 5 years ago #

    I was told it was a problem with my .htaccess file being renamed to .old although I can't say I renamed it! That may well have been a wee fib... who knows *shrug*

  9. CX07
    Member
    Posted 5 years ago #

    I've had the same problem!

    I contacted my host like Soulgirl had, but my host (Lycos) weren't so helpful. Maybe it is something to do with them going out of business, i don't know...

    'Please be informed that if the Word application is directly from WordPress, you would have to contact their support for further assistance.'

    Anyway, i tried the Disable 'Canonical Redirection' Plugin and that seems to have worked!

  10. Jaap
    Member
    Posted 5 years ago #

    Hello,

    I had the same problem. The 'Disable Canonical Redirection' plugin didn't work for me but the following thing worked:

    I deactivated all my plugins and the problem was gone. So I activated plugin by plugin and tested where it went wrong.
    The plugin that I had installed called WP-lite caused the problem. When I activated and deactived it I could login again. So some plugins just aren't ready for WP 2.7 I guess.

  11. azjudy
    Member
    Posted 5 years ago #

    I had a similar problem - my hand coded .htaccess file wouldn't redirect to the www version of my domain, even though the coding was correct.

    I think there must be code written in version 2.7 that uses the setting information to create a canonical redirect (chooses whether to point to www or non-www version of your domain). I didn't have the same problem with the prior version of WordPress.

    Once I went into Settings/General and added "www." to the WordPress Address URL and the Blog address URL - the redirect stopped spinning in circles.

  12. justjohnna
    Member
    Posted 5 years ago #

    I also upgraded to 2.7 and lost my main page to the redirect loop.

    My main page is a static page, but I get the redirect error message since the upgrade:
    http://segullah.org/

    when I chose front page to display lastest posts in settings>>reading, front page still goes into redirect feedback loop.

    Only the front page seems to be broken: My internal wordpress pages are all working, including my posts page.
    http://segullah.org/blog/

    I tried clearing and resetting my .htaccess but that's not helping, or it takes more than an hour for .htaccess edits to become effective.

    I removed an old unused index.html file I had hanging out on the directory.

    my wp-recent-links plugin participates in the .htaccess, but I don't understand why. I disabled it and removed the php code that calls it, but that didn't fix the redirect loop problem.

    I tried add "www." to Settings/General and that didn't help my situation.

  13. rubc
    Member
    Posted 5 years ago #

    Discovered this problem shortly after upgrading to WP 2.7. Tried the various solutions provided. The one that works was deactivate plugins and test each individually.

    The culprit for my installation was the WordPress Tweaks plugin.

  14. justjohnna
    Member
    Posted 5 years ago #

    I've deactivated all my plugins. Then had wordpress reset .htaccess.
    Still getting redirect loop on main page.

    my .htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  15. fzelders
    Member
    Posted 5 years ago #

    The Disable Canonical Redirection plugin did it for me

    THANKS Bossy!

  16. DR4296
    Member
    Posted 5 years ago #

    I've just encountered the same issue after upgrading to 2.7. Disabling all plug-ins did not work. Installing that "disable canonical redirection" plugin worked in the sense that I can now get to the main page. However, the central pane is blank and it's not pulling in one of the sidebars. So, I disabled that plug-in again.

    My .htaccess file is exactly like "justjohnna"'s.

    Searching for the solution?? There must be SOME correction that can be made to the .htaccess file?

  17. DR4296
    Member
    Posted 5 years ago #

    OK, The reason my main page wasn't pulling in posts and a sidebar was that I had some other plugins disabled. Not sure how that happened.

    What I did was:
    1) Reverted fully back to previous version. Made sure this worked fine.
    2) Deleted all files, except for config file and wp-content.
    3) Reinstalled 2.7. Made sure all previous plug-ins were active, except for the "disable canonical redirection" one, which I had ftp'd out there earlier.
    4) Main page still went into redirect. Admin prompted for database upgrade. When I approved the upgrade, I saw it update the .htaccess file. I deleted this and put back the old version of it. Main page still looping on redirect.
    5) Activated that "disable canonical redirection" plug-in. Main page (and, of course, other pages) pulls up fine.

    Thanks!

    -= Dave =-

  18. ch0p5
    Member
    Posted 5 years ago #

    I can't get into wp-admin to activate the plugin. Anybody know how to get around that?

  19. bradyjfrey
    Member
    Posted 5 years ago #

    Just had the same issue for me on http://ambermariebently.com, I had the following 3 plugins:
    1) Filosofo's remove dashboard
    http://www.ilfilosofo.com/blog/2006/05/24/plugin-remove-the-wordpress-dashboard/
    2) Role Manager (not updated still):
    http://sourceforge.net/projects/role-manager
    3) Filosofo's database backup:
    http://wordpress.org/extend/plugins/wp-db-backup/

    Might have been remove dashboard for me - regardless, I dumped that and role manager, and I could log in again. I have a feeling remove dashboard was trying to redirect to a sub page, and then that trying to send back.

    Regardless, I recommend when you have these problems do two things:
    1) Make sure the folder for Admin and it's contents are set to 755, or rwxr-xr-x (everyone can read and execute, but only user can write)
    2) copy your plugins locally, then delete them from the server

    The disable redirection is a bit of a funky hack, you could be covering a larger issue, like I had above.

    Thanks everyone, I hope this helps you a bit!

  20. ediltonsiqueira
    Member
    Posted 5 years ago #

    If you have redirections in your site document root directory
    the problem could be mishandled links in PHP code for some plugins.

    I had a redirection problem with wp-reCAPTCHA. The options form pointed to $_SERVER['PHP_SELF'], who fetches the raw address of the script file and thus gets scrambled by actual site redirection, since form actions are delivered via http server (apache 2.0) and not directly by the OS. The actual page would never be reached and WP got lost in endless login forms.

    So I hacked the plugin code (version 2.9.2, wp-recaptcha.php, line 696), pointed the options form action to $_SERVER['REDIRECT_SCRIPT_URI'] and it worked like a charm.

    If you can - and that is the case - try hacking the source code of the broken page, point out the missing link, grep its surrounding code into the plugin directory and var_dump the variables used in forms and link options. Quite messy, I know, but that may help here and there.

  21. Richard Palace
    Member
    Posted 5 years ago #

    Before you try anything, try removing the object-cache in your wp-content folder if it exists.

    Hope this helps

  22. christophdollis
    Member
    Posted 5 years ago #

    With WP 2.81, disable canonical URL redirect plugin worked for me, whereas disabling all plugins did nothing.

    * * *
    However, why can't I use canonical URL redirects!!? They're there for a reason.
    * * *

    So annoying. And only at http://christophdollis.com/

    My other sites work just fine.

    Incidentally, it was my posts page getting the redirect loop error, not my homepage. WordPress is installed in its own directory not the root, if that matters.

  23. marlowe5
    Member
    Posted 4 years ago #

    Just upgraded to 2.8.6 and had this redirect error, even with all plugins disabled. The "Disable Canonical Redirection" plugin worked for me, thank god! I appreciate the advice!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.