WordPress.org

Ready to get started?Download WordPress

Forums

2.7 Plugin Install Hostname Issue (14 posts)

  1. Morphzan
    Member
    Posted 5 years ago #

    I am attempting to install plugins using the plugin installer
    in WordPress 2.7 Beta 3

    I normally use an IP address when using ftp but my server
    puts all files in the /public_html folder so i get the following error:

    Unable to locate WordPress Plugin directory.
    Installation Failed

    What would i put in the hostname to correct this?

  2. skeemer
    Member
    Posted 5 years ago #

    I just want to bump this because I ran into the same thing. There needs to be a field for path. This could be a major deal breaker for usage on some hosts.

  3. skemple
    Member
    Posted 5 years ago #

    I agree. There should be someway to specify the path. I have 4 different wordpress installations on my server and use one ftp user to upgrade them manually right now.

    My main site is in /var/www

    and the other 3 are in user folders at /home/username/public_html

    It would be great to add this to the plugin updater and the wordpress upgrade options.

  4. amenthes
    Member
    Posted 5 years ago #

    I set up a FTP-User for upgrading. The user's root dir is my wordpress-installation. (Meaning: a FTP-browser will display index.php, wp-config.php and so on directly under / )

    Still neither the automatic upgrade nor the plugin install works for me.

    Supplemental: Just out of curiosity, i chomdded all my files to 777 - didn't change a thing. i also tried various other users with different root-dirs - no change either. Is there any logfile or verbosity-option i could turn on to run down to problem?

    (this was done using 2.7 final)

  5. lcf
    Member
    Posted 5 years ago #

    having the same problem here.
    (wordpress 2.7 final)

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The FTP updater method is not perfect and sometimes won't work. It tries to figure it out using what it knows about the WordPress path, as reported by PHP, but symlink trickery can sometimes muck this up.

    If you know the paths to the various folders on the server, as seen via your FTP user, you can manually define them in the wp-config.php file.

    FTP_BASE is the full path to the "base" folder of the wordpress installation.
    FTP_CONTENT_DIR is the full path to the wp-content folder of the wordpress installation.
    FTP_PLUGIN_DIR is the full path to the plugins folder of the wordpress installation.

    So add these to your wp-config.php file, with the other defines:

    define('FTP_BASE','/path/to/wordpress/');
    define('FTP_CONTENT_DIR','/path/to/wordpress/wp-content/');
    define('FTP_PLUGIN_DIR ','/path/to/wordpress/wp-content/plugins/');

    That might help you get it working.

    Alternatively, if you control your server, consider switching to suPHP instead of a normal PHP installation. suPHP lets the webserver run as the user who owns the files, allowing WordPress to update itself directly, not needing to do an FTP loopback. Most distributions have suPHP built into their repositories, all you generally have to do is to install it using your package manager.

  7. MichaelH
    Member
    Posted 5 years ago #

    Good info there Otto42, added this to Codex:

    http://codex.wordpress.org/Editing_wp-config.php#FTP_Constants

  8. lcf
    Member
    Posted 5 years ago #

    the full path is something like /public_html/blah/ ?

  9. pureananda
    Member
    Posted 5 years ago #

    hey..

    i dont use linux...sorry

    however, i amm facing a similar problem when i try to "add new" plugin.

    it says "Error: There was an error connecting to the server, Please verify the settings are correct."

    what am i supposed to enter in the "hostname" field??

    user/pass is ok..

    i am not facing any ftp upload issue (using filezilla) except for the "meet your commenters" plugin, which doesnt show up in the admin panel even though it has been uploaded ok.

    cheers

    ananda

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    what am i supposed to enter in the "hostname" field??

    Well, your hostname would be a good bet. ;)

    It'd be something like http://ftp.example.com or example.com or whatever you actually connect to when you ftp to the site.

  11. Charles7909
    Member
    Posted 5 years ago #

    The answer to this problem is found right here. I searched for days and tried all the stuff in this thread, but none of it is correct.

    Do what this guy says and everything will work fine:

    http://clifgriffin.com/2008/12/09/how-to-fix-wordpress-automatic-upgrades-plugins-and-wordpress/

  12. AlexS66
    Member
    Posted 5 years ago #

    My site works fine, no problem. http://www.webhostingr.net

  13. gnagent
    Member
    Posted 5 years ago #

    There is a space character in the critical define statement above that solves the problem described in this thread:

    define('FTP_PLUGIN_DIR ','/path/to/wordpress/wp-content/plugins/');

    should be:

    define('FTP_PLUGIN_DIR','/path/to/wordpress/wp-content/plugins/');

  14. gnagent
    Member
    Posted 5 years ago #

    By the way, if you make the above changes, and instead of an error message, you are told that everything worked fine, but your plugin still isn't available, check to see if it has unpacked in the /wp-content/upgrade directory rather than in the /wp-content/plugins directory where you hoped it would. If it did, read this webpage:

    http://www.theosquest.com/2009/04/19/fixing-plugin-auto-update-in-wordpress-271/

    and follow the direction exactly, including making the change from 'getmyuid' to 'posix_getuid' (the 'sanity' check). In WordPress 2.7.1 the 'getmyuid' function is used on lines 626 & 628 of /wp-admin/includes/file.php, and those need to change to use posix_getuid.

    Good luck and I hope this helps. My installation is now able to upload a plugin .zip file and have it installed and read to be activated, but it took a good three hours of digging to get it to work. Not what I'd call friendly, but hey, the price is right. ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic