WordPress.org

Ready to get started?Download WordPress

Forums

[2.7] Install Plugins: Error: There was an error connecting to the server, Pleas (15 posts)

  1. dashnc
    Member
    Posted 5 years ago #

    Hi,

    I created a new WP 2.7 blog. Everything work fine except the automated installer for plugins.

    I get this error:

    Error: There was an error connecting to the server, Please verify the settings are correct.

    I use the right login data for the ftp (the data works fine within my browsers (ftp://user:password@domain.com) and within my ftp-program...)

    I tested another WP 2.7-system ( an 1-click-installation) of my hoster. But with the same error and a strange error message extra:

    extract() [function.extract]: First argument should be an array in /wp-admin/includes/file.php on line 691

    Any help? ... please? :)

    dash

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Try using localhost for the ftp server. That sometimes works.

    The problem is essentially your server's configuration. It's unable to connect back to itself. Could also be the network configuration at your host.

  3. dashnc
    Member
    Posted 5 years ago #

    When I use "localhost" for the ftp server, WP throw the same error message nevertheles. And fill the hostname-input with the following value:

    localhost://domain.com/dir

    And what do you mean with
    "It's unable to connect back to itself. Could also be the network configuration at your host."

    It's a kind of selfprotection, set up by my hoster, with no chance to change that?

  4. davidscommonsense
    Member
    Posted 5 years ago #

    I have been able to access plugins fine in the auto installer until today when it keeps telling me an "unknown error has occurred" Is anyone else running into this?

  5. RoarinRow
    Member
    Posted 5 years ago #

    I'm getting this as well "unknown error has occurred" for the plugs and for akismit. It won't recognize my key cause it can't connect to wordpress.com

  6. davidscommonsense
    Member
    Posted 5 years ago #

    Makes me wonder if the wordpress servers are having issues...

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    It's a kind of selfprotection, set up by my hoster, with no chance to change that?

    Well, no. You'd have to have your host change that.

    Also, that sort of thing is not a real protective measure in any sense.

  8. dashnc
    Member
    Posted 5 years ago #

    I solved it!
    A friend of mine hadn't this issue at the same hoster. So we compared our preferences and find a difference: He uses PHP5, I used PHP4.

    I changed it to PHP5 - et voilá ... no error.

    Change your PHP to version 5! (works for me...)

    Thanks for your help guys, anyway ;)

  9. inkedblots
    Member
    Posted 5 years ago #

    How do you change your PHP version to 5?

  10. dashnc
    Member
    Posted 5 years ago #

    I had to add a line in the .htaccess-file:

    AddHandler php5-cgi .php

    But this way may only work with my hoster. I don't know if you can change your PHP version with this solution too.

    But I think you can ask your hoster if they can change the PHP version for you :)

  11. webplacer
    Member
    Posted 5 years ago #

    I had the same problem, verified the php version which was 5, and changed domain to localhost, viola.

  12. meshmarketer
    Member
    Posted 5 years ago #

    I'm using WP 2.8 and PHP 5 and I get this error message.

    What's weird is that I am able to make changes to posts, but not delete a plugin.

    Any help?

  13. btorgan
    Member
    Posted 5 years ago #

    I just had the same problem with 2.8.2 and I changed the "host name" to localhost and used my ftp username and password and it worked fine.

    Thanks to the posters on this forum for figuring it out for me. :)

  14. poluter
    Member
    Posted 5 years ago #

    unknown error has occurred" for the plugs and for akismit. It won't recognize my key cause it can't connect to wordpress.com

    I'm also having this exact problems! I'm running PHP5.

    How and where do I change "host name" to localhost? Please advice me where to look!

  15. wetwebwork
    Member
    Posted 5 years ago #

    I clicked on the message saying new release, please upgrade. When the upgrade failed, I was given three fields to enter connection details. I changed these to localhost and my ftp details, and the upgrade worked.

    Not sure where you would do this for plugins, though.

Topic Closed

This topic has been closed to new replies.

About this Topic