WordPress.org

Ready to get started?Download WordPress

Forums

2.7 Image Upload Not Working (49 posts)

  1. husar
    Member
    Posted 5 years ago #

    Just installed 2.7 yesterday. When creating a new post I am clicking the image icon to select an image from my gallery or upload a new one. The image admin screen jumps out of WP altogether and it is page by itself.

    Anyone else have this happening? Can't upload and insert an image at all. :(

  2. dmahler
    Member
    Posted 5 years ago #

    Thanks for asking that one! I'm having the same problem. It navigates away from the page and then when I try to use the browser upload, it uploads but clicking insert into post just gives me a blank page. Can't even get back to the original post and when I do, image is not there anyway.

    I'm looking forward to the response on this! Thanks for asking!
    Debbie

  3. civmatt
    Member
    Posted 5 years ago #

    At least you're able to get it uploaded all I get is "Missing a temporary folder."

  4. Marionp
    Member
    Posted 5 years ago #

    I am having a similar problem. When I try to upload through the media library using browser, it appears to download (and there is no error message), but no images appear in the library.

  5. mulligankm
    Member
    Posted 5 years ago #

    I am having a possibly related problem. It is trying to upload the images to a completely different domain on my server and I have no idea where it is getting this information from.

  6. pcmt
    Member
    Posted 5 years ago #

    Ditto for me (at first). Clicking the upload button took me to the Media Library after a short wait (as if something was being uploaded). Nothing was uploaded.

    Then I noticed my upload folder had 755 permissions and when I changed it to 777, the uploader worked and the image showed up in the library.

  7. dmahler
    Member
    Posted 5 years ago #

    Just did what pcmt suggested and no luck. Still getting the blank page after upload.

  8. surmacki
    Member
    Posted 5 years ago #

    Just create /tmp folder in your wordpress directory and it should be fine - works for me :-)

  9. dmahler
    Member
    Posted 5 years ago #

    Okay I tried that too. No go. I keep clicking on the insert into post and I get a page like this:
    http://mysite.com/wp-admin/media-upload.php?type=image&tab=library&post_id=519

    That is totally blank! Nothing, zip, zero, nada.

  10. richardforeman
    Member
    Posted 5 years ago #

    got the same problem. Had to install 2.6.5 to post with photos. Can't wait to see the solution on this one.

  11. richardforeman
    Member
    Posted 5 years ago #

    I had to disable my wp-amazon plugin, because it was affecting the java scripts on the dashboard.

  12. darlene54
    Member
    Posted 5 years ago #

    I tried changing the permissions on the upload file,but it didn't help. The photos upload, but they won't display in the post. I get a box with a broken icon in it. This also happened with wp 2.5.1, I think. There was a plug-in that fixed the problem, but I had to take it off because it was messing up my blogs. My webhosting service said it was causing an error of some kind. Why don't they check to see if you can upload pictures before they release a new version?

  13. Prasad Thombre
    Member
    Posted 5 years ago #

    I am facing the same issues with my website after upgrading to 2.7 Please help me to resolve this.

    Error: Permission Denied.

    .../media-upload.php?

    i tried everything... i also tried changing media upload folder path... but nothing worked....

    Please sugggest.

  14. eibhlin
    Member
    Posted 5 years ago #

    Me too. Mine is telling me
    "Unable to create directory /wp-content/uploads/2008/12. Is its parent directory writable by the server?"

    The first odd note was that there's no button for me to click for Flash upload. So, I'm using the browser upload... or trying to, anyway.

    I checked permissions and changed everything to 777, up through wp-contents.

    No luck.

    I manually created the 2008/12/ directory with CHMOD 777. That didn't help, either.

    I tried manually uploading the image to my 2008/11/ directory. (Hey, it was worth a try.) The Media Files don't show the image.

    I tried uploading the image through the Media Files tab, not through the Post. I didn't get an error message, but after it appeared to upload, the image didn't show up in my files. (I also checked through FTP, just in case.)

    I deactivated every plugin. Nope, it still won't upload images.

    The site was working fine before the 2.7 upgrade. I hadn't uploaded new images since November, and I can still use the old images but I can't add new ones.

    Weirdly, several of my other WP 2.7 upgrades are working fine on the same server (HostGator) with the same theme (Branford Magazine) and same plugins.

    Any other ideas?

    30 MINUTES LATER: I manually upgraded 2.7, just to be sure it's working. The Flash button has returned to my "Add an Image" screen in Post. However, I'm still unable to upload images. Same error message, no matter what I try. Help...?

  15. eibhlin
    Member
    Posted 5 years ago #

    After my previous post, I tried the .htaccess file addition in wp-admin. I'd used that with success at WP 2.5.

    That didn't help 2.7.

    I also tried the fixes recommended at the Installations section of the forum. I double-checked my swfupload folder in wp-admin/js and I cleared my cache.

    Still no luck. I'm going back to 2.6.5 for now.

    UPDATE: Now it's not working in 2.6.5, either. I'm contacting my hosting service in case I've mangled the database.

  16. eibhlin
    Member
    Posted 5 years ago #

    Solved!

    First, I had to fix the problems created by rolling back to 2.6.5.

    2.6.5 files had changed the database Uploads path to the full path (myusername/root/domainname.com/wp-content/uploads/...) so I had to go into pHpMyAdmin and change it back to /wp-content/uploads in the Options section.

    My existing images reappeared on my website. Whew!

    But, retrying 2.7, I was still reaching the error message when I tried to upload new images through WordPress.

    An overnight conversation with tech support ensued, and they found the problem.

    In my case, the new (2.7) wp-content/uploads folder had automatically uploaded with CHMOD 777. Apparently, my hosting service (Hostgator) won't allow 777, only 755.

    So, switching all folders back to CHMOD 755 solved the problem.

  17. wibbler
    Member
    Posted 5 years ago #

    For those with blank admin pages after media and image uploads - I disabled all plugins, and the re-enabled all except the WP-Amazon plugin. All working well!

    (I did just deactivate MT_Amazon initially, but that didn't seem to solve it - heance the drastic Disable All!)

  18. nbostic
    Member
    Posted 5 years ago #

    I've tried chmoding the upload directory (and subs) as well as deactivating all plugins and am still getting the problem where I can't upload media, images in particular. Anyone have any other bright ideas?

  19. ernestkoe
    Member
    Posted 5 years ago #

    having the same problems here:
    - all plugins disabled
    - permissions on uploads dir seem to be okay

    still, image uploading fails to actually upload the image into the uploads dir

    help?

  20. mikaelwehner
    Member
    Posted 5 years ago #

    I had the same problem with permissions on uploads after upgrading from 2.7 beta to 2.7. I got an error message telling that it couldn't upload to /wp-content/uploads/2008/12/ because permission was denied. All folders was there, the folders "2008" and "12" was created by WP and given permission 777. However, I did not have permission to change the permission on these folders myself. I then delete those two and created them again with permission 777 and everything worked.
    I hope this gets solved however, since I don't want to do this manually for every month of the year.

  21. cyriacgc
    Member
    Posted 5 years ago #

    @eibhlin and all those who are facing the following error
    "unable to create directory XXX is it a parent directory writable by server ?"

    i fixed it using the following solution,
    NO NEED FOR ANY CHMOD to 777
    just edit the store uploads directory in settings>miscellaneous to the default value (shown there)

    A more detailed solution is given here, how to solve image upload error in wordpress 2.7

    hope this helps guys there

  22. jeffsonstein
    Member
    Posted 5 years ago #

    I found a simple fix here

    jeffs

  23. jeffsonstein
    Member
    Posted 5 years ago #

    but now I have a report that the image still does not show in the RSS feeds (sigh)

  24. daveconrey
    Member
    Posted 5 years ago #

    I don't know if this is truly related or not, but I was having the same problem. I wasn't using the WP Amazon plugin, but I did still have the Automatic Upgrade plugin activated, which might have been a conflict with WP's new automatic upgrade feature. I disabled the plugin and it seems to be working fairly well.

  25. BriefEpisode
    Member
    Posted 5 years ago #

    Thanks for the help on this one! It was driving me crazy.

    I deactivated the Amazon plugin and everything with my images returned to normal!

    If only I could get my tags to start working again...

  26. dmahler
    Member
    Posted 5 years ago #

    Thanks folks! You gave me the idea to do the same. I disabled all my active plugins and started to reactivate them one-by-one!

    CommentLv is another plugin that stops the image uploader from working also!

    Thank you so much! Next time, I'll try disabling the plugins like that again! Lesson learned.

  27. Prasad Thombre
    Member
    Posted 5 years ago #

    I tried every possible way to get this image upload error resolved includes...

    1) CHMOD 777
    2) De-activating all plugins
    3) tried path other than default wp-content/uploads to wp-content/userdata
    4) edited database table entry...
    5) Tried Installing fresh copy of WordPress 2.7
    6) using .htaccess file

    all this wasted... and i am still facing issues with media/photo uploads.

    Waiting for some accurate solution...

    Team
    MyLoversWish.com

  28. Samuel Jesse
    Member
    Posted 5 years ago #

    It worked for me, I manually mad a new folder called "uploads" and then changed the permissions higher and higher until it worked. It may have been 777 in the end...

    Then I tried uploading again and presto! Perhaps those who are changing permissions and not getting results on 2.7 are not manually creating the uploads folder to start with?

  29. harjeetsg
    Member
    Posted 5 years ago #

    Solution for the error

    Step 1: Log into your admin panel

    Step 2: Go to Settings>>Miscellaneous

    You will see two options,

    Store uploads in this folder
    Full URL path to files
    Most probably you will see

    /home/.boogee/XXXXX/XXXXXXX/wp-content/uploads

    in the first field.

    Step 3: Edit that to just

    wp-contents/uploads

    PS: Please take a backup of what you are editing, incase this trick didnt work, you can restore the old URL.

    This should do the trick.

  30. fredmiller
    Member
    Posted 5 years ago #

    Do you mean wp-content
    or
    wp-contents?

Topic Closed

This topic has been closed to new replies.

About this Topic