WordPress.org

Ready to get started?Download WordPress

Forums

2.7 Dashboard: RSS Feed not loading (53 posts)

  1. jca
    Member
    Posted 5 years ago #

    Since upgrading to WP 2.7, the Other WordPress News RSS feed (widget) in the Admin Dashboard refuses to load.

    When checking the widget's Configure link, the default http://planet.wordpress.org/feed/ url is replaced with a Error: could not find an RSS or ATOM feed at that URL. error message. The planet.wordpress.org feed loads fine directly in my browser, and I can load other feeds in that same Other WordPress News widget. Other Dashboard feeds continue to work as well. But whenever trying to use the feed from planet.wordpress.org (and variations of that feed's url), it doesn't work. The feed worked fine in previous versions of WP.

    Any ideas?

    Appreciate any help/info.

  2. ensworth
    Member
    Posted 5 years ago #

    I have exactly the same problem ... which began after I upgraded to 2.7.

  3. jca
    Member
    Posted 5 years ago #

    I have WordPress 2.7 installed on a different host/server, and it has no problem with the Other WordPress News widget using the planet.wordpress.org feed.

    I tried burning the planet.wordpress.org to a Feedburner feed to see if that version would load, but it made no difference.

    Could this may be a problem with the web host (which is Dreamhost, in this case)?

    Any ideas?

  4. dljmktg1
    Member
    Posted 5 years ago #

    I have the same problem with the other wordpress news RSS feed. I am on a different host than you are. The other RSS feeds are working, it's just that one.

  5. grassrootspa
    Member
    Posted 5 years ago #

    Guys, I started a bug/defect report on this for them to fix for 2.7.1.

    http://trac.wordpress.org/ticket/8543

    Can you guys help me with it? Maybe fill in stuff I missed?

  6. rainnetdev
    Member
    Posted 5 years ago #

    This is what I did to fix this problem...

    1. Open wp-config.php
    2. Remove any spaces after "?>" at the very end of the document.

    For some reason that worked for me. It took some time for Feed Burner to register the change, but the FireFox RSS reader registered the change instantly.

  7. jca
    Member
    Posted 5 years ago #

    Remove any spaces after "?>" at the very end of the document.

    This didn't fix the problem for me.

    Are we talking about the same issue? You mentioned using your Firefox RSS reader -- we're talking about seeing the RSS feed in a Admin Dashboard widget.

  8. manjulmanjul
    Member
    Posted 5 years ago #

    It's not working. Here is the error it shows
    XML Parsing Error: no element found
    Location: http://feeds.feedburner.com/cartoonsbyMANJUL
    Line Number 1, Column 1:

  9. RoarinRow
    Member
    Posted 5 years ago #

    I'm looking forward to a fix as well. Mine is busted on 2 of my 4 blogs.

  10. Lisa Rouissi
    Member
    Posted 5 years ago #

    me too, I miss the wp news on my dashboard :(

  11. PalmBeach
    Member
    Posted 5 years ago #

    After upgrading to 2.7 my dashboard is not showing up either. I will not upgrade the rest of my blogs until their is some response. This issue is 2 weeks old...............Hello is anyone home? Earth to wordpress can you read me wordpress. Come in wordpress. Come in wordpress can you hear me?

  12. PalmBeach
    Member
    Posted 5 years ago #

    This worked for me

    Create an empty plugins folder

    * Via FTP or your host's control panel, navigate to the wp-contents folder (directory)
    * Via FTP or your host's control panel, rename the folder "plugins" to "plugins.hold"
    * Via FTP or your host's control panel, create new folder called "plugins"
    * Login to your WordPress administration menus
    * Via FTP or your host's control panel, delete the empty "plugins" you previous created
    * Via FTP or your host's control panel, rename "plugins.hold" back to "plugins"

  13. wwonka
    Member
    Posted 5 years ago #

    Palmbeach your lucky that did not work for me.

  14. pixelgeek
    Member
    Posted 5 years ago #

    I have the same issue

    How did this not get picked up in testing?

  15. Ryan S
    Member
    Posted 5 years ago #

    You can try this:

    http://planet.wordpress.org/?feed=rss2

    I hope this will work..

  16. Frenetik
    Member
    Posted 5 years ago #

    This feed only shows the usual planet webpage, but this link worked for me :

    http://planet.wordpress.org/feed/?feed=rss2

  17. CesarQuinterox
    Member
    Posted 5 years ago #

    I found I had the same problem last night. I agree it might be the new WP version. However I also noticed that if you turn on WP-Cache and you go to your RSS link you get XML output but without the standard feed format. After refreshing, it fixes itself. The two things are totally unrelated but somehow work (?). It really confuses me but at least gets your feeds kinda working. Anyone have any idea why this is?

  18. CesarQuinterox
    Member
    Posted 5 years ago #

    Another silly thing. I found the error occurred even less with the super cache. Makes no sense to me but I thought people would like to know.

  19. RoarinRow
    Member
    Posted 5 years ago #

    Using the above feed URLs don't work for me. When I submit the URLs I still get nothing. When I go in to look at the URL I see this - Error: could not find an RSS or ATOM feed at that URL.

  20. grassrootspa
    Member
    Posted 5 years ago #

    Frenetik, you are my hero.

    WORKED!!!

  21. NuAngel
    Member
    Posted 5 years ago #

    Same problem, no RSS feed exists any more? And Frenetik just pointed to a different URL - not really sure how to go about fixing this, yet. Also don't see the option to disable caching anywhere in my dashboard?

    NuAngel

  22. nmallory
    Member
    Posted 5 years ago #

    I started another thread earlier -- not only am I not getting any dashboard feed, my del.icio.us widget and flickr widget feeds have stopped working and I can no longer automatic update plugins. It all seems to have started yesterday. I have cleared my cache, I think.

    Something has gone wonky.

  23. NuAngel
    Member
    Posted 5 years ago #

    Some of your plugins simply need to be moved to the root "wp-content" folder, rather than in subfolders OF wp-content. That might help some of those. Though I still can't get "TwitterUpdater" to work, either.

    But still, the RSS is my biggest issue at this time. :( It's not a 3rd party plugin, it's part of WordPress.

    NuAngel

  24. nmallory
    Member
    Posted 5 years ago #

    I don't think that's it. I deactivated everything but :

    Akismet
    Bad Behavior
    del.icio.us for WordPress
    Executable PHP widget
    flickrRSS
    My Custom Widgets
    runPHP

    I still don't have any dashboard feeds and the del.icio.us and flickr feeds in my sidebar (http://jlynne.exit-23.net) are coming up empty.

    However, the deactivation of Google XML Sitemaps did correct the issue with the built-in auto-upgrade.

    Other things I deactivated:

    Amazon Reloaded for WordPress
    Amazon Showcase
    Angsuman's Feed Copyrighter
    Autorelated
    Blog Copyright
    commentluv
    Contact Form ][
    DashBar
    Do Follow
    Post-Plugin Library
    Similar Posts
    Simple Trackback Validation
    Subscribe me
    Subscribe To Comments
    Tag Managing Thing
    Tiny Link
    TinyMCE Advanced
    Trackback List
    WP Super Cache

  25. nmallory
    Member
    Posted 5 years ago #

    OK This definitely has something to do with the embedded WP rss functionality. I may not be familiar with the inner-workings of WP but I've looked at everything else and if the dashboard RSS doesn't work and the widget RSS isn't working, that seems like 1+1=2 to me.

  26. worldview
    Member
    Posted 5 years ago #

    my issue is

    I op;en the config and submit ANY working feed url and click submit which produces he dreaded white page and does not update.

  27. dswinson
    Member
    Posted 5 years ago #

    I have the same issue. Tried adding the extra /feed/ but still getting the error message.Error: could not find an RSS or ATOM feed at that URL.
    Has anyone had a resolution to this issue?

    Thanks David

  28. gfyd
    Member
    Posted 5 years ago #

    I am in the same boat. My rss feed works fine, but my comments feed doesn't work. Don't know what to do. Can anyone help me?

    Kimberly
    http://blog.go-for-your-dream.com

  29. vane.
    Member
    Posted 5 years ago #

    I have the same problem...

    well... everyone with the same problem and nobody appears to fix this :)

  30. michelle3duk
    Member
    Posted 5 years ago #

    I have this problem too.
    RSS feed not working.

    I'm fairly new to blogging, just moved mine from wordpress.com.
    url is: http://www.michelle-reader.co.uk/Blog
    I spent ages yesterday taking all the blank spaces from beginning and end of my php files, but to no avail...

    I'm using inove theme - the rss-related code in sidebar.php doesn't look like the support documentation example, but I'm not sure if or how I can change it. Sounds like that's not the problem anyway.

    Any solutions yet?
    Michelle

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags