WordPress.org

Ready to get started?Download WordPress

Forums

2.7 beta1 missing avatar size plus layout problems (11 posts)

  1. Branch
    Member
    Posted 5 years ago #

    The new wp_list_comments means that the size of avatars can no longer readily be set manually, but I don't see anywhere in the admin panels to set the size. Presumably this should be added under Settings > Discussion, with the other avatar settings.

    The other quirk I'm running into looks like a layout issue: on short pages the Settings menu item is hidden underneath the admin pages footer and I can't click on it. Yay for absolute positioning; perhaps a z-index statement is in order?

    Similarly, if any content in the main area overflows the right side, no scroll bar appears and there's no way to get to that, either. So far this has happened with the auto-upgrade messages and one plugin. Overflow:auto, please?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    wp_list_comments has an option called "avatar_size". You can set it through that. Like so:

    wp_list_comments('avatar_size=64');

    Here's the point where that was added to 2.7: http://trac.wordpress.org/changeset/9207

    There is no admin panel setting for this size at present. Considering that size of the avatar can be highly dependent on the theme, there may not be one added in the future. Let the theme take care of sizes and looks and such, is the general idea.

  3. 87insight
    Member
    Posted 5 years ago #

    but if the theme's css set avatar size more than 32px, the picture will be resized from 32px, it will get fuzzy...

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    If you use CSS, then yes, it'll be fuzzy.

    But if you do it the way I said above, then it will not get fuzzy. The avatar_size parameter is not a simple HTML resize, it changes the request to the gravatar servers to actually get a bigger avatar picture.

    Gravatar supports avatars up to 512x512.

  5. 87insight
    Member
    Posted 5 years ago #

    OK. I'm using 2.7 in the iNove theme, in comment.php it says

    // for WordPress 2.7 or higher
    			if (function_exists('wp_list_comments')) {
    				wp_list_comments('type=comment&callback=custom_comments');

    I don't know where to add it. (I'm a total newb in codes)

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Like this:

    wp_list_comments('type=comment&callback=custom_comments&avatar_size=64');

  7. 87insight
    Member
    Posted 5 years ago #

    &avatar_size=64 won't work. No change.

    I tried to make it into
    wp_list_comments(array('avatar_size'=>64), 'type=comment&callb......
    a default avatar of 64px showed, but the rest of the comments are gone.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Well, then you'll need to ask the theme author. Perhaps he has the avatar size hardcoded.

    That code works in normal WordPress. However, the theme author has clearly chosen to use a custom comments callback function. So, he may not be following the same standard that WordPress uses.

  9. 87insight
    Member
    Posted 5 years ago #

    Thank you all the same, for your patience. :)

  10. 4star
    Member
    Posted 5 years ago #

    never mind i found my answer.

  11. ramon fincken
    Member
    Posted 5 years ago #

    Here's a howto which is tested at 2.7.1 and includes CSS fixes:
    http://www.ramonfincken.com/permalink/topic136.html

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.