WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 2.6 Toggle between Flash uploader and classic one (14 posts)

  1. Huugendruug
    Member
    Posted 5 years ago #

    Great! But how?
    I've been looking all over the place: write panel, admin panel, settings, user, you name it...
    Where is the checkbox, togglebox... magicbox, that let you toggle between the Flash uploader and classic one?

  2. Jeremy Sarber
    Member
    Posted 5 years ago #

    I think if you don't have your flash player updated, then it will automatically use the browser uploader and not give you an option.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    It's on the uploader screen itself. There's a line of text that says something like "you are using the flash uploader, if you have problems try the browser uploader instead". It has a link to use it there.

  4. Huugendruug
    Member
    Posted 5 years ago #

    I can see "You are using the Browser uploader." on the uploader screen. That's it, no more, no less. No link. Nothing to toggle.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The Browser Uploader is the non-flash one. And that's what appears when it doesn't detect Flash on your browser or detects that the Flash Uploader will not work, for whatever reason.

    Try upgrading your browser's Flash version.

    This can also be caused by a plugin blocking the Flash Uploader or some such thing.

  6. Huugendruug
    Member
    Posted 5 years ago #

    Thanks for the help sofar Otto42.
    I have Adobe Flash version 9,0,124,0 installed (latest).
    Using XP SP2, IE 7.0.5xx and FF 3.0 = same "problem".
    Do you mean plugins used in WP?
    I might try to disable all plugins in WP and then see what happens... i'll keep you informed.

  7. Huugendruug
    Member
    Posted 5 years ago #

    Okey, I disabled plugins, first all, then one by one, then at random and in sequence. No avail.

  8. SilentlyScreaming
    Member
    Posted 5 years ago #

    IF you use the WP automatic upgrade plugin, and were using FireFox and a noscript/flashblocker plugin at the time of your upgrade, you may find two SWF files are missing from your installation. I had this issue which was stopping Google Gears from working. One of the files involved was the media uploader one.
    Easiest way to check is to FTP in and look at /wp-includes/js/swfupload/ if swfupload_f9.swf is missing
    and also flv_player.swf from wp-includes\js\tinymce\plugins\media\img
    then download WP2.6, and manually upload those files to your site in those locations. Apologies if this doesn't help you out, but it might help others who have similar issues.
    Please do let me know if this works for you. I don't suppose these support forums automatically e-mail you if someone replies?

  9. Huugendruug
    Member
    Posted 5 years ago #

    Dear SilentlyScreaming, a thousand thank you's!!!
    This is it, this is the solution to the problem. Yes indeed, I used the the WP automatic upgrade plugin and indeed it does not upload the files you mentionnned. After manual FTP upload it does work as it should be, many thanks! Wahey! :-)

  10. SilentlyScreaming
    Member
    Posted 5 years ago #

    Glad that sorted it. If you felt like occasionally visiting my blog (link) and taking a look round, I'd appreciate it.
    No problem if not, but no harm in asking, hopefully?

    PS Apparently if you enable your blog with your flash blocker add-in before you use the WPAU plugin next time, said files should be upgraded fine...

  11. Ajay
    Member
    Posted 5 years ago #

    Thanks for the solution SilentlyScreaming.

    Gears now worked perfectly on both my blogs.

  12. StrategyGalore
    Member
    Posted 5 years ago #

    If you can't find a link to activate the flash uploader, try this:
    http://strategygalore.nodblog.com/wp-admin/media-upload.php?post_id=1&flash=1

    Notice the variable sent: flash=1

    Good Luck!

  13. haryadimas
    Member
    Posted 5 years ago #

    i too have experiencing this problems. strangely enough i got all the swf SilentlyScreaming mentioned. and when i use the url StrategyGalore mentioned it works. the flash uploader show it self. BUT when i try to upload it says "An error occured in the upload. Please try again later."

    any ideas?

    dimas

  14. Google Slapper
    Member
    Posted 5 years ago #

    Thanks for the update SilentlyScreaming!

    That has saved me a shedload of hassle

    -----------------------------------------------
    Google Slapper

Topic Closed

This topic has been closed to new replies.

About this Topic