WordPress.org

Ready to get started?Download WordPress

Forums

2.6-beta3 and permalinks (33 posts)

  1. Aarne Toompark
    Member
    Posted 6 years ago #

    Found a bug in version 2.6.beta3. All posts will give 404 error when site uses "index.php/%postname%/" permalink structure. Also tag and archive pages will give 404 error. Normal pages are still working OK.

    With 2.5 there was same issue for pages (posts were OK).

  2. Aarne Toompark
    Member
    Posted 6 years ago #

    Same problem with 2.6-RC1.

  3. Aarne Toompark
    Member
    Posted 6 years ago #

    ...and in final release too. Really sad. :(

  4. siutouamy
    Member
    Posted 6 years ago #

    Hello, I just upgraded to WP 2.6
    and found the permalinks issue. (i know, should've read before upgrading, sighs)
    Is there a way to fix that? This is my blog
    http://personal.amy-wong.com/

  5. oriste
    Member
    Posted 6 years ago #

    Just wanted to chime in saying that I have no problems with the tag and archive views in my upgraded-to-2.6 installation. I don't use the particular permalink structure that aarnet mentions.

  6. Aarne Toompark
    Member
    Posted 6 years ago #

    Error only occurs if you use "index.php/%postname%/". Otherwise everything should be fine.

  7. Anonymous
    Unregistered
    Posted 6 years ago #

    I have same problem!! Any answer?

    Please help us!

  8. JohnvanDam
    Member
    Posted 6 years ago #

    I have just upgraded to the final 2.6 and have the same problem... setting the permalinks to the default returns the functionality but is quite inconvenient.Every other permalink structure returns 404's.

  9. nickajordan
    Member
    Posted 6 years ago #

    I've just upgraded and I'm experiencing the same problem. Does anyone have a fix for this?

  10. 7milesdown
    Member
    Posted 6 years ago #

    I think all Windows Server users are in the same boat nick. Looks like they were not able to find a solution to this before this release..

  11. nickajordan
    Member
    Posted 6 years ago #

    I'm not on a Windows server. My hosting company uses Linux servers running Zeus web server.

  12. Aarne Toompark
    Member
    Posted 6 years ago #

    This is now a "critical" error with "high" priority. Take a look at http://trac.wordpress.org/ticket/7306

    This error occurs no matter what server you use. This error only occurs if you use "index.php/%postname%/".

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    @aarnet: So you posted it here 6 days ago, but didn't bother to stick it on the bug tracker until 6 hours ago? Any particular reason?

    Bug reports do not go here. This is a support forum only.

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Also, workaround is here:
    http://wordpress.org/support/topic/189058

  15. rawalex
    Member
    Posted 6 years ago #

    Otto, that work around is a pain in the butt for people who have been using it, plus a major problem for the search engines who are going to see all the pages as having disappeared or been removed from the site.

    I am amazed that something as simple as this made it out to a release version.

  16. Aarne Toompark
    Member
    Posted 6 years ago #

    @Otto42: Sorry, didn't know how to act. Now I know better.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    @rawalex:
    a) There's two workarounds there.
    b) If the first workaround works for you, then it does not affect Google or anybody else at all, because all your old permalinks will still work, and redirect to the new permalinks with 301 redirections, thanks to canonical redirects.
    c) The second workaround simply remedies the problem, the permalinks remain the same.

    So quite frankly, you don't know what you're talking about.

    As far as your amazement, WordPress is open source, and if nobody reports a problem with it, then it doesn't get found. I would think that this would be pretty obvious.

    Why do you stick around here anyway? You do nothing but troll and bitch about WordPress all the time. If you don't like it, then don't use it.

  18. rawalex
    Member
    Posted 6 years ago #

    otto, I use wordpress extensively, and it is important to me that the product works, or is at least functional without security holes. I hang around here hoping like heck that there will be a secure and reasonably up to date version so that I can get off the upgrade elevator at some point without being in a security risk situation. I also help a number of people out with their personal blogs, and end up seeing these problems because people are encouraged (heck reminded every time they log in) to make an upgrade that they may not need or want.

    why do you hang around here? Looking to meet new people?

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Well, bitching about the product doesn't make it any better. So stop it. If you want to be constructive, fine. But comments like "I am amazed..." are not appreciated and they rather lead those of us who actually try to contribute patches and code to the project to be very much inclined to ignore anything else you have to say.

    I respect expertise and knowledge. I do not respect whiners.

  20. rawalex
    Member
    Posted 6 years ago #

    I do not respect poor code. Poor code - and poorly tested code - is just that. I can't be anything other than amazed that this went out with this sort of a change in it.

    I'm not whining, but any suggestions for WP made by the people I am involved with has been ignored, many of them to do with significantly improving the queries and execution speed of wordpress. But that's okay.

    In the meanwhile, perhaps we can figure out why something that worked fine (permalinks) was changed, and perhaps we can find a way to roll back that part of the code?

  21. The Spook
    Member
    Posted 6 years ago #

    I'm on IIS. The workaround Otto referred to worked, and my permalinks remained the same.

  22. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    In the meanwhile, perhaps we can figure out why something that worked fine (permalinks) was changed...

    If you had been paying attention, you'd know that that has already occurred: http://trac.wordpress.org/ticket/7306

  23. rawalex
    Member
    Posted 6 years ago #

    Umm, Otto, I can read, I can also read that it ain't gonna get fixed until 2.6.1...

    milestone changed from 2.7 to 2.6.1.

    here is to hoping that 2.6.1 comes out, say, Friday.

  24. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The schedule only gets pushed up for security issues, generally. This is not a security issue, and there's a known workaround that does indeed work.

    The roadmap has no date set for 2.6.1, however I'd be surprised if it happened in less than 3 weeks.

  25. estjohn
    Member
    Posted 6 years ago #

    Funny thing is, I am on apache on a *nix box... and 2.5 I had to use index.php/%postname%/ or it would not work.. now i can't use it or anything to get permalinks to work. Only the default works. Even using the default theme, no plugins.

    Same box, different site - default and with a theme, no plugins it works fine. /%category%/%postname%/

    I even copied the .htaccess over - rules, permissions, owner, everything exact same. I cant figure it out

    my .htaccess
    '
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    '

    AA Rewrite Rules reports
    > Permalink: /%category%/%postname%/
    > Writable .htaccess file found
    > mod_rewrite found
    > Not using pathinfo style index permalinks
    > Using mod_rewrite permalinks

  26. 7milesdown
    Member
    Posted 6 years ago #

    looking at your site estjohn it seems you found a fix.

  27. estjohn
    Member
    Posted 6 years ago #

    Thanks.. unfortunately it was going back to 2.5 and not using 2.6 deleting the .htaccess didnt work, adding something to categories and tags didnt work, using index.php or removing it either one did not work. Only solution was to go back :(

  28. Anonymous
    Unregistered
    Posted 6 years ago #

    Hmm... Why you have to go through .htaccess.
    All I did just change my permalink setting to something else, save it, and change it back to my previous setting.
    Voila, it's work again.

    Like I wrote it here

  29. estjohn
    Member
    Posted 6 years ago #

    Silentwind, that might have worked for you, but it did not work for me. wish it had been that easy... I tried that more than a few times.

  30. Anonymous
    Unregistered
    Posted 6 years ago #

    Hi guys,

    I had the same problem with permalinks on a Zeus server. I wanted a simple custom /%postname%/ rewrite (so for instance, the URL for the about page would have to be: http://www.domain.com/about/), but I either ended up with the index.php pushing itself in (www.domain.com/index.php/about/) or a 404 Not Found error.

    The main issue seemed to be the Zeus server in my case. It does not work like the Apache .htacces mod_rewrite rules WordPress generates. They need to be converted into "Zeus-ish" regex.

    If you are running your WordPress blog on a Zeus server and are having problems with your permalinks after the recent update, try copy pasting this script into the appropriate rewrite rules field in your hosting admin panel. If you're not sure what/where that is, please ask your hosting provider for help. (If you pay them, they should help you with this!)

    RULE_0_START:
    # get the document root
    map path into SCRATCH:DOCROOT from /
    # initialize our variables
    set SCRATCH:ORIG_URL = %{URL}
    set SCRATCH:REQUEST_URI = %{URL}
    
    # see if theres any queries in our URL
    match URL into $ with ^(.*)\?(.*)$
    if matched then
      set SCRATCH:REQUEST_URI = $1
      set SCRATCH:QUERY_STRING = $2
    endif
    RULE_0_END:
    
    RULE_1_START:
    # prepare to search for file, rewrite if its not found
    set SCRATCH:REQUEST_FILENAME = %{SCRATCH:DOCROOT}
    set SCRATCH:REQUEST_FILENAME . %{SCRATCH:REQUEST_URI}
    
    # check to see if the file requested is an actual file or
    # a directory with possibly an index.  don't rewrite if so
    look for file at %{SCRATCH:REQUEST_FILENAME}
    if not exists then
      look for dir at %{SCRATCH:REQUEST_FILENAME}
      if not exists then
        set URL = /index.php?q=%{SCRATCH:REQUEST_URI}
        goto QSA_RULE_START
      endif
    endif
    
    # if we made it here then its a file or dir and no rewrite
    goto END
    RULE_1_END:
    
    QSA_RULE_START:
    # append the query string if there was one originally
    # the same as [QSA,L] for apache
    match SCRATCH:ORIG_URL into % with \?(.*)$
    if matched then
      set URL = %{URL}&%{SCRATCH:QUERY_STRING}
    endif
    goto END
    QSA_RULE_END:

    You can find the original script here: http://drupal.org/node/46508

    It worked for me, and believe me... I'm very technically challenged ;-)

    cheers,
    adRem

Topic Closed

This topic has been closed to new replies.

About this Topic