WordPress.org

Ready to get started?Download WordPress

Forums

2.5 Visual Editor/TinyMCE problems (97 posts)

  1. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    Yep, WPLANG cannot be an empty space " ", it can either be completely empty "", or has to have proper value like de_DE, fr_FR, it_IT, etc. Setting it to "en" or even "en_US", "en_GB", etc. should work too.

  2. yogicoach
    Member
    Posted 6 years ago #

    Thanks for your suggestion proximity2008 - you're a lifesaver!

    The visual editor magically started working again when I switched back to the default template. I soon discovered that I inserted some extra characters in the functions.php when I customized this file to support multiple sidebars. Fixing the error has allowed me to go back to using my customized template and the visual editor. Certainly not an obvious fix.

  3. tortillasoup
    Member
    Posted 6 years ago #

    Problem appeared in both Firefox and Safari. Upgraded WP to 2.5.1 and fixed the issue in Safari (don't know how that happen). Problem continued in Firefox until I changed the "compress" to "false", then [poof] fixed. Thanks for all the fixes.

  4. mirandasoft
    Member
    Posted 6 years ago #

    Hello everybody. I forgot to post in this thread that the posting problem was fixed. I removed the Advanced TinyMCE plugin, and then, I de-activated all the plugins and then, re-activated the plugins, one by one, in order of importance, such as Akismet, first, etc.

    Now, I just run a selected few plugins, unlike before that I ran too many plugins.

  5. redforty
    Member
    Posted 6 years ago #

    I fixed mine!
    It turned out to be my theme. When I viewed my tiny_mce_config.php file, I saw a LOT of garbled text, but near the top were a few php errors calling to my theme's FUNCTIONS.PHP.

    I checked out the functions.php and found a bunch of php commenting at the top, so I cleaned up the file, removing extra line breaks and all of the comments. I refreshed the tiny_mce_config.php and it came across totally clear!

    So, if you need another step in the diagnosis, check to see if tiny_mce_config.php gives you any errors with paths to certain theme files!

    Cheers!

  6. evillines
    Member
    Posted 6 years ago #

    Worked for me. Thank god this was a simple fix. I've had a number of issues with 2.5.1 -- and checking a simple box is great to hear!

    Thanks!

  7. rodrigobrod
    Member
    Posted 6 years ago #

    For me, the solution was to turn off the Google Analytics Plugin. Now I'm using only these plugins: Lighbox-2, Add Lightbox, Akismet, TinyMCE Advanced and WordPress.com Stats.

  8. SirStuey
    Member
    Posted 6 years ago #

    I had a similar problem, but none of the above suggestions helped. I was able to come up with my own solution, modified from azaozz's suggestions (but also originating from a "patch" he introduced into the new 2.51 version).

    http://wordpress.org/support/topic/177490?replies=7#post-764006

  9. lclarkberg
    Member
    Posted 6 years ago #

    I am having a similar problem with the visual editor being stuck in html mode. I tried setting the javascript to be uncompressed to no avail. The error I am getting is:
    invalid flag after regular expression
    along with
    <b>Warning</b>: Cannot modify header information - headers already sent by (output started at D:\[a long path goes here]\wp-config.php:1) in <b>D:\[a long path goes here]\wp-includes\js\tinymce\tiny_mce_config.php</b> on line <b>244</b><br />
    As you can tell from the path this is a Windows server. Could that be the problem? I'm not having any problems on my development machine (Mac PowerBook).

  10. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @lclarkberg there's most likely a BOM on the first line of wp-config.php. Try creating a new wp-config.php on the Mac, then replace it on the server without opening it with notepad, etc. or use a hex editor and remove the BOM.

  11. MHNet
    Member
    Posted 6 years ago #

    Here is another solution--make sure ALL the files uploaded!!

    I tried the other fixes first (tiny_mce_config, etc...) and that didn't fix it for me.

    So I FTPed to my account and did a folder-by-folder comparison of what was on my hard drive and what was on my server. To my surprise a few folders on the server were missing several files, including one folder that was completely empty! Once I re-uploaded everything, Visual/HTML now works for me.

  12. xbawax
    Member
    Posted 6 years ago #

    I had the same problem. Deactivate: wp-google-analytics Plug-in, Now everything else working fine for me.
    WP version 2.5.1

  13. lclarkberg
    Member
    Posted 6 years ago #

    Thanks so much asaozz, your solution to my "Cannot modify header information" problem was pleasantly correct. It seems that there are many different possible causes for the visual editor not showing up.

  14. daniel.phiinx
    Member
    Posted 6 years ago #

    OMG proximity FTW it worked you rock

  15. jtimar
    Member
    Posted 6 years ago #

    When I try to load http://inthelimelight.net/wp-includes/js/tinymce/tiny_mce_config.php in firefox, wordpress gives me a 404 error. The file is definitely there I can see it in ftp, and edit it, but it won't load in the browser.

    My visual editor is still broken, and NONE of the solutions in any of the threads on this topic have worked, and I have tried all of them.

  16. jtimar
    Member
    Posted 6 years ago #

    UPDATE:

    I have fixed the problem. Thanks to the help of my amazing webhost I now have a fully working visual editor. Their live support helped me track down the problem in less than five minutes. Turns out in my case it was inncorrect file permissions for the tinymce folders (among anothers). They were set to 777, a workaround I needed on my previous host to make wordpress install at all, and upon setting them back to 755, the visial editor worked like magic.

    I must say I am a bit shocked that such a simple possibility has not been mentioned in any of these threads on this issue.

    ~Jonathan
    The Limelight: Personal development and money Mangement for young adults, and older ones too!

  17. fryewiles
    Member
    Posted 6 years ago #

  18. passegua
    Member
    Posted 6 years ago #

    I was writing my failure in fixing this issue when I read the jtimar solution, it worked for me too!!!

    I indeed checked my chmod permission and the /wordpress/wp-includes/js
    folder had 777, I changed to 755 and voila' viusual edito works properly again!!!

    Thanks so much.

  19. Mr.OB
    Member
    Posted 6 years ago #

    Hi, everybody. I had solve it by change CHMOD to 777 as list below;

    1) /wp-includes/js/tinymce/blank.html
    2) /wp-includes/js/tinymce/license.txt
    3) /wp-includes/js/tinymce/tiny_mce
    4) /wp-includes/js/tinymce/tiny_mce_config
    5) /wp-includes/js/tinymce/tiny_mce_ext
    6) /wp-includes/js/tinymce/tiny_mce_popup
    7) /wp-includes/js/tinymce/wordpress
    8) /wp-includes/js/tinymce/wp-mce-help

    after that it's will refresh your wordpress then visual editor works properly. If not please clear any cookies/ history/ from windows.

    Hope every can be solve it. Please feel free to contact me if need any help about this event.

  20. amechad
    Member
    Posted 6 years ago #

    I'm having the same problem at http://israeli-wine.org. Can't use the visual editor. Changed the compression to false and now I can see the text (but it's garbled together and not formatted properly line-by-line).

    Tried installing the editor, didn't work. This is using Godaddy's Ad Supported hosting, which ads some coding at the beginning automatically - could that be the problem?

  21. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @amechad Yes, the headers are messed-up and this is appended to the end:

    </object></layer></span></div></table></body></html><!-- adsok -->
    <script language='javascript' src='https://a12.alphagodaddy.com/hosting_ads/gd01.js'></script>

    Would probably have to find another host, lots of $5/month hosts around...

  22. amechad
    Member
    Posted 6 years ago #

    Any recommendations for good low-cost hosts?

  23. Anonymous
    Unregistered
    Posted 6 years ago #

    azaozz: You made my day with your sollution :-)

  24. debatelord
    Member
    Posted 6 years ago #

    I am having this same problem with the free Godaddy hosting. Does anyone know if there is a workaround for this, or do I just need to bite the bullet and buy the add-free hosting?

  25. skrimpy
    Member
    Posted 6 years ago #

    Firebug worked for me. I was able to see that I had quite a few files missing in my tinymce directories. I'm not sure why they didn't upload properly but I was able to upload each file individually and now my visual editor is functioning well. Thanks for the Firebug tip!

  26. Anonymous
    Unregistered
    Posted 6 years ago #

    First of all, I have noticed that there seems to be a few different issues with the visual editor not working, so this is most probably not a fix for everyone. But it certainly worked for me.

    I performed an update from 2.5 -> 2.5.1 and thats when I started getting the TinyMCE errors. I followed a lot of advice from the forums but nothing seemed to work, although changing WPLANG to your actual language is a good idea anyway. The closest that I got to actually getting it to work was by getting the latest and greatest TinyMCE files but even this only seemed to be half of a solution. I then began to realise that on an upgrade you only copy across the new files that are required and with FTP only the files that exist actually get overwritten, so if there are any old files that were not overwritten then these can (and did) cause problems.

    So here are the steps that I followed:

    1. Clear your cache in the browser.
    2. Remove the cache javascript file from the /wp-content/uploads/js_cache folder.
    3. Completely delete the contents of the /wp-includes/js.
    4. Copy of the contents of the js folder from the wordpress installation files.
    5. Run up your admin page and check to see if its fixed.
    6. If not (I am sorry) try one of the othr methods listed.

    This actually got me up and running again so I hope that it can do the same for you.

  27. PaperVictory
    Member
    Posted 6 years ago #

    I've done all these freaking things and still no Visual Editor. I'm starting to think about switching. This problem has persisted from 2.5 through 2.6. Newsflash: this shouldn't be this hard.

  28. Anonymous
    Unregistered
    Posted 5 years ago #

    Very Useful. Clearing the browser cache did the trick. Thank you.

  29. xxxevilgrinxxx
    Member
    Posted 5 years ago #

    before I install a plugin, I usually come here to see if other people have crazy issues with it, to see whether it's worth the trouble to add it.
    I had planned on installing the TinyMCE Advanced plugin but chose not to. (More work is something I try to avoid :) ) But I have to say thank you to member Azaozz. It's rare to see someone give such detailed information to help and, from someone who's a tinkerer, it's appreciated. Thank you!
    E.

  30. arso77
    Member
    Posted 5 years ago #

    Hello,
    I have the same problem, TinyMCE doesn't display and the button to switch from html to visual editor doesn't work.
    Firebug keeps telling me that "tinyMCE is not defined" when I click on the "HTML" button.

    I tried to load http://bn-in-oz.com/wp-includes/js/tinymce/tiny_mce_config.php but I get a 500 error. I also have tried all the other stuff (changing file permissions to 755, clearing the "js_cache" folder, setting the gzip compression to false in the "tiny_mce_config.php" file, turning off the google analytics plugin) but nothing worked!

    Do someone have a solution please ?

Topic Closed

This topic has been closed to new replies.

About this Topic