WordPress.org

Ready to get started?Download WordPress

Forums

124

2.5 Visual Editor/TinyMCE problems (97 posts)

  1. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    If TinyMCE is not loading properly or the editor is stuck in HTML mode and won't switch to Visual, there are several things to try and fix it:

    1. Make sure the "Use the visual editor" checkbox in your profile is selected.

    2. Clear your browser's cache, quit it, start it again, go back to the write page and force-reload it several times, while holding down Shift (Firefox) or Ctrl (IE).

    3. Delete both wp-admin and wp-includes directories and upload fresh copies from the WordPress installation package.

    4. In Firefox, go to the following URL:
    [your site]/wp-includes/js/tinymce/tiny_mce_config.php

    It should open a large text (JavaScript) file, first line starting with var tinyMCEPreInit = ... and last line starting with tinyMCE.init({mode:"none",....

      If it's a text file but doesn't start and end as above, it is being pulled from network cache somewhere between the computer and the server. Reloading it a few times while holding down Shift/Ctrl may force the cache to refresh. After this, go back to the write/edit page and refresh it again.
      If it's full with garbled characters, it usually means that compression on the server is enabled, but not set properly in php.ini. In this case either edit tiny_mce_config.php and change 'compress' => true, to 'compress' => false, to stop the compression of TinyMCE, or download this small plugin that will do it automatically.

    If TinyMCE loads properly but the "Add Link" or "Edit Image" pop-up doesn't work or show only empty frame, right-click in it and select Refresh while holding down Ctrl in IE, or This Frame -> Reload while holding down Shift in Firefox.

    This is the same caching issue as above, but affecting only the pop-ups. Try these URLs with Firefox:
    [your site]/wp-includes/js/tinymce/themes/advanced/js/link.js
    [your site]/wp-includes/js/tinymce/themes/advanced/js/image.js

    and force-refresh them several times to try to update the network cache.

    In any case, the pop-ups will start working after a few hours (or may be a day) when the cache is refreshed.

    And finally if none of the above fixes worked, try Firefox with Firebug and notice any js errors or any missing files (red 404s in the "Net" tab). If there are js errors, copy only the first one and see if it already has been discussed here, or open new thread with the specific error.

  2. bellasvenezolanas
    Member
    Posted 6 years ago #

    Hi. Did all that and still can't use the Visual editor...

  3. selfobliged
    Member
    Posted 6 years ago #

    the small plugin didn't work for me. I used TinyMCE advanced, and I have no probs after that, just need to clear your browser cache and good to go.

  4. selfobliged
    Member
    Posted 6 years ago #

    Sorry, forgot to mention, and the edition of tiny_mce_config.php and change 'compress' => true, to 'compress' => false,

  5. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    bellasvenezolanas, what are the js errors you see in Firebug?

  6. tomboersma
    Member
    Posted 6 years ago #

    Thanks a lot. The compressing wass the problem.

  7. artfulalibi
    Member
    Posted 6 years ago #

    I have done all of the above, including what selfobliged did, adding the TinyMCE advanced. And I still can not use the visual editor.

    This is the only error Firebug spits out:

    switchEditors.go is not a function
    onclick(click clientX=0, clientY=0)

    Please help. Thank you.

  8. artfulalibi
    Member
    Posted 6 years ago #

    Ah. Clearing cache and refreshing after adding the advanced editor, seems to have worked.

  9. DualFever
    Member
    Posted 6 years ago #

    I can't use the visual editor after those steps, i get the first 4 buttons to add media and a button to switch to html view or visual, both don't work.

    How do you revert to the old visual editor? the one that worked in 2.3.3?

    -Dual

  10. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    artfulalibi, the switchEditors functions are in /wp-admin/js/editor.js. Make sure this file exists and if not, repeat step 3 again as it seems it didn't work: delete both wp-admin and wp-includes directories and upload fresh copies.

    DualFever, what is the first js error when you load the page?

  11. hakre
    Member
    Posted 6 years ago #

    Additional Steps:

    1. Clear wp-content/uploads/js_cache
    2. Check if there is a Desktop Firewall. Whitelist your Blog

    Start to collect some Stuff in the Codex Wiki.

  12. jonbius
    Member
    Posted 6 years ago #

    I had the same problems folks are describing above, but none of the fixes seemed to work, and I could not identify the problem. So I did as all good web citizens do, I guessed and started pushing buttons.... :-)

    I had a plugin called Tiny Table installed, which put some tools to insert tables in the WYSIWYG toolbar. I deactivated that, and the problem was solved.

    'Course.... that's not much help if you don't have Tiny Table.... ;-)

    HTH!

  13. mirandasoft
    Member
    Posted 6 years ago #

    For a few days, I've been having problems with this, to the point I had to make an alternate site on WordPress.com.

    In my wordpress 2.5, I've been permanently stuck in HTML Editor mode when trying to post. My current suspicion is: Server-related problem

    I'm in Manila, Philippines and my webhosting service is in Colorado, USA. The common problem I've been having is... Network Error, which points to a TCP/IP configuration problem at the Server-level.

    In Mac OS X and Safari 3, I've identified the problem as a file not readable error, in respect to TinyMCE. My FTP program (Transmit) identifies the file is present and in tact, but that particular file continues to say, unreadable error, in both Safari and Firefox.

    Is there a permanent fix for WordPress 2.5 Visual Editor/TinyMCE problems? I need a solution, last week. I've tried the problems above, and the Visual Editor is stuck in HTML mode. I have a business to run and I don't have time to waste my time figuring out why I can't post the normal way, when instead, I can be posting as I did before. Due to this WordPress failure, I have two remaining choices left:
    1. Scrap WordPress 2.5 and install Joomla
    2. Or scrap all blogs and use iWeb to make a fixed, WORKING website.

    "I can't make an effective article in WordPress 2.5 HTML Editor... It's better to dump WordPress and go to something that's reliable."

    I operate The MirandaSoft Report, and can't post normally on my main website. I'm forced to have a WordPress.com website.

    If anyone has a Working Solution for me, please contact me, ASAP. Thanks!
    The MirandaSoft Report

  14. gtb
    Member
    Posted 6 years ago #

    I am having the exact same issue. I used the Advanced TinyMce plug in prior to 2.5 and never had any problems. As soon as I noticed the issue, I disabled the Plug-in and reinstalled WP and the prob elm still exists. I don't see that anyone wants to fix this real quick and so I may be forced to have revert to keep my business running as I cannot make comments etc in the current condition.

    This PROBLEM needs to be fixed quick !!!

  15. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @mirandasoft, did you try the step-by-step above? If yes, in step 3, were you able to delete that file?

    Also, which file is it? Did you contact your hosting company so they can have a look why it's not readable (servers can get disk errors too, but usually they are fixed before you even notice)?

    Also, what do you see in step 4? Did you delete the /wp-content/uploads/js-cache directory as hakre suggested?

    @gtb, did you try the step-by-step above? If yes, what is the first js error you see when loading the write page?

  16. mirandasoft
    Member
    Posted 6 years ago #

    Regarding the TinyMCE Advanced plugin:
    Uninstalled and Deactivated, 4 times. Deleted browser caches each attempt. HTML Editor.
    Deleted, Reinstalled, and Reactivated, 5 times. Deleted browser caches each attempt. HTML Editor.

    Step 3 Results:
    Deleting wp-admin directory deleted without any problems.
    Ownership of wp-includes/images/crystal is fixed at "70" and can't be deleted. Files in that directory have an octal of 644 with "70" as the owner and can't be deleted.
    Files in the wp=includes/js directory can't be deleted.
    I had to rename the wp-includes directory and move it to another section of the site for the webhosting company to delete the directory.

    Step 3 Ending Result: Same HTML Editor in Post, after deleting browser cache in firefox and safari. 15x refreshes.

    ** I have to break for breakfast... More details to come.

  17. mirandasoft
    Member
    Posted 6 years ago #

    Step 4 Results:
    a. Firefox displays a blank page.
    b. Uploaded patched tiny_mce_config.php file into /wp-includes/js/tinymce/ (Patched means compress = false not true)
    c. Large text file displays, no errors
    d. Nice HTML Editor appears when "Create New Post" is selected.
    e. Empty cache of browsers. Forced Reload, and back to d.

    Deleted files in /wp-content/uploads/js_cache
    Result is HTML Editor, 5x clear browser cache, 5x reloads

    Create New Post results:
    Add new media buttons are graphical.
    Clicking on "Visual" results in no changes.
    Clicking on "HTML" results in no changes.

    Verified /wp-admin/js/editor.js exists.

    Deleted files in /wp-content/uploads/js_cache
    Emptied Firefox browser cache.
    Reloaded "Create New Post"
    HTML Editor appears.

    Verified "Use the visual editor when writing" is checked under Users.

    Ending Result: HTML Editor

  18. mirandasoft
    Member
    Posted 6 years ago #

    Final Attempt Results by MirandaSoft...
    Primary Computer: Apple Mac Mini (Intel, Single core)

    1. Make sure the "Use the visual editor" checkbox in your profile is selected.
    Confirmed as checked.

    2. Clear your browser's cache, quit it, start it again, go back to the write page and force-reload it several times, while holding down Shift (Firefox) or Ctrl (IE).
    Performed in Safari Version 3.1 (4525.13) and Firefox 2.0.0.13. HTML Editor continues to show.

    3. Delete both wp-admin and wp-includes directories and upload fresh copies from the WordPress installation package.
    Performed in 30 minutes with multiple server disconnects. Had to do semi-automatic installations.

    4. In Firefox, go to the following URL:
    [your site]/wp-includes/js/tinymce/tiny_mce_config.php
    Uploaded patched tiny_mce_config.php file into /wp-includes/js/tinymce/ (Patched means compress = false not true)
    HTML Editor continues to show.

    Deleted files in /wp-content/uploads/js_cache
    Emptied Firefox browser cache.
    Reloaded "Create New Post"
    HTML Editor appears.

    Reply from MacHighway (Webhosting company): "I can verify that the problem isn't on this server as we have many customers successfully running WordPress on the gumby server."

    Total Time wasted in trying to fix WordPress problems: Over 4 Hours

    Summary: My original iWeb site has been uploaded as a REPLACEMENT for defective WordPress. WordPress will remain on the server with notications that updates may not happen due to WordPress Visual Editor/TinyMCE problems.

    Conclusion: WordPress.com site will be used for Blogging.

  19. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @mirandasoft, thanks for the detailed descriptions. There are couple of things that are irregular:

    1. The fact that there are files with unknown owner in your account and you cannot delete them.

    2. While uploading WordPress' files, the ftp timed-out/disconnected multiple times. Each time-out/disconnect may result in a corrupted file.

    If you decide to try this again, I think the proper way would be to rename the old installation directory of WordPress (if it was installed in a directory), then create a new one with the same name and try to upload all files with another ftp program, as the current one may not be fully compatible with the specific ftp server used by your hosting company (or perhaps the server was having some problems when you were uploading).

    The fact that there are many WordPress installations in other accounts on the same server suggests that it's working well.

    On the other hand having your blog hosted on wordpress.com is probably a better solution for your business, as if you get the commercial hosting there, you can customize it as much as you like and wouldn't have to worry about installations and upgrades.

  20. egoldin
    Member
    Posted 6 years ago #

    Hi,

    Just wanted to say thanks. I found the solution for this in the thread. This part solved my problem:

    Additional Steps:

    1. Clear wp-content/uploads/js_cache

    Thanks!

  21. donnie98125
    Member
    Posted 6 years ago #

    I'm another 'victim' of the Disappearing Visual Editor snafu. I un/reinstalled 2.5 three times, did all the lower level things, and I think it was indeed azaozz's fix - when I installed it and remembered to turn the plugin on, my visual editor showed up.

    Yikes, it was hairpulling times here, but thanks very much to all contributors.
    Don

  22. DeeJay Marrulla
    Member
    Posted 6 years ago #

    El mismisimo dia que wordpress anuncio la version 2.5 corri a instalarlo y me lleve la terrible sorpesa de que el editor visual no servia para nada. Intente varias cosas un par de horas y la solucion a todo fue ir al archivo mce_config.php y cambie 'compress' => true, to 'compress' => false, automaticamente refresque write post aparecio por primera vez en mi wordpress 2.5 el editor visual, vamos a ver como me va con eso, gracias a los posteadores de este foro, suerte panas.

  23. proximity2008
    Member
    Posted 6 years ago #

    I spent an age going through all the steps and no luck. Then I changed my theme to the default. This seemed to magically fix my TinyMCE problem. Now I have to work out why my theme breaks the editor....

  24. Peter Nemcok
    Member
    Posted 6 years ago #

    Thanks proximity2008, this exactly solved my problem. I have just changed my theme to default and back again and editor is working back again.

  25. gtb
    Member
    Posted 6 years ago #

    @azaozz PROBLEM IS SOLVED

    After trying all the steps again with no success, I installed the TinyMCE Advanced Plug-in, updated 3.0 Version and PROBLEM IS SOLVED.

  26. TheGekko
    Member
    Posted 6 years ago #

    I'm still having this issue persist after going through all of the mentioned steps, clearing cache, turning off javascript, reinstalling wp-admin and wp-inclue, checking if the visual editor is activated in the user account, modifying the tinyMCE config file, clearing my browser cache etc, etc,.

    The error which FireBug reports for me is as follows:

    tinyMCE is not defined
    go("content")editor.js (line 73)
    onclick(click clientX=0, clientY=0)post-new.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

    Please, I'm in dire need of assistance with regards to this problem! Any help you could provide is greatly appreciated!!

    Thanks,

    Gekko

  27. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @TheGekko did you see the large text/js file in step 4? If yes, what is the first js error you see when loading the page, "tinyMCE is not defined" means something is stopping it from loading properly.

  28. traprock
    Member
    Posted 6 years ago #

    There is a quick temporary (session by session) solution, if nothing else works. http://selectaffiliates.com
    It worked for me when none of the fixes here did, I tried them all.
    Still looking for a permanent fix.

  29. owencutajar
    Member
    Posted 6 years ago #

    Same here, can't get the tinyMCE editor to work on one of my blogs. All the others are fine. Tried all the steps above, but no luck

    Firebug report an Invalid Property ID in suggests.js Line 40 which reads:
    $results.bgiframe();

    Any ideas ?

  30. owencutajar
    Member
    Posted 6 years ago #

    Resolved the problem! I found this thread: http://wordpress.org/support/topic/166212?replies=3

    Which suggested WPLANG needed to be "en" in the config file. My installation has it set to " ". Changing it to "en" fixed the problem!

    Woohoo!!

124

Topic Closed

This topic has been closed to new replies.

About this Topic