WordPress.org

Ready to get started?Download WordPress

Forums

2.3.1 Serious Problem (19 posts)

  1. MitchellB
    Member
    Posted 6 years ago #

    Just upgraded to 2.3.1, and got errors all over the place.

    ns our destroyed. function wp_ob_end_flush_all() { while ( @ob_end_flush() ); } ?> post_status', '_transition_post_status', 5, 3); add_action('comment_form', 'wp_comment_form_unfiltered_html_nonce'); // Redirect Old Slugs add_action('template_redirect', 'wp_old_slug_redirect'); add_action('edit_post', 'wp_check_for_changed_slugs'); add_action('edit_form_advanced', 'wp_remember_old_slug'); ?> p_pre_kses_less_than_callback', $text); } function wp_pre_kses_less_than_callback( $matches ) { if ( false === strpos($matches[0], '>') ) return wp_specialchars($matches[0]); return $matches[0]; } ?> $file ) ? 'rtl' : "$file-rtl"; echo apply_filters( 'wp_admin_css', "\n", $rtl ); } } ?> mplate, true); clean_page_cache($post_id); global $wp_rewrite; $wp_rewrite->flush_rules(); } else { clean_post_cache($post_id); } } ?>> nction wp_prototype_before_jquery( $js_array ) { if ( false === $jquery = array_search( 'jquery', $js_array ) ) return $js_array; if ( false === $prototype = array_search( 'prototype', $js_array ) ) return $js_array; if ( $prototype < $jquery ) return $js_array; unset($js_array[$prototype]); array_splice( $js_array, $jquery, 0, 'prototype' ); return $js_array; } add_filter( 'print_scripts_array', 'wp_prototype_before_jquery' ); ?> ('hash_hmac') ) { return hash_hmac('md5', $data, $salt); } else { return md5($data . $salt); } } endif; ?>

    Sorry for the long code, but I can't decipher that at all. Something about hash, and some other stuff.

    I've gone to upgrade.php, got the same message and then WordPress told me everything was good to go.

    Any ideas?

  2. Chris_K
    Member
    Posted 6 years ago #

    What version did you upgrade from?
    Had you disabled plugins before the upgrade?

  3. MitchellB
    Member
    Posted 6 years ago #

    I upgraded from 2.3, I always keep up to date with the latest WordPress.
    And no, I didn't disable the plugins. I know I should have.

  4. Chris_K
    Member
    Posted 6 years ago #

    Do the errors persist after you log in, change theme to Default and disable plugins?

  5. MitchellB
    Member
    Posted 6 years ago #

    Yep. Enveere.org

    That's my website. It's on default, all the plugins are disabled.

  6. MitchellB
    Member
    Posted 6 years ago #

    Seriously, this is kind of a major problem right now.
    Did I do anything wrong?

  7. MitchellB
    Member
    Posted 6 years ago #

    Alright, I just downloaded and the uploaded WordPress. Fresh from the website, and I'm still getting the errors. MySQL is telling me that all of the databases are running fine.

    Still getting errors all over the place, even in the admin. Seriously, can anybody help me?

  8. moshu
    Member
    Posted 6 years ago #

    Did you ever use the Redirect Old Slugs plugin?

  9. MitchellB
    Member
    Posted 6 years ago #

    Never. Don't even have it on my server.

    But I've downgraded to 2.3.0, and everything is working. I'm not going to upgrade again. At least, not for a while.

  10. pozmu
    Member
    Posted 6 years ago #

    I have the same problem. What can it be?

  11. pozmu
    Member
    Posted 6 years ago #

    Weird. I had exatly same error. Transferred files again using Total Commander and everything works. I've used SmartFTP before.

  12. ANappyGirl
    Member
    Posted 6 years ago #

    WOW! Glad I didn't upgrade. Something told me to stay right where I am, and I'm going to do just that.

    I'm so sorry you guys are having problems with the upgrade.

  13. denialhost
    Member
    Posted 6 years ago #

    i upgrade and have no problems at all.. but just try to rewryte again or something.. the db have all the data of your post so you can even erase all the site and reinstall wordpress and keep everything on place.

  14. MitchellB
    Member
    Posted 6 years ago #

    I think I'll stick with 2.3.0 for now.
    No idea what the problem is, I'm using CyberDuck on Mac OSX.

  15. Storyman
    Member
    Posted 6 years ago #

    Updated 3 sites from 2.3 to 2.3.1 without any problems. Though in the future I think I'll wait several days after a new release. I'm taking this problem as a cautionary tale.

  16. zqw
    Member
    Posted 6 years ago #

    I have excactly the same problem with my site. I upgraded to 2.3 without any problems. Now, with 2.3.1 the following error message all over the site:

    mplate, true); clean_page_cache($post_id); global $wp_rewrite; $wp_rewrite->flush_rules(); } else { clean_post_cache($post_id); } } ?>> nction wp_prototype_before_jquery( $js_array ) { if ( false === $jquery = array_search( 'jquery', $js_array ) ) return $js_array; if ( false === $prototype = array_search( 'prototype', $js_array ) ) return $js_array; if ( $prototype < $jquery ) return $js_array; unset($js_array[$prototype]); array_splice( $js_array, $jquery, 0, 'prototype' ); return $js_array; } add_filter( 'print_scripts_array', 'wp_prototype_before_jquery' ); ?> ('hash_hmac') ) { return hash_hmac('md5', $data, $salt); } else { return md5($data . $salt); } } endif; ?> ?>

  17. zqw
    Member
    Posted 6 years ago #

    I just compared "broken codes" posted by me and MitchellB. They seem to be from the same part of the engine. MitchellB's code is longer, though. There must be something conflicting with something in certain set-up. :)

  18. ronocdh
    Member
    Posted 6 years ago #

    This hit me, too. I get the same message all over my site (also on the admin pages). When I upgraded, I got the same text as Mitchell in the OP.

  19. ronocdh
    Member
    Posted 6 years ago #

    I've downgraded to 2.3 by overwriting all the 2.3.1 files, and the ugly code has gone away. I'll stick with 2.3 for a bit yet, I think.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags