WordPress.org

Ready to get started?Download WordPress

Forums

2.3.1 not showing visual editor (46 posts)

  1. cholito
    Member
    Posted 6 years ago #

    Hi!

    I just made a fresh install of WP 2.3.1 and it seems that I'm not able to use the rich visual editor.

    I've enable it in the user profile.
    http://img158.imageshack.us/img158/8553/profileoptionsfq6.png

    I've also cleared my cache and tried it with Opera, IE6 and FF2 and the same problem.

  2. ecstatic
    Member
    Posted 6 years ago #

    I don't think it's the 2.3.1 version that's at fault, I have the same problem and when I restored to the pre-upgrade backup it's still there. There's another post by someone else about the same thing, so it's not just us.

  3. ecstatic
    Member
    Posted 6 years ago #

    Or maybe not? I made another test blog and that one's doing the same thing.

  4. cholito
    Member
    Posted 6 years ago #

    Same thing as mine?

  5. ecstatic
    Member
    Posted 6 years ago #

    It's a computer thing. I just logged into my site from a spare laptop and they both work perfectly, still won't work from my desktop though. I've done the whole clearing cache etc stuff. Maybe there's a security setting somewhere.

  6. ecstatic
    Member
    Posted 6 years ago #

    Aaaaahhh. I turn off Kasperski Security Suite and it all starts working. Wonder 's what's in that that could cause it. Soon find out...

    ...it's the web antivirus module that's causing it. I turn just that bit off and everything is fine.

    Sorry I missed your question. I'm assuming its the same, even with the box ticked there's no toolbar for text formatting, all you get is the code window.

    Fixed on mine now, in KAV Web Anti-virus settings I had streaming scan (whatever that means) set, switch that to buffering scan and all works fine.

    I'm really sorry if this doesn't relate to your problem, I'd got this far assuming it was the same and its too late to go back now.

  7. ceo
    Member
    Posted 6 years ago #

    Try adding your website to your "safe" list if you can.

  8. cholito
    Member
    Posted 6 years ago #

    I only have AVG antivirus and ZoneAlarm Firewall and there is no option in neither program to add my web to a save place. Any other idea? =(

  9. ceo
    Member
    Posted 6 years ago #

    Hmmm, depending on what browser your using it could just be blocking the WYSIWYG as an ad -- I know Firefox with ABP blocks rather mundane things like those popup window things when you hover over links (which personally I find annoying and don't mind that it does that).

    I guess I'm not being too helpful, I'm sorry.

  10. cholito
    Member
    Posted 6 years ago #

    It's not that as I tried with Firefox 2, Opera 9 and IE6 and none of them showed the visual editor =/

  11. cholito
    Member
    Posted 6 years ago #

    fresh install again, and same problem. Any plugin to use a visual editor will not work :(

  12. maidanet
    Member
    Posted 6 years ago #

    I'm having the same issue with 2.3.1 on GoDaddy hosting. No visual editor, even though I enabled it in my profile.

    I have tried both Firefox and IE - no visual editor.

    I might have to downgrade to 2.0.7 if I can't get this working soon.

    What changed in the coding this version to make this a problem? I have used WordPress the past 3 years without a problem with the visual editor...

  13. cholito
    Member
    Posted 6 years ago #

    What changed in the coding this version to make this a problem? I have used WordPress the past 3 years without a problem with the visual editor...

    Same here. I'm glad I'm not the only one! Can anyone help us with this? =/

  14. cholito
    Member
    Posted 6 years ago #

    Re-uploaded the files, and nothing. Fresh install again, and nothing. Anyone else having this problem?

  15. drummergirl
    Member
    Posted 6 years ago #

    Same here -I came to the forums to see what gives. I had no problems until this weekend when my web host did an upgrade and enabled phpsuexec on my server. I had all sorts of problems at first that took some ironing out. Now the only thing left is the visual editor issue. I don't know if this is a clue, but I can disable all plugins and get the editor back. I can then reactivate all plugins and the editor is there and working just fine. Now if I wander off and come back a few hours later, the editor is gone. I don't get it. I've done the browser checks and cache clearing. Still nada.

  16. cholito
    Member
    Posted 6 years ago #

    So, do we have to make an old-install because of this?

  17. drummergirl
    Member
    Posted 6 years ago #

    FWIW I just solved my issues with the visual editor not displaying...as I mentioned above, my web host had setup phpsuexec on my server, which hosed a lot of stuff. I figured that tinymce just wasn't fully loading at times, so uploaded a php.ini file to this directory:

    wp-includes/js/tinymce

    the file contains two lines:

    memory_limit = 32M
    output_buffering = On

    This seems to have fixed it for me. Hope it helps someone else. :)

  18. kevaleb
    Member
    Posted 6 years ago #

    When you say visual editor do you mean that you are unable to post new pages or posts. and is there somewhere that I can download that php.ini file so that I can upload it?

  19. drummergirl
    Member
    Posted 6 years ago #

    By "visual editor" I meant I was missing the "toolbar" that has the formatting options for text when editing a post. I could still create and publish a post, but I had to type in all the html tags myself.

    To create the php.ini file, just paste those two lines in a plain text file and save it as php.ini. That's all I did before uploading it.

  20. cholito
    Member
    Posted 6 years ago #

    it doesn't worked for me :(
    see here

  21. moture
    Member
    Posted 6 years ago #

    Exactly the same problem.

    php.ini file did nothing. Thanks for trying. I'd really like this fixed? 2.3.2?

  22. pdiamond
    Member
    Posted 6 years ago #

    I have tried all these fixes for WP 2.3.1 and still nothing. I have deleted WP-includes and reloaded, I have backed up the db and reloaded WP from scratch, I have tried a plugin to enhance the editor, and a few more things but nothing. I am about ready to downgrade my WP version to an earlier version.
    Can anyone help with this issue? I see tons of threads here with the same problem but with no workable solution.

  23. bigsquaredot
    Member
    Posted 6 years ago #

    The same issue came up for me while installing the latest version of WordPress on a client's web server. The only solution that I could come up with was to disable the visual editor mode (user profile panel) and install the WYSIWYG plugin for WP from the following URL: http://mudbomb.com/archives/2005/02/02/wysiwyg-plugin-for-wordpress/

    Not the prettiest solution but until the developers at WP get this issue fixed, I'm afraid it might be one of the only solutions.

  24. pdiamond
    Member
    Posted 6 years ago #

    Ok, here is what I did and I have no idea why, but it worked. I renamed all folders under the root ex: :wp-admin_old" and then uploaded a freshly downloaded version. I did not clear the DB so when the new files were loaded I just signed in and went to write a post but still no visual editor. I cleared my browser cache and also using "ctrl-F5" I reloaded the editor page and still nothing. I exited the browser and went back in and all of the sudden the visual editor was working. To install my plugins I just renamed the old wp-content file back to normal and now everything (plugins Inc.)is back and working.
    Mot sure what I actually accomplished but the WYSIWYG editor is working fine.

  25. cholito
    Member
    Posted 6 years ago #

    well, that's like playing the lotery. Anyway, I'm using mudbomb's plugin. Althou it works, I think it's not normal that the original plugin don't work out of the box...

  26. livethelife
    Member
    Posted 6 years ago #

    Hi,

    I have the same problem. All of a sudden I do see the toolbar, but not the buttons for the video plugins and contact form. On another laptop it does work, so think it's Firefox, it was updated 15/11. Will try to donwload the old version, hope it works. Any other suggestions ?
    Thanks

  27. cholito
    Member
    Posted 6 years ago #

    I just tried with firefox 2.0.0.11 and still doesn't work, neither work with IE 7.0.5730.11IC

    Anyone else had tried in other versions?

  28. webDressing
    Member
    Posted 6 years ago #

    It's a browser issue. We can't get it to work with IE. We switched away fro IE to Safari 3.0 and it is working great. It's also working in firefox 2.0.0.11. Also, make sure it's turned on in your WP profile.

  29. cholito
    Member
    Posted 6 years ago #

    Browser which has been tested:

    IE 7.0.5730.11IC
    Opera 9.50
    Firefox 2.0.0.11

    None of these show the visual editor :(

  30. WPLady
    Member
    Posted 6 years ago #

    Been interesting reading all the posts regarding the visual editor not working. I too am having problems. The last time the visual editor worked for me was in 2.2. I'm going to downgrade. All the problems is not worth the fight in trying to get the visual editor to work with the new versions. With all the post regarding this, there is something wrong.

Topic Closed

This topic has been closed to new replies.

About this Topic