WordPress.org

Ready to get started?Download WordPress

Forums

2.2 Admin Area really slow (19 posts)

  1. SpencerLavery
    Member
    Posted 7 years ago #

    Hi guys,

    Been using WordPress for years and always been impressed with the speed of the admin area, but my most recent site uses a fresh install of 2.2 and the whole admin area is painfully slow.

    I have a shared hosting package with a few of my own sites on the same cluster. The other sites are running older versions of WordPress and they're still running pretty fast. The front-end of the problematic web site is also slow but only on pages with any WordPress content.

    Is there anything I should/could do to the database to optimise things?

    Site in question is http://phobea.com/index.php, let me know if it's loading any faster with you.

    Only plugins I have running are Askiment, iMP Slimbox and Audio Player, not using wp-cache on any of the sites as I understand it doesn't work with 2.2 yet and plan to upgrade the other sites.

  2. SpencerLavery
    Member
    Posted 7 years ago #

    I have also just noticed a pattern in the load times, they are all between 40-41 seconds in the Admin Area. Which suggests to me that it's looking for something it can't find and set to give up trying after 40 seconds. Any ideas what it might be?

  3. SpencerLavery
    Member
    Posted 7 years ago #

    Have also just noticed that my feeds aren't working (but aren't displaying the 404 page - permalink error?):

    http://phobea.com/feed/

    Sorry, fixed this feed issue. Entirely separate I think.

  4. Vince2006
    Member
    Posted 7 years ago #

    I have only seen this happen once befoe with 2.2 and that's when a friend of mine didn't do a database back-up and didn't follow the wordpress upgrade exactly.

    Upgrading WordPress

    He had some issues like youra as well because he had a mix of older and newer files in his install.

    Another thing... there is a new wp-config-sample.php file in 2.2 . Did you by channce change anything in that file before renaming it to wp-config.php?

    Vince

  5. SpencerLavery
    Member
    Posted 7 years ago #

    Hi Vince,

    Thanks for the reply, but this is a completely fresh install not an upgrade. Completely fresh and completely vanilla I'm experiencing these same problems.

    This is the contents of my wp-config file if it helps at all:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'phobea_wordpress');    // The name of the database
    define('DB_USER', 'phobea_wordpress');     // Your MySQL username
    define('DB_PASSWORD', 'XXXXXXXX'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'en');
    
    /* That's all, stop editing! Happy blogging. */
    
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    As a sidenote - all of the plugins that I mentioned I have installed have been disabled but didn't fix the problem so have been re-enabled. Same with the theme. As I noted the Admin Area is just as slow.

  6. Vince2006
    Member
    Posted 7 years ago #

    Looks fine as long as you have a file called en.mo under /wp-content/languages/ .

    If that file doesn't exist, you need to either have it or just change this:

    define ('WPLANG', 'en');

    To:
    define ('WPLANG', '');

    If you don't have the language directory and / or the corresponding en.mo file, then perhaps WP is looking for something it can't find? Not really sure though... I don't use any specific language files since all of my installs are in english. I leave the line as:

    define ('WPLANG', '');

    which defaults to english anyway.

    Vince

  7. SpencerLavery
    Member
    Posted 7 years ago #

    I only changed that a few minutes ago so it can't have been that. I wasn't aware that it looked for a file though, I thought it pertained to the language attributes that it places in the HTML declaration. I may as well switch it back if that's the default anyway.

  8. Vince2006
    Member
    Posted 7 years ago #

    Yeah, I just tried adding the 'en' to a sandbox site and it didn't cause any errors or slow load times.

    Is it possible it's theme related?

    Try changing to the default or classic theme and disable all plug-ins and see if that speeds anything up.

    I was able to ping your domain and server with no problems but there is always a possibility that the 'DB' is having issues, however you said that you have other domains on with the same hosting company but are they both on the same physical server or different ones?

    If your site is on a different server than the sites you say work fine, then it is possible that the resources are limited due to another client on the server you are on, may be using up database resources.

    Vince

  9. SpencerLavery
    Member
    Posted 7 years ago #

    Hi Vince,

    Thanks for you help by the way.

    I think I said above but the actual Admin Area is the part causing the headache, and that's not themed at all. Just to rule it out I have gone back to the default theme, disabled all plugins, and made it completely vanilla, to no avail.

    I've also contacted my host who's double checked everything and says that the site's not functioning slowly in any way. Resource usage for both MySQL and Apache are very low with plenty of room for play, and yes as you suspected they are on exactly the same server as the sites that are running fine.

    I also have static pages on this same domain that don't have any WordPress content or code on them at all and they're loading instantly. My FTP transfers are faster than usual, as are regular HTTP requests for files such as JPEGs.

    The DB is the only bottleneck I can envisage but I've logged in with SQLyog to have a look aruond and it all seems fine. I've also disabled Pings and removed the pingomatic reference to see if that had any effect but it didn't.

    I'm seriously stumped.

  10. Vince2006
    Member
    Posted 7 years ago #

    Hey I just revisted your site and the pages are loading very fast now even on a second computer I am using.

  11. Vince2006
    Member
    Posted 7 years ago #

    Ok forget what I said, since the issue is in the admin area only.

    Is the version of 2.2 you are using, the latest download?

  12. SpencerLavery
    Member
    Posted 7 years ago #

    The weirdest thing just happened. I did absolutely nothing and the issue has completely resolved itself.

    I'm just emailing my host now to ask if he has restarted the server or made any other changes that might have fixed this. I'll keep this thread updated in case anybody else experiences similar problems.

    Typical that I've been working on this site all day with these problems and just as I'm about to call it a day it starts working properly.

  13. Vince2006
    Member
    Posted 7 years ago #

    I have seen issues like that and once I rebooted my box, all was good too so hopefully this topic will help others as well.

    By the way, I visited phobea.com/ without the index.php, followed the link to your personal site, and now have become a fan of Feist!

    Best of luck man - Oh and I'll keep watching Phobea to see if you play in Tulsa!

  14. SpencerLavery
    Member
    Posted 7 years ago #

    Feist is incredible! She's on a tour at the moment so definitely keep your eye out. As for Phobea, I'm lucky enough to get a local gig these days :)

    This site's died a death again all of a sudden though, blank pages throughout the front-end. One problem after another today lol :) Gotta get error reporting turned on then get back to it now.

  15. SpencerLavery
    Member
    Posted 7 years ago #

    This is an email I've just received from my host regarding the loading times:

    Hi Spencer

    No, haven't noticed anything else going on with the mysql server or apache server. Unfortunately I don't know too much about wordpress to be able to debug it efficiently.

    It does appear though, that each apache process that gets created when you go to your webpage takes up to 99% CPU power for that burst of 30-40 seconds. I don't think it's the server killing off the process or we would be alerted to it, which we are not.

    Regards
    Tony

  16. SpencerLavery
    Member
    Posted 7 years ago #

    Re-uploaded absolutely everything and that's fixed the blank pages, must have been a permissions problem.

  17. Vince2006
    Member
    Posted 7 years ago #

    You know man, that was the last thing I was going to say, to re-install the whole darn thing! lol

    Glad it all worked out in any event. Keep plugging away with the jams!

    Vince

  18. SteveFree
    Member
    Posted 6 years ago #

    I'm having the same problem. Site is lightning fast but the admin pages take 30 seconds to load. When I look at my mySQL server, it shows the process sleep for 30 seconds then after 30 seconds, bam, it processes the request.

    Odd....

  19. SpencerLavery
    Member
    Posted 6 years ago #

    Try re-uploading the lot, as my problem appeared to be entirely permissions based.

    Are you experiencing this with 2.3.1? If possible have your host switch PHP Error Reporting on, if you're seeing blank pages.

    Might you have any conflicting url rewrite rules? 30 seconds make it seem as though the browser's being pointed in a few different directions before making the database call.

Topic Closed

This topic has been closed to new replies.

About this Topic