WordPress.org

Ready to get started?Download WordPress

Forums

2.0.3 shows as 2.0 in Admin footer (19 posts)

  1. billsaysthis
    Member
    Posted 8 years ago #

    I updated the blog as per the instructions and everything seems fine except for the odd version in Admin page footers. Anyone else seeing this or can it be something about my install? I used the 2.0.1 to 2.0.3 upgrade instructions, even though I had 2.0.2 installed, and afterwards got the "You need to run the upgrade script" message. Despite the instruction saying that isn't necessary I ran it anyway.

  2. Mark Jaquith
    WordPress Lead Dev
    Posted 8 years ago #

    Don't know what to say about the version number. That's bizarre.

    An upgrade of the database, however, is required for 2.0.2 to 2.0.3

  3. deko
    Member
    Posted 8 years ago #

    I think the idea of "upgrade the database" is misleading.

    Does this mean I have to upgrade MySql?

  4. Jonathan Landrum
    Member
    Posted 8 years ago #

    Mine is showing 2.0.3. So I don't think it's a bug. Maybe some bits got misplaced during your FTP session.

  5. Chris_K
    Member
    Posted 8 years ago #

    @billsaysthis: I'd reupload the WP files.

    I see this in your pages:
    <meta name="generator" content="WordPress 2.0.2" />

  6. Chris_K
    Member
    Posted 8 years ago #

    @deko - no. you need to run the wp-admin/upgrade.php script. But I think you already have based on another thread.

  7. deko
    Member
    Posted 8 years ago #

    @HandySolo - yes, I understand. But you see how that message is misleading? I think "Click here to nurp your installation" would have been easier to understand. :)

  8. Chris_K
    Member
    Posted 8 years ago #

    Quick! Someone go add "Nurp" to wikipedia.com. :-D

  9. Jonathan Landrum
    Member
    Posted 8 years ago #

    Somebody beat us to it: http://en.wikipedia.org/wiki/Nurp

  10. billsaysthis
    Member
    Posted 8 years ago #

    Handy, thanks for the response. However, I was referring to my company's blog (http://blog.rawsugar.com/blog) and not the personal one linked to my username here.

  11. Chris_K
    Member
    Posted 8 years ago #

    @bill - well... same deal then:
    <meta name="generator" content="WordPress 2.0" />

  12. billsaysthis
    Member
    Posted 8 years ago #

    Right, but I was using 2.0.2 before yesterday and updated by deleting the entire folders, not overwriting them. So even if there was an issue with the updated files not being FTPed the version number should be 2.0.2 and not 2.0.

  13. evilzenscientist
    Member
    Posted 8 years ago #

    Hmm - mine went in from 2.0.2 to 2.0.3 - my footer shows 2.0.3 and I've got:

    <meta name="generator" content="WordPress 2.0.3" />

    If that helps..

  14. billsaysthis
    Member
    Posted 8 years ago #

    My header.php has the normal bloginfo('version') call, so I'm assuming that for some reason the update script didn't change the db field. My question is why not and is this indicative of something else wrong, though there's nothing visible.

  15. arnee
    Member
    Posted 8 years ago #

    Hi,

    the version info is stored in wp-includes/version.php

    The file size of the 2.0.2 version and the new one is exactly the same, so maybe four FTP program skipped that file. Ensure that the version variable in this file is correct and try to upload the file again. If your FTP program skips this file again, delete it before starting the upload.

  16. spencerp
    Member
    Posted 8 years ago #

    arnee is correct about the version being stored in the:
    wp-includes/version.php file.

    Sometimes while FTP-ing stuff, it doesn't fully overwrite the files and stuff..

    That's why I always delete the files, even the images in the FTP directory, and then re-upload them, just to be sure.. I know some of you have done this already..so maybe it's just something with your FTP clients or whatever, maybe..skipping stuff or something...

    spencerp

  17. billsaysthis
    Member
    Posted 8 years ago #

    Guys I appreciate the responses but as I mentioned twice before I did delete the old files before uploading so I don't see how the particular problem you mentioned could be the problem and even so the version would be reported as 2.0.2, not 2.0.

    Looking at the file you named, it says:

    $wp_version = '2.0';
    $wp_db_version = 3308;

    Weird, eh?

  18. moshu
    Member
    Posted 8 years ago #

    Stupid question... Are you sure you uploaded the right package? I mean I know I have several versions stored on my HD and, unless I rename them, they all are in a "wordpress" folder :)

  19. billsaysthis
    Member
    Posted 8 years ago #

    I did recheck after noticing, moshu. All the files had the 2.0.3 sizes and dates. But I just redid the upgrade and the problem went away. Weird but probably my fault.

Topic Closed

This topic has been closed to new replies.

About this Topic