WordPress.org

Ready to get started?Download WordPress

Forums

2.0.3 & Blogger import (33 posts)

  1. calvinccc
    Member
    Posted 8 years ago #

    Hi all,

    I'm having trouble importing my posts from Blogger into WordPress (2.0.3). I've successfully imported posts from this blog to my local machine (running an older version of WordPress). I've got 2.0.3 running on my web host. After I've logged into my Blogger account from within the WordPress importer window, then selected the title of the blog, it "crashes" at blog-publishing. With...

    Error on form submission. Retry or reset the importer.

    Followed by some undecipherable code:


    Array ( [code] => 200 [header] => Array ( [Date] => Sat, 01 Jul 2006 05:22:48 GMT [Server] => Apache [Set-Cookie] => ServerID=1288; Domain=.blogger.com; Path=/ PyraID2=; Expires=Thu, 01-Jan-1970 00:00:10 GMT I=; Domain=www.blogger.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT
    ...

    The rest of the page looks like an unformatted 'Dashboard' page in Blogger.

    Any help would be great. Thanks.

  2. taintme
    Member
    Posted 8 years ago #

    i am recievieng the same error.
    Error on form submission. Retry or reset the importer.
    Array ( [code] => 200 [header] => Array ( [Date] => Sun, 02 Jul 2006 07:15:40 GMT [Server] => Apache [Set-Cookie] => ServerID=1571; Domain=.blogger.com; Path=/ PyraID2=; Expires=Thu, 01-Jan-1970 00:00:10 GMT I=; Domain=www.blogger.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT I=SQinPLwwBAAA=.WtlvVlfokQXIJFl/tfV2hw==.bz9d8oSZ98CJsfWoNyxuNA==; Domain=.blogger.com; Path=/ B1I=heyitsgayj&; Domain=.blogger.com; Path=/ NSC_cmphhfs-fyu=0a1402230050;Version=1;Max-Age=1800;path=/ [Cache-control] => no-cache [Pragma] => no-cache [displaylang] => en [Content-Length] => 6866 [Content-Type] => text/html; charset=UTF-8 ) [cookies] => Array ( [0] => Cookie: ServerID=1571; Domain=.blogger.com; Path=/ [1] => Cookie: PyraID2=; Expires=Thu, 01-Jan-1970 00:00:10 GMT [2] => Cookie: I=; Domain=www.blogger.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT [3] => Cookie: I=SQinPLwwBAAA=.WtlvVlfokQXIJFl/tfV2hw==.bz9d8oSZ98CJsfWoNyxuNA==; Domain=.blogger.com; Path=/ [4] => Cookie: B1I=heyitsaj&; Domain=.blogger.com; Path=/ [5] => Cookie: NSC_cmphhfs-fyu=0a1402230050;Version=1;Max-Age=1800;path=/ [6] => Cookie: ) [body] =>
    perhaps a blogger issue..re: date 01june 1970

    help...thanks

  3. evilspock
    Member
    Posted 8 years ago #

    Trying to get this going with my wife's site and having the same exact problem. I'm really trying to get her off of Blogger. Anyone have a fix?

  4. eireoxford
    Member
    Posted 8 years ago #

    HOORAY!

    I'm so glad to see I'm not the only one having this issue. I have a brand new WP 2.0.3 install provided by my webhost (Netfirms.com) from two days ago and am getting a similar error while running the Blogger import script.

    Thinking it might have something to do with the 01 June 1970 cookie, I've cleared my browser's cache and deleted cookies but each time have the same result:

    Error on form submission. Retry or reset the importer.
    Array ( [code] => 200 [header] => Array ( [Date] => Wed, 05 Jul 2006 14:15:22 GMT [Server] => Apache [Set-Cookie] => ServerID=1301; Domain=.blogger.com; Path=/ PyraID2=; Expires=Thu, 01-Jan-1970 00:00:10 GMT I=; Domain=www.blogger.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT I=SW3rCQAwBAAA=.dl7gEo9R5AzMKUpRQ2NSAw==.En78Fi0CMomjGAoG3U9Nmw==; Domain=.blogger.com; Path=/ B1I=EireOxford&; Domain=.blogger.com; Path=/ NSC_cmphhfs-fyu=0a1401150050;Version=1;Max-Age=1800;path=/ [Cache-control] => no-cache [Pragma] => no-cache [displaylang] => en [Content-Length] => 6899 [Content-Type] => text/html; charset=UTF-8 ) [cookies] => Array ( [0] => Cookie: ServerID=1301; Domain=.blogger.com; Path=/ [1] => Cookie: PyraID2=; Expires=Thu, 01-Jan-1970 00:00:10 GMT [2] => Cookie: I=; Domain=www.blogger.com; Expires=Thu, 01-Jan-1970 00:00:10 GMT [3] => Cookie: I=SW3rCQAwBAAA=.dl7gEo9R5AzMKUpRQ2NSAw==.En78Fi0CMomjGAoG3U9Nmw==; Domain=.blogger.com; Path=/ [4] => Cookie: B1I=EireOxford&; Domain=.blogger.com; Path=/ [5] => Cookie: NSC_cmphhfs-fyu=0a1401150050;Version=1;Max-Age=1800;path=/ [6] => Cookie: ) [body] =>

    Terradyme: Trials and Tribulations
    ← Back to Dashboard ? Help x Sign Out

    Any help would be appreciated by many!

  5. kimbahlee
    Member
    Posted 8 years ago #

    Me too, identical! Any updates on this?

  6. taintme
    Member
    Posted 8 years ago #

    i still get the same message as above ....but if i reset the importer right away and tryagain it seems rto work all the way till the end...it says its published 100 percent of my files...then i get this line:

    malformedYour Blogger blog did not take the new template or did not respond

  7. edpaffjr
    Member
    Posted 8 years ago #

    I'm having this problem as well. I've used the importer before with no problems but when I went to do it a final time it is no longer working. Any advice would be appreciated.

  8. 5purposedriven
    Member
    Posted 8 years ago #

    I can't get mind to go beyond the last publishing step going from blogger either. Stuck at 2% with an "error on page error."

    I've tried a couple days apart...same problem. Tried changing dates and settings in blogger first...no help.

  9. gpaciga
    Member
    Posted 8 years ago #

    I'm having the same error described in the original post. At the blog-publishing stage, the importer prints an array like those already shown and a text version of the Dashboard page which sets the publishing settings. It looks like it was trying to set the blog to publish to Blog*Spot, but hit an error. Any help would be greatly appreciated.

  10. gpaciga
    Member
    Posted 8 years ago #

    Sorry for the double post but I don't think I can edit my last one... It turns out that once in a while (maybe 1 in 5 tried) the importer gets past the error at blog-publishing, but then after publishing 100% I get the same error as taintme:

    malformedYour Blogger blog did not take the new template or did not respond

  11. eireoxford
    Member
    Posted 8 years ago #

    I wrote Skeltoac, who according to this page is the author of the blogger import script, on July 5th, but have had no response.

    http://www.skeltoac.com/2005/03/12/

  12. Carlos Alonso
    Member
    Posted 8 years ago #

    same error here. it seems it's a bug from the 2.0.3 version, I think. I'm uninstalling WP and waiting for 2.0.4 to come.

  13. gpaciga
    Member
    Posted 8 years ago #

    I noticed when the Blogger page is displayed after spitting out that array, the fields all have a backslash and quotation mark like \"this\" where I wouldn't expect them (i.e. the blogspot subdomain field). Might this be causing the "malformed" error later on, or is it just an artefact of printing the data? There are some other threads about backslashes creeping in where they shouldn't in 2.0.3.

  14. Carlos Alonso
    Member
    Posted 8 years ago #

    http://trac.wordpress.org/query?status=closed&milestone=2.0.4

    Here you can see a list of errors that'd been fixed in the next release of WP (due in 4 days!). Maybe the first one, called import problems, fixes our problem, we'll see this weekend.

  15. gpaciga
    Member
    Posted 7 years ago #

    The details only mention Textpattern and Dotclear, so it doesn't sound like it....

    I tried getting an account on wordpress.com and importing my blogger blog there, but encountered the same error. That makes me think it's a problem with Blogger, and I'm doomed to copy and paste each entry manually :(

  16. taintme
    Member
    Posted 7 years ago #

    although this isnt a fix by any means..i have managed to port over the first 100 in one shot this way:
    in blogger i set the number of posts to show on page to 999
    ( in publishing )
    then republished.
    then set up my own feed at feedburner and subscribed to it through netnewswire...
    and downloaded the feed address.
    Then in wp i chose import rss feed..
    got about 100 post through that...just a lame sort of hack ..but considering i have over a thousand posts waiting to be imported..im trying anythng i can.

  17. gpaciga
    Member
    Posted 7 years ago #

    I took a look at your idea, taintme, and yeah, it seems like the atom feed blogger puts out only has 100 posts. You could delete the posts successfully imported, republish, and important again since the atom feed will have the next 100 posts. Marking them as draft, so you don't loose them from Blogger all together, should have the same effect. You're still stuck doing comments manually though. Once I get my template the way I want, if this problem isn't fixed, I'll do the feedburner RSS import.

  18. matthawke
    Member
    Posted 7 years ago #

    I found a reference somewhere which says that this import tool only works if you publish to blogspot.com. I changed over to blogspot.com to test and was able to convert.

    Unfortunately the converter lost all my bold/italic formatting... However, the text is now there in my shiny new WP blog!

  19. Carlos Alonso
    Member
    Posted 7 years ago #

    how did you do it? simply change your publishing preferences in blogger to blogspot, and republish the entire blog, isn't it? and then run the importer?

    I thought about it, but for some reason discarded it. I'll try when i get back at home.

  20. startspark
    Member
    Posted 7 years ago #

    That seems to make it work better, but it doesn't finish - it goes through all the steps then gives me

    "Not Acceptable
    An appropriate representation of the requested resource /(subdirectory)/wp-admin/admin.php could not be found on this server."

    Any suggestions?

  21. gpaciga
    Member
    Posted 7 years ago #

    Hmmm... I tried switching to blogspot too, but I still got the same errors.

  22. Carlos Alonso
    Member
    Posted 7 years ago #

    it worked fine with me!!

    great!

  23. startspark
    Member
    Posted 7 years ago #

    Ok, now I got it to work - after switching my Blogger to publish on blogspot, I had to add the following to my .htaccess file:

    SecFilterEngine Off

  24. gpaciga
    Member
    Posted 7 years ago #

    To which .htaccess file? One in your wordpress directory? That seemst to do nothing but cause a whole lot of Error 500's for me.

  25. olafmol
    Member
    Posted 7 years ago #

    this is indeed a bug, when switching to blogspot it works ok

  26. gpaciga
    Member
    Posted 7 years ago #

    Well, it didn't work the first time, but switching to publish on BlogSpot and then publishing worked this last time. It froze halfway through so I didn't get all my entries, but at least it's working. One or two more runs and I should be able to get everything.

  27. prince747
    Member
    Posted 7 years ago #

    hi.
    i wanna install wordpress software on my blogger account.howevr i don know the procedure to doin myself.
    kindly someone help me out of this..

  28. gpaciga
    Member
    Posted 7 years ago #

    The import is still *very* buggy... it freezes at different points, sometimes skips every entry, and is generally unrealiable all over.

  29. kenop
    Member
    Posted 7 years ago #

    Hi all. I'm having the same headaches when it comes to importing files from Blogger.

    I did manage to get to 75% finally after trying DOZENS of times, and even the 75% it brought over was maybe 30% skipped.

    My question is, since it's already published to blogspot using the required WP special template formatting.. ie:

    <wordpresspost>7/30/2004 04:25:03 PM|W|P|blogname|W|P|titleofpost

    Blahblahblah blah blah blah post content blah blah.

    Can I somehow dump each month's worth of formatted posts into a text file and direct WP to import directly from that?

  30. edpaffjr
    Member
    Posted 7 years ago #

    I was also able to get the import working after switching to blogspot. It did take a few tries but in the end I believe that every post is now there. Thankfully I am now using wordpress and no longer have to worry about it.

Topic Closed

This topic has been closed to new replies.

About this Topic