WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 2010 theme not loading properly and no access to dashboar for subdirectory sites (14 posts)

  1. japk
    Member
    Posted 3 years ago #

    Hello,

    I've just installed multisite on my home blog http://jessicaklein.ca/ and successfully activated it and added the site http://jessicaklein.ca/portfolio/ which shows up under 'my sites' and 'sites', however I cant access the dashboard for it, and its not rendering the theme. Here is how I've configured htaccess:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    its hosted on justhost...I've checked db permissions and the blogs.dir permissions, they are set to "all" and "755"

    Not sure what's gone wrong. I wasn't certain on how to create the directory blogs.dir using cpanel. I added a new folder and named it blogs.dir. The extra network tables are present in the db.

    Thanks for the help.

  2. japk
    Member
    Posted 3 years ago #

    I'm contacting my host to see if the problem is with the htaccess file changes not being made--from another thread, it sounds like it must have to do with that file...

  3. japk
    Member
    Posted 3 years ago #

    now all my sites are down and I can't access cpanel....
    "error 101 (net::ERR_CONNECTION_RESET): Unknown error."

    I have contacted my host server again for help. Any insight appreciated!

  4. That's definitely on the host end.

  5. japk
    Member
    Posted 3 years ago #

    well my host didn't have much to say, only that 'I can be sure the mod-rewrite is enabled and works properly'. My sites came back online on their own and I regained access to cpanel. I think I might try reinstalling.

  6. Check if allow override is set to include and all (your host can tell you this).

  7. amadeus39
    Member
    Posted 3 years ago #

    I'm experiencing what I think is the same problem as Jessica at one of my WPMU installs, but not at another.

    The site having the problem also has some remnants of a non-WP php program, so I'm thinking conflicts are possible there, despite my having installed WPMU in it's own sub-directory.

  8. Please make a new post for your issue. Not the same and it will make it HARDER to help either of you in one post.

  9. japk
    Member
    Posted 3 years ago #

    This back from my host:

    AllowOverride is set to ALL

  10. amadeus39
    Member
    Posted 3 years ago #

    @Jessica or Ipstenua : where is "AllowOverride" ?

    The solution to my similar issue as Jessica's because the end webpage result looked the same (theme not showing; no dashboard access) : I relocated the .htaccess file to the subdirectory where WPMU was installed.

  11. amadeus39 - it's in the httpd.conf (you can google AllowOverride and find that out). But since you said you have a non-WP php program, it's a different type of debugging needed.

    japk - Ask them if they can set it to MULTIVIEWS and ALL (those are different settings)

    My section has this:

    Options Indexes FollowSymLinks MultiViews
    AllowOverride All

    You'll need both :)

  12. japk
    Member
    Posted 3 years ago #

    aayyiyi,

    My host replies:

    "Hi Jessica,

    You can do this via .htaccess file,
    just add this line to top of .htaccess

    Options Indexes FollowSymLinks MultiViews"

    So I did, doesn't seem to resolve the problem though.

  13. Honestly, this is 100% something to do with your .htaccess not being read.

    Tell them 'I did that, and it still isn't processing my .htaccess file.'

  14. japk
    Member
    Posted 3 years ago #

    Yup, you're right. Working through it with host. Thank you for all the help, much appreciated!

Topic Closed

This topic has been closed to new replies.

About this Topic