WordPress.org

Ready to get started?Download WordPress

Forums

2.0 work with old theme, what about 'attachment.php' and 'functions.php'?? (2 posts)

  1. ttk_2k
    Member
    Posted 8 years ago #

    Hey, after 1 year staying with this kick-butt awesome blogging system, I've become Xtremely happy with it!!

    Yet, everything is perfectly okey except one thing... 2 weeks ago I upgraded my WP to the latest version. As usual I didn't spent even a second on my custom theme since I saw it never bothered me to face any problem whenever it got upgraded from WP 1.x to now.

    So I believe my blog's theme has become quite old, if I remember well, it's modified from the Default skin of WP 1.3 or something. But again, if I remember well, here on WP's official documentation page it never told us which file of the Default theme have been changed when upgrade from the old version to the new, right?

    So today suddenly, I found in the folder WP 2.0.2 Default Theme, there are two files that are not existing in my custom theme's folder: 'attachment.php' and 'functions.php'. I am not sure if it's ok just to copy them into my custom theme's folder, so I come to ask what can I do to upgrade my old theme to be completely compatible with the WP 2.0.2 except just copy those 2 files. Maybe I should modify some other files to call those 2 files? Or if there are any other things I should do or if there are any instructions you guys could recommend?

    Thanks for your help!!

    TT

  2. ttk_2k
    Member
    Posted 8 years ago #

    any help please?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.