WordPress.org

Ready to get started?Download WordPress

Forums

2.0 not generating permalinks (21 posts)

  1. IanMoody
    Member
    Posted 8 years ago #

    I've just upgraded to 2.0 from 1.5.2 and it went really smoothly. The only bug I've foud so far is that WordPress is not generating the rewrite rules for permalinks, it just spits out
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    instead. This isn't a problem for me as the old 1.5.2 rules are working fine, but I thought I should note it. This happens whether I am using a custom structure or one of the provided ones. I even tried a clean install at a different address (because I modify some of my core files slighty) and the same thing happened. It is not generating them in the text area or adding anything to the .htacces file (with permission 666).

  2. masquerade
    Member
    Posted 8 years ago #

    This is intended behavior, and as you'll notice, with that structure that 2.0 spits out, your permalinks still work.

  3. Football
    Member
    Posted 8 years ago #

    The permalinks only work with the year/month/date/ settings though. Using the post id/category etc generates a 404.

  4. honewatson
    Member
    Posted 8 years ago #

    The permalinks do NOT work unless you do like what Football said.

  5. WordPress handles permalink parsing now rather than mod_rewrite doing the parsing. It's a lot better that way.

  6. greatbananas
    Member
    Posted 8 years ago #

    I have the same problem as Football. I tried post id/post name and it won't work.

  7. makemead
    Member
    Posted 8 years ago #

    Mine wouldn't work until I went to the options -> permalinks panel and hit the update permalink struction button. (I changed no settings though).

  8. Moldarin
    Member
    Posted 8 years ago #

    Here's my settings. Non of them works after installing WordPress 2.0. Can't I use these on WordPress 2.0?

    How can I get them to work again?

  9. Just for fun, have you tried hitting "Update Permalink Structure"? Worth a try.

    And I'm using something similiar (/archives/%year%/%monthnum%/%day%/%postname%/) and it works fine:

    http://www.viper007bond.com/archives/2006/01/01/happy-new-year/

  10. caffeine23
    Member
    Posted 8 years ago #

    my install is in a subdirectory on my site so i place a .htaccess file in the install dir/ than i had to chmod it 666 after that i just hit update permalink structure, and it worked for me.

  11. Colin-uk
    Member
    Posted 8 years ago #

    No permalinks are generated for me either, which means clicking on any of the titles of my blogp osts just refresh the main page with all my posts on it

    The permalink structure, themes or plugins dont seem to make a diffrence if i change, activate, or deactive them

    My .htaccess file is chmodded 666, there is nothing in it, pressing the "update permalink structure" button doesnt do anything.

    I cant see what the problem is :/

    my wordpress install is at: http://www.colin-uk.com/blog

  12. HowToBlog
    Member
    Posted 8 years ago #

    I'm having no problems with custom permalinks on a new install of WP 2.0. I used %postname%.htm and then clicked 'update permalink structure' (with having my .htaccess file rewriteable), and all is fine. You can see it in action at http://www.sealectric.com/tools/ (which for now is just a test blog where I'm playing around with WP 2.0)

  13. bart154ce
    Member
    Posted 8 years ago #

    I'm having a problem with the new permalinks in 2.0.

    For my posts, categorys, pages etc it seems fine, but for any of the child 'pages' it can't find them and I get my 404 error page.

    I'm using the standard link structure.

  14. jalal
    Member
    Posted 8 years ago #

    You need to update the functions-post.php and classes.php files.

    I wrote a small article here.

  15. Stuarts
    Member
    Posted 8 years ago #

    HI All,

    I am having problems. Only on a brand new version 2 install. So clearly it isn't only an upgrade issue.

    I have tested various permalink permutations to get to the bottom of exactly where the problem lies, and and here are my findings:

    I uploaded a blank .htaccess file (ie open notepad and save as .htaccess - all files) and cmod it to 666 on the server - Then clicked on the options and clicked on Update Permalink Structure - This added the new .htaccess format

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    Using this, the first five permutations below work (I have posted them here so that you can get it too work in some shape or form if you are in a hurry) - 4 and 5 DO NOT WORK.

    1/ Default

    http://www.domain.com/?p=123

    Works - (with or without .htaccess file)

    2/ Date and Name based

    http://www.domain.com/2006/01/04/sample-post/

    /%year%/%monthnum%/%day%/%postname%/

    Works fine

    3/ Numeric

    http://www.domain.com/archives/123

    /archives/%post_id%

    Works fine

    4/ Custom

    /%post_id%

    Works fine

    5/ Custom

    /%postname%/

    Works fine

    6/ Custom - Here are where the problems are!!

    /index.php/directoryname/%post_id%/%postname%/

    Now, on a WP 1.5 install I have this working fine without the need for a .htaccess file.

    On WP 2 it doesn't work at all with or without the .htaccess

    7/ Custom -

    /%post_id%/%postname%/

    Again, does not work. (Which is odd given that /%post_id% DOES work)

    Bottom line. Does anyone know what I need to change the .htaccess code above too in order to get 7/ to work?

    ie /%post_id%/%postname%/

    As that is the one I actually like to use (along with 6 -which also doesn't work - if I am in a hurry - Lucky me!)

    Regards,

    Stuart

  16. Stuarts
    Member
    Posted 8 years ago #

    Hi,

    Ok. I have tried the suggestion above of updating the functions-post.php and classes.php files.

    This does not change the above results.

    I have re-ran tests on the seven permutations above, and the results are identical even with those two files changed.

    ie 1 - 5 work fine. 6 and 7 do not work. ie

    6/ Custom - Here are where the problems are!!

    /index.php/directoryname/%post_id%/%postname%/

    Now, on a WP 1.5 install I have this working fine without the need for a .htaccess file.

    On WP 2 it doesn't work at all with or without the .htaccess

    7/ Custom -

    /%post_id%/%postname%/

    Again, does not work.

    So, does anyone else have any ideas or code to get 6 and 7 working?

    Regards,

    Stuart

  17. Austin Matzko
    Member
    Posted 8 years ago #

    Stuarts, when you say "doesn't work," could you describe in more detail what goes wrong?

  18. Waldo Jaquith
    Member
    Posted 8 years ago #

    WordPress 404s are gone from my install. Nonsense URLs work just fine.

    Worse still, feeds no longer work. I had to take the WP1.5 RewriteRules and stick them in the header of my .htaccess.

    I'm not a fan of this new internalization of .htaccesses, particularly because I guarantee you that mod_rewrite handles them faster than PHP.

  19. Stuarts
    Member
    Posted 8 years ago #

    "doesn't work," means that it either displays a 404 cannot find error if I sue a structure like

    /health/%post_id%/%postname%/

    Or else, if I use /%post_id%/%postname%/ it would display a page, but instead of the post it will show

    Sorry, no posts matched your criteria.

    (This also displays when I use /index.php/directoryname/%post_id%/%postname%/)

    Either way, I am very dissappointed. If something as fundamental as this can be missed in a beta testing phase of about six months (I see that the last version of 1.5 was released in August); then it makes me wonder what else doesn't work?

    Looks like its time to downgrade to 1.5 and take another look in a month.

  20. Colin-uk
    Member
    Posted 8 years ago #

    couldnt fix mine, oh well, i just did a full re-install.

  21. Colin-uk
    Member
    Posted 8 years ago #

    And it still doesnt work

    argh >.<

    im going back to 1.5

Topic Closed

This topic has been closed to new replies.

About this Topic