WordPress.org

Ready to get started?Download WordPress

Forums

20-10 Theme Page Error (6 posts)

  1. shonie777
    Member
    Posted 3 years ago #

    I had updated to 3.1 last week and activated the 20-10 theme. It worked fine and now all of a sudden just a minute ago it came up with this:

    Parse error: syntax error, unexpected ';', expecting T_STRING or T_VARIABLE or '$' in /home/kayenta/public_html/blog/wp-content/themes/twentyten/header.php on line 14

    I didn't do a thing. Everything was fine just a few minutes ago.

    I have to activate the Word Press Default Theme in order for it to come back up.

    Could someone help me out?

    Thanks,
    Shonie

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    from your admin area, go to the upgrade section, and reinstall WP 3.1, that will replace WP, including twentyten

    Or use ftp or a file manager to overwrite the header.php

    Or copy the code from a fresh download of twentyten and paste it over the existing code in the editor for header.php

  3. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    What do you mean by, "I have to activate the Word Press Default Theme in order for it to come back up"?

    TwentyTen is the default WordPress Theme.

  4. shonie777
    Member
    Posted 3 years ago #

    I had upgraded to WP 3.1 about 2 weeks ago and it totally lost my site. I found out that WP 3.1 didn't support my old theme so I would up switching my theme to 20-10 and it worked perfectly.

    Everything was working perfectly fine today. I could browse my site and everything. I then logged into my Admin page and checked my stats. I then opened another tab in my browser to view my WP site and I got the following error:

    Parse error: syntax error, unexpected ';', expecting T_STRING or T_VARIABLE or '$' in /home/kayenta/public_html/blog/wp-content/themes/twentyten/header.php on line 14

    Now please remember that I did nothing but access my Admin page. I didn't do any updates, new posts, etc. I simply logged into my Admin page and checked my stats. That was it. That is when I got the error message.

    Chip: When I said activate my default WP Theme, I am talking about the boring and ugly plain Jane theme of WP. 20-10 is not the WP default theme I was talking about.

    Shonie

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    The confusing part here, is that twentyten is the default theme now

    Whereas prior to WP 3.0, the default theme was named 'default'

    So you still have the old default 'default' in your install

    As I said, something seems to have gone wrong with the theme somehow. You have to repair it somehow, using the methods Ive stated above

  6. shonie777
    Member
    Posted 3 years ago #

    Rather than waste my time tying to make the theme work, which WP should have made work properly all the time with their version of WP, I just downloaded and installed another theme that works with 3.1.

    This 3.1 version is the worst of all the updated versions ever. In my opinion.

    I've never had this much trouble with any of the other older versions. I sure wish these compatibility issues weren't such a pain. I don't know about the rest of you, but I don't like doing manual installs, recode this and that, etc.. If it aint broke, leave it alone.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.