WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce Menu Cart
[resolved] 2 cart icons in menu bar ? (17 posts)

  1. philine
    Member
    Posted 1 year ago #

    Hello,

    2 icons are displayed in my menu bar. the woocommerce original one is still in place after installing the plugin and I don't know how to remove it.

    Thanks for your help

    Philippe

    http://wordpress.org/extend/plugins/woocommerce-menu-bar-cart/

  2. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Philine,

    Could you post a link to your site so we can check it out?

  3. philine
    Member
    Posted 1 year ago #

  4. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Philine,

    Try adding the following to your site's custom css:

    ul.cart {
    display: none !important;
    }

    Also excellent photographs. :)

  5. philine
    Member
    Posted 1 year ago #

    Hi Jeremiah,

    Thanks for your fast reply and your kind words :)

    I added custom css but it doesn't work..

  6. philine
    Member
    Posted 1 year ago #

    Jeremiah,

    I have 3 sites on my domain. Seems to work now as I installed the plugin on my 3 sites. Hope that helps :)

    Thanks again

  7. Jeremiah
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Philine,

    You're welcome! So everything is working for you now? If not give me the exact url for each of the 3 sites and I'll get you some custom css for each.

  8. philine
    Member
    Posted 1 year ago #

    Everything's fine with the custom css in the 3 sites.

    All my best !

    Philippe

  9. janetbakker
    Member
    Posted 2 months ago #

    Hey there,

    I'm experiencing the same problem - I installed your plugin because I couldn't find the woocommerce cart and didn't know how to have it show up in the top main navigation.

    When I install your plugin, it shows up twice, next to each other (www.joangevaert.nl/justjoan).

    I tried adding the code to the styles.css, but no luck.

    Can you please advise?

    Thanks!
    Janet

  10. Jeremiah
    Member
    Plugin Author

    Posted 2 months ago #

    Hi Janet!

    I'm not seeing that issue, so I'm guessing you either fixed it, or it was a caching issue. Can you report back? Thanks!

    Jeremiah

  11. Ewout
    Member
    Plugin Author

    Posted 2 months ago #

    Hi Janet,
    In your case, this has another cause, namely the way that your menu creates the sliding effect.

    this code should solve that for you:

    a.wpmenucart-contents span.menu_text,
    a.wpmenucart-contents span.menu_slide {
    	display: block !important;
    }

    Also, if you set the alignment setting to "default" instead of right, it will display in one line with the rest of the menu items.

    One note here: because your theme creates that slide-in effect on the fly, this is not compatible with the live-update feature of the cart. Whenever someone adds an item to the cart, it will revert to the default, non-animated version (this is probably what Jeremiah saw). After they navigate to another page, it will animate again...

    this makes the none-animated version look a little bit better:

    a.wpmenucart-contents > span.cartcontents {
    	padding-top: 14px;
    	padding-right: 18px;
    }
    
    a.wpmenucart-contents > i {
    	padding-left: 18px;
    }
  12. janetbakker
    Member
    Posted 2 months ago #

    Hey Ewout,

    This totally resolves everything! Thanks for your excellent support. Are you Dutch by any chance? ;)

    Thanks again and happy easter!
    -Janet

  13. sarken
    Member
    Posted 2 months ago #

    Hello Everyone,

    Having the same issue as the people in this thread. Cart shows up twice in the navigation. I believe I am using the same theme as janetbakker too, Foxy from Elegant Themes. However I am not using wpmenus.

    I have tried the `ul.cart {
    display: none !important;
    }`

    to no avail. The URL of the site is dev.statdetox.com

    Any help would be appreciated!

  14. Jeremiah
    Member
    Plugin Author

    Posted 2 months ago #

    Hi Sarken,

    I just tried the method Ewout outlined above in my browser and it worked for your site. Can you confirm that you've attempted that method?

  15. sarken
    Member
    Posted 2 months ago #

    Yes, here is a screen shot of my custom CSS panel within my theme options, as well as what I see after clearing all my cache and cookies within Chrome. I have also tested in multiple browsers.

    http://i.imgur.com/8U0uaMs.png

  16. Ewout
    Member
    Plugin Author

    Posted 2 months ago #

    Hi Sarken,
    Please check again to make sure these custom styles are applied. I searched your code but it doesn't turn up:

    http://imgur.com/NG72gIT

  17. Ewout
    Member
    Plugin Author

    Posted 2 months ago #

    @sarken, did you manage to solve the issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.