WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 1and1 error 500 HELP PLEASE (12 posts)

  1. loveglass
    Member
    Posted 4 years ago #

    Hi
    I am having a big issue on my hosted domain. I wanted to activate wp e-commerce plugin without success. I have tried to put line in to .htaccess and also trick with php.ini file with line about memory. So far no result :-(. I am really exhausted with this problem and I regret to go in contract with 1and1.
    Their service is really unhelpful and last mail they sent to me is :

    I have received and read about your query/concern, and in an effort to
    completely assist you, I have personally looked into the website itself
    and as well as your account's webspace files and found out that you
    have uploaded a .htaccess file(for PHP parsing from PHP4 to 5 purposes)
    which is syntactically misconfigured that in return causes this 500
    Error.

    To resolve it, please make a slight correction from your .htaccess
    file's syntax(if you really intend to have this configuration)
    otherwise you may just disable it yet, so then it will have your webpage
    back.

    Does anyone can translate me what they want me to do?

    Any help or suggestion are appreciate it.

    THaks for help

    LoveGlass

    http://www.love-glass.co.uk

  2. loveglass
    Member
    Posted 4 years ago #

    my .htaccess file, I put there only line with AddType..... It's seems to me like all the other stuff was put there by 1&1, still error 500. What shall I do with it?

    {\rtf1\ansi\ansicpg1252\cocoartf949\cocoasubrtf540
    {\fonttbl\f0\fswiss\fcharset0 ArialMT;}
    {\colortbl;\red255\green255\blue255;}
    \paperw11900\paperh16840\margl1440\margr1440\vieww9000\viewh8400\viewkind0
    \deftab720
    \pard\pardeftab720\ql\qnatural

    \f0\fs24 \cf0 AddType x-mapp-php5 .php}

  3. loveglass
    Member
    Posted 4 years ago #

    This one work for me

    <files .htaccess>
    order allow,deny
    deny from all
    </files>

    ServerSignature Off

    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Options All -Indexes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

  4. boss2000
    Member
    Posted 4 years ago #

    Do you need the e-commerce package at 1and1 for this plugin to work or the regular hosting will do?

  5. MichaelH
    Member
    Posted 4 years ago #

    Regular hosting (hopefully linux) should work with that plugin. If WordPress runs, so should that plugin.

  6. BrightonGuru
    Member
    Posted 4 years ago #

    Hello Love glass did you manage to sort out your problem. I am having exactly the same problem with 1 and 1. My site runs fine, but the wp eccommerce just gives the error 500 message when I try to activate it.

    Your help would be greatly apreaciated...

    Thanks...

  7. BrightonGuru
    Member
    Posted 4 years ago #

    For anyone else who stumbles on this forum. I have resolved the issue with the activation of the WP Eccomerce plugin. You need to put an .htaccess. file at the route of your web, there are lots of entries about this. But something that is not made clear in other forum solutions, Is make sure that the .htaccess. file is not a txt file. and just a file called .htaccess. . PS the text you need is "AddType x-mapp-php5 .php" I created the file in note pad

  8. dean-smith
    Member
    Posted 4 years ago #

    thanks for all your help. BrightonGuru is correct, make sure it's a NOT A TEXT FILE.

    Make sure to created in NOTEPAD on PC with just 1 line ""AddType x-mapp-php5 .php""

    I was having trouble since I was trying to create .htaccess using textedit in MAC, and it was crashing my entire site/blog since it was not a proper .htaccess file.

    It's important to note this when creating your file. Works now!

  9. Shopworker
    Member
    Posted 4 years ago #

    Thanks for this post.

    I had the same problem with Error 500 at 1und1 in Germany and with WordPress 3.0 german version.

    The original english version WordPress 3.0 i could install without .htaccess but the german WordPress 3.0 wouldn't install without entry in .htaccess.

    Thanks,
    Stephan

  10. stacistubbs
    Member
    Posted 4 years ago #

    @loveglass - thank you for the post. made an .htaccess file with a direct copy from your post... worked like a charm.

  11. adventurehermit
    Member
    Posted 3 years ago #

    THANK YOU, THANK YOU, THANK YOU!

    I have been struggling with 1and1.com and THESIS for weeks. This solution along with placing a file called php.ini (with the single line of text memory = 20MB) into the wp-admin folder FINALLY makes the error 500 go away.

    I did not have this issue with default themes, for what it is worth.

    I was getting it any time I attempted to activate a plugin using WordPress 3.0 and Thesis 1.7

  12. manfredtex
    Member
    Posted 3 years ago #

    Thank You!

    I was having the exact same issue with the Event Espresso plug-in and this did the trick. I also am using 1and1.com with a basic package.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic