WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 1.5.2 Upgrade Broke RSS (5 posts)

  1. kabitzin
    Member
    Posted 8 years ago #

    I recently upgraded to the latest WP (1.5.2), and doing so seemed to break my RSS 2.0 link (at siteurl.com/feed/). On one of my blogs, the error reads:

    Warning: Cannot modify header information - headers already sent by (output started at /home/kolaapf/public_html/index.php:3) in /home/kolaapf/public_html/wp-rss2.php on line 10

    when you click on the RSS 2.0 link, and

    Warning: Cannot modify header information - headers already sent by (output started at /home/kolaapf/public_html/index.php:3) in /home/kolaapf/public_html/wp-commentsrss2.php on line 9

    when you click on the Comments RSS link. On the other site, only the RSS 2.0 link seems to be broken, as all the other RSS links work. This one gives a different error:

    Warning: main(/home/seaslug/public_html/wp-rss2.php): failed to open stream: No such file or directory in /home/seaslug/public_html/wp-feed.php on line 29

    Warning: main(/home/seaslug/public_html/wp-rss2.php): failed to open stream: No such file or directory in /home/seaslug/public_html/wp-feed.php on line 29

    Fatal error: main(): Failed opening required '/home/seaslug/public_html/wp-rss2.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/seaslug/public_html/wp-feed.php on line 29

    ================

    Does anyone know why this is? I searched but didn't find anyone having an issue with the upgrade's RSS.

  2. Looking at those error messages it looks like you have not uploaded all the files to your server - when trying to return the feed it is failing to find wp-rss2.php.

    Check that you have uploaded all the files into the correct places.

  3. kabitzin
    Member
    Posted 8 years ago #

    I uploaded the wp-rss2.php to the root directory in both places (did a delete and upload, rather than an overwrite), which is why this is so mysterious. I also tried fiddling with the permissions, even trying 777 and 755, but that didn't seem to change anything.

    Also, the error seems to be different between the two blogs. The kolaap.com site has errors for both the RSS feeds, and displays a message about the header already being sent. What does this mean?

  4. Ok i had a look at kolapp.com...

    http://kolaap.com/wp-rss2.php works fine http://kolaap.com/feed/ is broken as you said. It looks like something in index.php is causing the error rather than a file being missing.

    Can you check that index.php has no extra blank lines in it.

    Also check that wp-blog-header.php has no extra blank lines as well.

  5. kabitzin
    Member
    Posted 8 years ago #

    Ah ha, the index.php file had a space in between the command that I added for referrer karma, which fixed kolaap.com (the extra line break was not at the beginning or the end, but rather in between two php commands). I didn't do anything to the other blog, however, and it just started working again on its own...

    Thanks for your help westi!

Topic Closed

This topic has been closed to new replies.

About this Topic