WordPress.org

Ready to get started?Download WordPress

Forums

1.2-alpha-15 - Final Alpha (17 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    Matt for those of us who have hacked about the index.php do we need to install the new one? And do we still need to if the hacks are only alterations to the xhtml? TY for your help. Looking forward to WP 1.2.

  2. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    You can continue to use your version 1.0 templates with no changes.

  3. Anavy
    Member
    Posted 10 years ago #

    The last nightly build is 2004-04-28, and it is Alpha-11. I found this bugs
    with Alpha-11 :
    1. Options >> Reading >> Syndication Feeds >> Show the most recent: XX posts
    changing & saving a new value fails. Last value returns.
    2. some system vars were dropped from the options table, so Alexking's wp_grins
    hack can't locate the 'smilies_directory' and tries to load them from the root. Hard
    coding of '$smilies_directory' in the hack body didn't help.
    3. LaughingLizard's wp-Backup/Restore hack is not addressable anymore, in spite
    the fact that it's included in my menu.txt file.
    Another issue: I wrote once about the need for a forth target option in the
    Link Manger - "framed" (a named frame). Can it be added?
    Thanks for a great job.

  4. randybrown
    Member
    Posted 10 years ago #

    separate WP and blog addresses - can someone address this? What is this and how do we get it working?
    <rb>

  5. NuclearMoose
    Member
    Posted 10 years ago #

    randy,
    Documentation for this is currently being checked over and will be available soon!

  6. randybrown
    Member
    Posted 10 years ago #

    OK, Thanks Moose.

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    Hey there, I've been continuously updating to the nightly builds every chance I get and I'm still having two problems with them and I don't understand why. I think it might just be my setup but I was hoping somebody might shed some light on the subject.
    First, when trying to make any changes to ANY options at all I always get this error after clicking update changes:
    Notice: Undefined index: option_group_id in C:\Brian\wp-admin\options.php on line 38
    Warning: Cannot modify header information - headers already sent by (output started at C:\Brian\wp-admin\options.php:38) in C:\Brian\wp-admin\options.php on line 113
    It does save the changes, but it never confirms that or takes me anywhere else. I end up there every time.
    The second problem I've been noticing is that for some reason I cannot have the option enabled to moderate comments AND have the time zone adjustment set correctly. Its supposed to be -6 for me and when I put that in it turns off moderation, if I go back and turn on moderation it changes the time zone to +1. Anybody know what my problem is?
    Thanks,
    Brian

  8. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    The documentation for the new address options as they current stands is available at http://wordpress.org/docs/installation/different-address/ .

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    The RSS 2.0 is generating a funky publish date: <pubDate>Wed, 31 Dec 1969 18:59:59 +0000</pubDate>

  10. mog
    Member
    Posted 10 years ago #

    I uploaded the 4/28 build and among the problems, small ones were some link descriptions were put in image uri and I had to individually edit them. Also all the descriptions show up and I haven't found a way to turn them off.
    And of course, it totally screwed up my time zones, added 7 hours to all of them and broke all the links. I have the two scripts but am unsure how to modify them and which ones to use to reset it. Or do I have to restore my old database? Never did that either. Any help would be appreciated.
    I'd already mentioned the problem with the mod rewrite.

  11. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Eke, I've fixed most if not all the IE display issues you describe. The "problems" with the default front-end CSS are known and expected behaviour.
    Anavy, third party hacks will need to be updated if they don't work with 1.2. I was unable to recreate the syndication option problem you described, but I did fix a bug where the character encoding might get wiped out.
    Randy, the delete button will stay that way for now, we can clean it up in a future version. I'll look at the link manager options.
    Anonymous1, fixed your first problem. I also fixed the super-funky options behaviour some of you have been experiencing.
    Anonymous2, can't recreate that problem. Maybe you didn't run upgrade.php?

  12. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Mog, go ahead and send me an email or IM me. You should be able to turn off the link descriptions in Links > Link Categories. It shouldn't have modified any of your post times, just created GMT ties.

  13. Alan
    Member
    Posted 10 years ago #

    I get that odd publish date from the RSS 2.0 feed. Since I knew Mog upgraded, I looked at her RSS 2.0 feed and see the same date problem....not in the first entry but further down.
    I upgraded with both the .tar.gz and .zip files and each gave the same result.

  14. mog
    Member
    Posted 10 years ago #

    I tried to use the first script http://wiki.wordpress.org/index.php/1.2%20CVS%20upgrades and got Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'INTERVALÊÊÊ'-7:0' HOUR_MINUTE)' at line 1]
    UPDATE b2posts SET post_date = DATE_ADD(post_date, INTERVALÊÊÊ'-7:0' HOUR_MINUTE)
    What do I change where?

  15. harpshot
    Member
    Posted 10 years ago #

    Whoa - I downloaded the nightly wordpress-2004-04-28.zip and a bunch of the files in it are *newer* than what I got from CVS at the same time. I hoped it was just time-stamp differences, but some of the code is in fact different. I assume the nightly, then, is the latest available version of all the files, although there've been some fixes since this thread was started. I guess (hope) these will show up in CVS later this evening.

  16. mog
    Member
    Posted 10 years ago #

    Found the error and fixed the date time, there were too many spaces in the script when you copy paste.
    $wpdb->query("UPDATE $tableposts SET post_date = DATE_ADD(post_date, INTERVAL   '$add_hours:$add_minutes' HOUR_MINUTE)");
    should be
    $wpdb->query("UPDATE $tableposts SET post_date = DATE_ADD(post_date, INTERVAL '$add_hours:$add_minutes' HOUR_MINUTE)");
    Worked fine after I fixed that.

  17. mog
    Member
    Posted 10 years ago #

    In the 4/29 build the blockquote was perfect in Safari, Camino, even IE Mac, not so in IE Windows. I don't have any problems with the edit screens and appears to have fixed some styling differences I saw in the 4/28 build.
    Alex King's WPGrins worked perfectly for me without any modifications aside from remembering to add them to the new forms, haven't readded what I need to show wp-blacklist but with comment moderation options, wouldn't importing the list work irregardless if I show the blacklist in the top menu?
    Still haven't gotten the links descriptions to not show thou.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.