WordPress.org

Ready to get started?Download WordPress

Forums

1.2 alpha 10 - TEST PLEASE (18 posts)

  1. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Okay, this is a pretty big change from the previous nightlies and as such needs as much testing as possible. Some timezone issues were cleaned up. wp-mail.php has been redone. Some character and additional options problems were fixed.

  2. Beel
    Member
    Posted 10 years ago #

    Just waiting for it to show up in the CVS...

  3. randybrown
    Member
    Posted 10 years ago #

    1. The link rating icons do not show when viewing a single posting. Instead, the alt attribute is displayed.
    2. Only one plugin can be active. When activating another, the previous is deactivated.
    3. In wp-mail, it no longer is checking for a username or password, nor is there a way to assign the email to a specific category. Was this intended?
    4. import-rss can still mangle entries imported from weblogs that are feeding encoded HTML. (html_entities_decode would solve this and have no side effects (that I know of) on entries that were not encoded.)
  4. Alan
    Member
    Posted 10 years ago #

    The import style sheet URL doesn't work: <?php bloginfo('url'); ?> .....but this one does: <?php echo get_settings('siteurl'); ?>

  5. carthik
    Member
    Posted 10 years ago #

    The geo url button is missing in the options page. The page is still available at options.php?option_group_id=8.

  6. Ryan Boren
    WordPress Dev
    Posted 10 years ago #

    Geo has moved to Miscellaneous.

  7. carthik
    Member
    Posted 10 years ago #

    Sorry, that was the latest CVS.
    In alpha10, after I got the new files, upgraded my wpnightly installation, when I get to index.php I can see unstyled content.
    The stylesheet included by index.php has the URI
    http://2fargon.com/wpnightly/index.php/wp-layout.css !
    the blog is at
    http://2fargon.com/wpnightly
    and I checked in the Options page, the URI of the weblog is specified correctly, no problem there.

  8. Ryan Boren
    WordPress Dev
    Posted 10 years ago #

    Style import is fixed. pubDate should be fixed. Link ratings is fixed.
    Thanks for testing.

  9. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Randy,
    wp-mail now functions in the secret address paradigm, that is that you have a secret address and everything that goes there gets posted. This is much more useful for how people actually use posting by mail, which is generally posting from interfaces where logging in to WordPress would be difficult or impossible Typing in your username:password on a phone is a pain. This has been reflected under Options > Writing for several versions now.
    As I said in the other thread, adding the entity decoding would break valid feeds that have genuine entities encoded. What sort of tool is producing the type of feed you describe? I tested with feeds from Movable Type, bloxsom, and Userland Radio.
    The plugin and link rating things appear to be bugs, and I'll fix them up if Ryan hasn't already.

  10. Beel
    Member
    Posted 10 years ago #

    I set up a "secret" e-mail address and already a spam message (Milzie said ok Cherise) has been added to my blog since we no longer use the username:password.

  11. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    The recommended method for a secret address is to use one of the random strings given on the admin screen, and obviously don't publish the address anywhere. Unless a spammer guessed the random string (highly unlikely) or you have some sort of catch-all set up to go to that account, I can't see you having any problems. I've been using this method for a long time for a different application and never had any problems.

  12. Beel
    Member
    Posted 10 years ago #

    Nope, used one of the random strings generated and set up the mail account with Comcast. Of course they send periodic e-mails to everyone so I can expect a post or two from them also. I have always used an address with my name appended with a random number - and change it every year because somehow junk eventually finds its way in. That is why I liked "Blog:Title", to screen those out.

  13. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Can you set up an email account @ your domain?
    Plugin bug fixed.

  14. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Link images should use absolute paths including the domain. Can you look at the HTML and see where it's looking for the images? This should be working.

  15. Beel
    Member
    Posted 10 years ago #

    Allusion: No, I can't currently set up an account @ my domain as it is forwarding to my computer and all e-mails get forwarded to my Comcast account so the problem would not be alleviated. Don't spend any time on this if your rational is sound as I don't envision needing to use wp-mail - just testing it.
    rb: You are not the only one. I had to change my link images to /wordpress/wp-images...

  16. randybrown
    Member
    Posted 10 years ago #

    RandomURL - My links-update-xml.php has the slash and is working fine here. But, I had to add a call to this in my index.php file - it was not in that file. It's also not in the CVS index.php
    <rb>

  17. randomurl
    Member
    Posted 10 years ago #

    Interesting, I know this error affect me and one other., had to help him through it on the IRC channel.

  18. fatherofpip
    Member
    Posted 10 years ago #

    a wp-mail.php issue when attempting posting via mobile mail.
    running the 1.2 alpha(10). have opened a secret mail address using one of the suggested strings.
    now, can anyone tip me the correct mobile process, the readme doesn't apply anymore presumably and i need to get a body delimiter in to cut of the provider's add.
    regardless of attempts i'm still receiving errors:
    Warning: Invalid argument supplied for foreach() in /data/members/paid/m/g/mgivf.com/htdocs/haiku/
    wp-blog-header.php on line 454

    on the page and
    Warning: Invalid argument supplied for foreach() in /data/members/paid/m/g/mgivf.com/htdocs/haiku/
    wp-blog-header.php on line 454

    plus
    Warning: Invalid argument supplied for foreach() in /data/members/paid/m/g/mgivf.com/htdocs/haiku/
    wp-includes/template-functions-category.php on line 81

    on edit.php.
    cheers-r.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.