WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
[resolved] [WP-Minify] 1.1 is broken (27 posts)

  1. hebbet
    Member
    Posted 3 years ago #

    after i installed the update my design is broken. clicking on the minified css file shows:

    <b>Parse error</b>: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in <b>/www/htdocs/mydomain/wp-content/plugins/wp-minify/min/config.php</b> on line <b>162</b>

  2. Habylab
    Member
    Posted 3 years ago #

    It's working for me, although the advanced options are shown by default now, and clicking 'General Configuration' (something like that) has no effect. Would be nice to know what it does, the latest update.

  3. Andreas Beer
    Member
    Posted 3 years ago #

    Seems like the 1.1 version is rather buggy. CSS and Java minification kill the entire appearance of my site.

  4. AlphaK
    Member
    Posted 3 years ago #

    Andreas, same for me.
    Going to revert to previous version.

    Going manually to the minified URL gives me a 400 Bad request

  5. Habylab
    Member
    Posted 3 years ago #

    I thought it did to me too, turned out some rogue code I added a while ago but hadn't tested. I notice there is a 2.0 version on the download list, someone want to give that a try?

  6. Andreas Beer
    Member
    Posted 3 years ago #

    Oh well, it's Easter, the weather is beautifull and there is vitually no traffic on my sites at all. Why not put it on the to do list for this weekend again. But first I'll have to figure out ho to get rid of all that facebook garbage slowing down my site....

  7. hebbet
    Member
    Posted 3 years ago #

    1.1.1 fixes it.

    2.0 is btw 0.2

  8. Habylab
    Member
    Posted 3 years ago #

    Thanks for that, I'll wait 'till he updates it, hopefully soon. How do you revert an update, or downgrade? Thanks.

  9. hebbet
    Member
    Posted 3 years ago #

    it is already live.

  10. Habylab
    Member
    Posted 3 years ago #

    Sorry, I don't know what I was thinking. I read your post thinking the version 1.1.1 was below the current version... Thanks again!

  11. puda
    Member
    Posted 3 years ago #

    Even with the version 1.1.2 my design is broken.

    I am using 2010 Weaver.

    How can I downgrade ?

  12. pacifika
    Member
    Posted 3 years ago #

    The pretty urls generated by wp-minify returned http 400 bad request.
    Fixed my site by disabling "pretty urls" in the advanced options.

    Hope that helps.

  13. AlphaK
    Member
    Posted 3 years ago #

    Still broken for me with version 1.1.3 : still having a HTTP/1.0 400 Bad Request when trying to get a minify link.
    The problem appears only when the option box [Don't use "pretty" URL] is unchecked, however. If this option is checked, my theme is displayed properly.

  14. Habylab
    Member
    Posted 3 years ago #

    So just leave it checked then for the moment.

  15. puda
    Member
    Posted 3 years ago #

    @Habylab Indeed checking this option is fine with my theme except one extension, wp cumulus is not working anymore. So I am waiting for another version !

  16. pacifika
    Member
    Posted 3 years ago #

    It's not resolved because the bug is still there.

  17. hydn
    Member
    Posted 3 years ago #

    Broken here 2. We get: HTTP/1.0 400 Bad Request

  18. admintiger
    Member
    Posted 3 years ago #

    Same problem here. I also get HTTP/1.0 400 Bad Request using WP-Minify 1.1.6 with a fresh WP 3.1.2 installation at a test site. (No other plugins and an unmodified Twenty-Ten theme)

  19. admintiger
    Member
    Posted 3 years ago #

    I traced the cause of "get HTTP/1.0 400 Bad Request" to a PHP error on line 859 of "wp-content\plugins\wp-minify\wp-minify.php". I am using a Windows Server and there is a deeply-seated problem with filemtime() under Windows due to the fact that it calls the Windows stat() function, which implements DST (according to this bug: http://bugs.php.net/bug.php?id=40568). The detection of DST on the time of the file is confused by whether the CURRENT time of the current system is currently under DST.

    A fix for that problem is available here:
    http://www.php.net/manual/en/function.filemtime.php#100692

  20. admintiger
    Member
    Posted 3 years ago #

    After adding a function to fix the problem on line 859 I discovered the same problem on two other lines in the same file. After those problems were fixed another PHP error occurred due to other code that is not compatible with the Windows operating system. All those problems could be fixed, but I have decided look for a Windows-compatible plugin or write my own.

  21. hydn
    Member
    Posted 3 years ago #

    Forget about wp-minify. Use AutOptimize it works a lot better and no bugs stable since end of 2010

  22. admintiger
    Member
    Posted 3 years ago #

    Thanks hydn, I will give AutOptimize a try.

  23. admintiger
    Member
    Posted 3 years ago #

    @hydn, it appears after some quick tests that you are right about AutOptimize. I hadn't tried it before, because the developer no longer seems to support it and because of concern that moving all JavaScript to the bottom of pages would break functionality. However, it is refreshing to find a plugin that in contrast most others I have tried recently is well-written and actually works as described. So far the JavaScript issues I was concerned about haven't caused any problems and if there are compatibility issues with future WP versions I can fix them myself.

    Thanks for taking time to post your recommendation.

  24. hydn
    Member
    Posted 3 years ago #

    @admintiger

    YW. I was beyond amazed as to how much better and non-buggy this dead plugin is.

    If you are goning to enable HTML minify make sure you are using some sort of Cache solution like WP SuperCache because without one it will slow down page delivery since pages have to be minified for EVERY request.

    On the other hand, WITH a cache solution like WP Super Cache the FIRST request is minified and saved in WP Super Cache's /cache/ folder thus all subsequent requests are static minified HTML pages. Much faster!

    This applies to WP Minify also. But more so to AutOptimize. Compare the HTML (view source) and you'll notice autoptimize reduces the size of HTML code MORE than WP Minify at the cost of added generation time. But if cached then this equals BEST static page serving performance after cache is primed with pages.

    If you have any java script issues just enable "Look for scripts only in <head>?"

  25. admintiger
    Member
    Posted 3 years ago #

    @hydn, our comments should be AutOptimize forum posts, so people considering that plugin will see them. However, I want to confirm that what you wrote above is true. Over the past several days I have installed and throughly tested all the various minification/caching/cdn plugins I could find at a test site that has pages loaded with unusually rich content (multiple large css files, multiple htc files, many images, audio, video, multiple JavaScript files, etc.). Most of the plugins I tried are seriously flawed by coding mistakes, fallacious underlying design logic, poor html header parameter choices, misleading setup information, and/or operating system incompatibilities. In contrast, AutOptimize and WP SuperCache work together flawlessly on both Linux and Windows servers (running Apache, I haven't tested with other web servers). Both plugins are simple to install and configure, and when used together page loading times half way around the planet are phenomenal.

  26. hydn
    Member
    Posted 3 years ago #

    I'm on windows IIS. U have an email or way I can send u a link to my test site?

  27. Homelite
    Member
    Posted 3 years ago #

    I found this plugin Autoptimize by chance, while looking for "expires" plugin. WordPress classification is to be blamed for poor placement of plugins. IMHO this should come below Wp-minify, bwp-minify ones.
    The plugin works best on minification. But when I used WP Super Cache, somehow the cache pages did not match, meaning some conflict with Autoptimize.
    If I optimize Javascript, my rotator stops. Any idea how can I exclude my rotator script?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags