WordPress.org

Ready to get started?Download WordPress

Forums

1 and 1 hosting database error (5 posts)

  1. FatherAzerun
    Member
    Posted 7 years ago #

    I am having a devil of a time executing my wordpress installation from the 1 and 1 hosting solution.

    There have been two topics on this subject previously, but unfortunately the solutions posted in them do not seem to aid my endeavor (http://wordpress.org/support/topic/68997) and (http://wordpress.org/support/topic/65777).

    My error is similar. After having created the SQL database through the 1&1 control panel and uploading the appropriate files, my attenpted execution of the install routine leaves me with this error message:

    ===========
    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at db418.perfora.net. This could mean your host's database server is down.
    ===========

    I assume the problem lies within either my pathing, configuration file, or just plain old stupidity on my part. :)8

    Here are the facts as I am aware of them:

    1. My web domain is active. I have three domains active under my user account and I use subdirectories (rather than a root directory) for each one.

    2. The domain, bowtieworld.com, is under a subdirectory /bowtieworld. The wordpress installation is in a folder, /wordpress, installed below this directory. My execution in the browser is: http://www.bowtieworld.com/wordpress/wp-admin/install.php

    3. The SQL database is set up and has a password, user name, database name, and a non-local host, each of which I have entered into my configuration file.

    The configuration file is as follows:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'db169001998'); // The name of the database
    define('DB_USER', 'db169001998'); // Your MySQL username
    define('DB_PASSWORD', '(password for my database)'); // ...and password
    define('DB_HOST', 'db418.perfora.net'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    ===================
    I tired removing the variable tag names such as 'DB_NAME',etc, which was suggested in another solution post, albeit that seemed like it would not work. It did not. I have also tinkered with the DB_HOST, using both localhost and teh above-mentioned hosting choice.

    Any help would truly be appreciated!

  2. deko
    Member
    Posted 7 years ago #

    1 and 1?? Sorry to hear of your misfortune. I too got ripped off - the only advice I can offer is get out... if you can...

  3. Chris_K
    Member
    Posted 7 years ago #

    This isn't much of an answer and may even be a red herring, but I don't "see" a db418.perfora.net machine. Is that name absolutely correct?

    Should that be perforMa.net I wonder?

  4. deko
    Member
    Posted 7 years ago #

    Yeah, that was more of a visceral reaction to the name 1and1...

    My guess, FatherAzerun, is that it's a matter of getting the path correct. On my host I have a pathing scheme like this:

    /home/username/public_html/mydirectory/myscript.php

    Goodness knows what 1and1 uses for a pathing scheme.

  5. wahgnube
    Member
    Posted 7 years ago #

    db169001998 is your database name.
    dbo169001998 user name.

    Relax. 1&1 is awesome.

Topic Closed

This topic has been closed to new replies.

About this Topic