WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[0.9.26] Unable to save minified settings (18 posts)

  1. OvaisAlam
    Member
    Posted 1 year ago #

    Clicking on Save all settings on Minify page here at wp-admin/admin.php?page=w3tc_minify is re-directing to a page not existed in my website (giving 404 error page).

    The issue rises after 0.9.2.6 update and it's still on 0.9.2.7

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. OvaisAlam
    Member
    Posted 1 year ago #

    Plugin is updated to 0.9.2.8 but the issue is still there.

  3. wpboys
    Member
    Posted 1 year ago #

    Are you on a multisite??
    If not , try reactivating the plugin..

  4. OvaisAlam
    Member
    Posted 1 year ago #

    I am not on a multi-site.
    Tried Disabling/enabling, restoring to default setting etc but the issue is still there.

  5. fivehead
    Member
    Posted 1 year ago #

    Same here. The default minify settings introduced a bunch of whitespace after my content, but before the footer, so I wanted to play w/the minify settings. Tried to save the settings and get a 404 on wp-admin/admin.php?page=w3tc_minify.

    The extra whitespace was present in Chrome and Safari, but not in Firefox.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Could you indicate which page its trying to redirect too after saving settings?

  7. OvaisAlam
    Member
    Posted 1 year ago #

    When I click 'Save setting' the page stays at wp-admin/admin.php?page=w3tc_minify instead of going to 'wp-admin/admin.php?page=w3tc_minify&w3tc_note=config_save'

  8. Swashata Ghosh
    Member
    Posted 1 year ago #

    Hi,
    I am on WP Multisite and having the same problem.

    This problem happens with the Minify Settings only.

  9. klihelp
    Member
    Posted 1 year ago #

    Hi Frederick,

    Hope this helps. Looks like minify is not working on single WordPress with subfolder install, also I have custom wp-content dir outside the wp subfolder.
    It's works WordPress with not subfolder install.

    The admin error message:

    >>> It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess. Or if using nginx verify all configuration files are included in the main configuration fail (and that you have reloaded / restarted nginx).

  10. ffhertford
    Member
    Posted 1 year ago #

    i am also getting this message

  11. klihelp
    Member
    Posted 1 year ago #

    Errors are displayed on a WP install folder structure like:

    /wp/
    /the-custom-wp-content/
    /index.php
    /wp-config.php

  12. OvaisAlam
    Member
    Posted 1 year ago #

    Any update on this issue?

  13. klihelp
    Member
    Posted 1 year ago #

    Waiting for this too ...

  14. jseth
    Member
    Posted 1 year ago #

    I just installed this plug in, and found this thread when I also got this message. No updates yet?

  15. OvaisAlam
    Member
    Posted 1 year ago #

    A work around I found:
    1. Change Auto Minify settings to "Manual" in W3TC's dashboard.
    2. Update/edit Minify settings and click save.
    3. Change Auto Minify settings to "Auto" again.

    When I done this on WP 3.5.1 and W3TC 0.9.28 it works.

  16. klihelp
    Member
    Posted 1 year ago #

    For single wp subfolders install is giving me an error

    Uncaught SyntaxError: Unexpected token <
    
    Warning:  require_once(/homepages/9/d375568784/htdocs/public_html/wp-load.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in <b>/homepages/9/d375568784/htdocs/public_html/content/plugins/w3tc-wp-loader.php on line <b>4
    
    Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/homepages/9/d375568784/htdocs/public_html/wp-load.php' (include_path='.:/usr/lib/php5') in <b>/homepages/9/d375568784/htdocs/public_html/content/plugins/w3tc-wp-loader.php on line <b>4

    My WP install folder structure is based on https://github.com/markjaquith/WordPress-Skeleton

    /wp/
    /the-custom-wp-content/
    /index.php
    /wp-config.php

  17. rajaotai
    Member
    Posted 1 year ago #

    Follow OvaisAlam's method and it is still not working

  18. jbadmin
    Member
    Posted 8 months ago #

    I have the same issue with multisite, when selecting minify and URL rewrite I get double URL's for css and js for some reason, and this causes 404 errors.. like the below.. something is wonky with multisite settings...

    When I turn on the debug... for some reason the www, and non www version of the URL are both being created.. not sure why..??

    .htaccess file contains rules to rewrite url http://www.site.com/http://site.com/wp-content/cache/minify/000000/w3tc_rewrite_test. If handled by plugin, it returns "OK" message.
    The plugin made a request to http://www.site.com/http://site.com/wp-content/cache/minify/000000/w3tc_rewrite_test but received:
    404 Not Found
    instead of "OK" response.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic