WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] 0.9.2.2 APC and minify Still does not work (20 posts)

  1. Mike McKoy
    Member
    Posted 3 years ago #

    APC with minify is still broken with the new version .9.2.2

    Please fix and test this.

  2. AngieP
    Member
    Posted 3 years ago #

    I find that the combination of W3TC and WP 3.1.3 works fine:

    Angie's DIARY | Online Writing Magazine - http://angiesdiary.com

    Cheers,
    Angie

  3. AngieP
    Member
    Posted 3 years ago #

    I should add: with minify enabled and manual.

  4. Bryan Hadaway
    Member
    Posted 3 years ago #

    Minify indeed is still not fixed.

    I've carefully checked all settings and flushed all caches after updating.

    The last known good version is 0.9.2 - both 0.9.2.1 and 0.9.2.2 are broken.

    Thanks, Bryan

  5. Bryan Hadaway
    Member
    Posted 3 years ago #

    Apologies, 0.9.1.3 is the last version that works correctly.

    Thanks, Bryan

  6. Takao Asayama 朝山貴生
    Member
    Posted 3 years ago #

    Same here. 0.9.2 and above are not working for me, even with WP 3.1.3

  7. Bryan Hadaway
    Member
    Posted 3 years ago #

    Hopefully 0.9.2.3 will be fixed. Until then; 0.9.1.3 works fine.

    Thanks, Bryan

  8. Mike McKoy
    Member
    Posted 3 years ago #

    Bryan were you able to downgrade without issue? I think the database structure is different in the earlier version

  9. Bryan Hadaway
    Member
    Posted 3 years ago #

    Steps:

    - Deactivate Plugin
    - Delete Plugin
    - Install 0.9.1.3 (Don't Activate Yet)
    http://downloads.wordpress.org/plugin/w3-total-cache.0.9.1.3.zip
    - Via FTP Download Your .htaccess File And Remove All References To W3 Total Cache
    - Upload
    - Now Activate W3 Total Cache
    - Set All The Settings You Wish
    - Flush All Caches
    - Refresh Your Homepage And View Source To Verify

    Seems to be just peachy keen again :).

    Thanks, Bryan

  10. Takao Asayama 朝山貴生
    Member
    Posted 3 years ago #

    My solution for now is to deactivate minify function.... and wait for next working version. Still CDN is working ok. Only the problem is now the page is calling like 10 separated css files...

  11. bakbek
    Member
    Posted 3 years ago #

    Indeed, Minify still is broken with 0.9.2.2 on WordPress 3.1.3 / I use APC too .. my site response time is suffering from this. I really hope a real FIX is implemented very soon, since downgrading now is not good for me as i'm using the new Cloudflare feature.

  12. Mike McKoy
    Member
    Posted 3 years ago #

    Hey guys my recommendation is to downgrade to 0.9.1.3 like bryan suggests. The dev has put a lot of work into it but obviously wasn't tested fully and completely.

    No telling what else is broken. He needs a beta process for a release this big.

  13. awendt
    Member
    Posted 3 years ago #

    No need to downgrade or re-install. See http://wordpress.org/support/topic/w3-total-cache-0922-file-param-is-missing -- the secret is to temporarily disable "Rewrite URL structure" in the minify settings!

  14. Bryan Hadaway
    Member
    Posted 3 years ago #

    Seems like a cover up / workaround fix -- I'm still going to wait for the plugin to be officially fixed.

    Thanks, Bryan

  15. Mike McKoy
    Member
    Posted 3 years ago #

    why would anyone want to disable the url rewrite structure? That makes no technical (SEO) sense and would do more harm than good. I'll wait as well or just install something else (leaning towards this after a month).

  16. awendt
    Member
    Posted 3 years ago #

    Thanks for cross-posting this, now I have to correct it here, too: I didn't mean disable "Rewrite URL structure" of your blog. What I'm talking about is a setting in the "Minify" tab.

    I don't really care about pretty URLs for my CSS or JS...

  17. Mike McKoy
    Member
    Posted 3 years ago #

    I'll just wait. He needs to beta test the new stuff. Too many things aren't functioning as they should.

  18. badMike
    Member
    Posted 3 years ago #

    I got minify to work. Here's how:

    1. I upgraded to ver. 9.2.2.

    2. I deactivated the plugin.

    3. I deleted all code referring to W3 Total Cache in my .htaccess file.

    4. I reactivated the plugin.

    5. Went to plugin admin area, which prompted me to re-generate the .htaccess code. So, I did.

    6. Re-minified all my CSS and JS and the site's working perfectly now.

    P.S. I do NOT use APC or CloudFlare, so maybe there's still some incompatibility with those, which I don't know.

  19. Takao Asayama 朝山貴生
    Member
    Posted 3 years ago #

    badMike,

    It worked like a charm!!

    Thanks a lot!

  20. badMike
    Member
    Posted 3 years ago #

    You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic