WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
0.9.2.11 won't use existing MaxCDN pullzone (6 posts)

  1. thrivingnow
    Member
    Posted 1 year ago #

    Installed plugin update on existing site where CDN was working with W3. Required authorization. Done. Then required the creation of a pull zone.

    The WordPress install is in /wp so it appears W3 is trying/forcing the creation of a pullzone for http://www.attractingabundance.com/wp and it will not see the pull zone for the root (which it has been using all along and I don't want to lose since it is used for other non-WordPress caching as well).

    Is there a way to restore the ability to hand-enter the pull zone, or to see the pullzone for the root of the domain?

    Rick

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. thrivingnow
    Member
    Posted 1 year ago #

    This is still an issue on my sites. I've used MaxCDN with W3TC for a long time. The pull zones were already configured. And they apply to the ROOT of the domain, even though WordPress is installed in a subdirectory.

    Been running without the cache... would be great to be able to get the CDN working again...

    Rick

  3. A2ndChance
    Member
    Posted 1 year ago #

    I am in the same boat here, It is not letting select my existing (already configured) pullzone after upgrading from 0.9.2.9 -> 0.9.2.11

    It seems as if there should be a selector (drop-down) that should let me choose my existing zone, but there is not, instead I am faced with the following: http://i.imgur.com/Raoow8D.png
    Notice there is only a button to "create" a zone, and not select an existing one.

    When I click the button and enter the name of my existing Pull Zone I get the following error message:
    "Something is wrong:
    You have reached the limit of zones you can create"
    - http://i.imgur.com/LY7ucH1.png

    Luckily I am testing this on a staging site so my production site is not affected and still happily using MaxCDN w/ W3TC 0.9.2.9, but I'd like to upgrade this plugin on production, but this issue is a blocker.

    -Chris

  4. tanster
    Member
    Posted 1 year ago #

    I am in the exact same situation, WordPress installed in root.

    I can't choose the zone I already created in MaxCDN, but if I click the "Create pull zone" button on the WTC CDN tab, I get the "Something is wrong: You have reached the limit of zones you can create" error.

    Did any of you resolve this issue?

    I am using WordPress 3.5.2 and W3 Total Cache 0.9.2.11.

    Any advice is greatly appreciated!

    Thanks,
    tanster

  5. tanster
    Member
    Posted 1 year ago #

    My issue has been fixed, thanks to MaxCDN chat support. :)

    I had originally set up my origin as http://www.website.com.

    Once the support rep changed the origin to http://website.com, and I clicked Save all settings, the "Select pull zone" dropdown list appeared!

    Clicking the "Test MaxCDN" button now results in the green box "Test passed."

    tanster

  6. A2ndChance
    Member
    Posted 1 year ago #

    After emailing MaxCDN support I figured out the issue. You must access the admin portion of the site using the same hostname as the pull zone. Therefore if you have a staging or dev site that uses a different hostname (stg.example.com) then the production hostname (www.example.com) the plugin will exhibit this behavior. So I pushed my changes to production and everything is working just fine.
    -Chris

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic