WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 0 cached pages 0 expired pages (17 posts)

  1. jkjliu
    Member
    Posted 6 years ago #

    First, many thanks for this super-cache plugin -- it seems like it will be very valuable.

    I installed the plugin and everything went very smoothly as described in readme.txt

    I even see a long list of html files in wp-content/cache!!!

    However, on my WP Super Cache Manager page, I see: 0 cached pages and 0 expired pages. It doesn't change from zero no matter what I do. Also, my site doesn't seem to be loading faster.

    Because I am a beginner programmer, the only directions that I did not understand was: "You must have mod mime, mod rewrite and fancy permalinks enabled. PHP safe mode should be disabled." Since I don't know what this means, I didn't "do" any of it. Is this my problem?

    Thank you in advance for any assistance/suggestions.

    Warm regards,
    Host Bee
    http://www.busybeelifestyle.com

  2. ericdano
    Member
    Posted 6 years ago #

    I get something like this too. I get 0 pages served with Super-Cache, but a lot with just WP-Cache. I have all the correct things installed, and have posted a topic about this in the forums here.....with no reply.

  3. Donncha O Caoimh
    Member
    Posted 6 years ago #

    jkjliu and ericdano - I need more information. What OS are you running on your server? Linux, *BSD, Windows?
    Is there anything unusual about PHP? Is it Apache+mod_php? fcgi? IIS?

    Is there anything in your PHP error_log? (Ask your administrator if you don't know where that is)

    Open up wp-cache.php and look for the code that generates the stats. You need to look at wp_cache_files().

  4. jkjliu
    Member
    Posted 6 years ago #

    donncha, many thanks for your prompt reply.

    my hosting company is dreamhost. because I am a beginner programmer, I copied the questions that you asked above into an email to dreamhost customer support.

    I want to make a correction/clarification regarding my previous post: I believe the html files that I see in wp-content/cache are not from wp-supercache but from my previous attempts at using wp-cache (you probably already figured that out).

    In fact, I don't see a supercache subdirectory with an exact replica of my permalink structure, as you describe on your blog.

  5. jkjliu
    Member
    Posted 6 years ago #

    I've been trying to debug this for the past couple of hours.

    One thing that I've found: the symlink for advanced-cache.php is plugins/wp-cache/wp-cache-phase1.php.

    Isn't it supposed to be plugins/wp-super-cache/wp-cache-phase1.php ?

  6. jkjliu
    Member
    Posted 6 years ago #

    I'm also getting a Warning (and my site crashes!) at the following 2 lines of wp-settings.php:

    if ( defined('WP_CACHE') )
    require (ABSPATH . 'wp-content/advanced-cache.php');

    If I comment out these 2 lines, then my site works again.

  7. Donncha O Caoimh
    Member
    Posted 6 years ago #

    jkjliu - yes, that symlink should point at the wp-super-cache folder, no wp-cache. Did you have wp-cache installed before?

    Normally the plugin detects that the symlink is wrong so I'm surprised it didn't for you.

  8. jkjliu
    Member
    Posted 6 years ago #

    donncha, many thanks for your continued replies. Yes, I did have wp-cache installed before.

    so my problem now is I can't delete wp-cache (or rename it to wp-super-cache) in my dreamhost webftp. you don't have any thoughts on how to do this do you? I probably need to ask dreamhost support...

  9. ericdano
    Member
    Posted 6 years ago #

    FreeBSD 4.11 I believe.

    Apache 1.3.39 with Php 5.2.4 with Modules Mime and mod_rewrite active.

    I don't see anything in the error logs. I'll try dumping them to a different file (in case I'm missing something).

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    jkjliu: Delete the advanced-cache.php symlink entirely. Super Cache should then recreate it. You may need to deactivate and reactivate the plugin.

  11. ericdano
    Member
    Posted 6 years ago #

    Ok, I checked again, and I don't see anything in the logs. What is happening is that if I turn Supercache on, and compression on, I never get pages served from it. All the pages come dynamically, and the stats on the wp-cache page never show anything for Supercache. WP-Cache seems to not work either when the compression is active. When I turn off compression, only WP-Cache seems to serve up pages. Supercache never shows anything other than 0 pages, where as WP-Cache will have 50+.

    Ideas? Does one need to have compression enabled in the php.ini file?

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Stop mixing the two. Use one cache plugin only, having two will cause them to interfere with each other.

    WordPress can only use one caching plugin. There's only one hook. Whatever the advanced-cache.php file points to is what is being used, no matter what you have "activated".

  13. jkjliu
    Member
    Posted 6 years ago #

    THANK YOU to Otto42 and donncha: supercache seems to be working well now!!

    However, there is one problem: I'm seeing odd characters every once in a while like  and ”Â.

    I used to have this problem with wp-cache too. Is there any way to make the odd characters go away, please?

  14. jkjliu
    Member
    Posted 6 years ago #

    Just some more information on my previous post regarding the odd characters that I'm seeing:

    I have Super Cache Compression disabled.

    My host is dreamhost.

  15. ericdano
    Member
    Posted 6 years ago #

    "Stop mixing the two. Use one cache plugin only, having two will cause them to interfere with each other.

    WordPress can only use one caching plugin. There's only one hook. Whatever the advanced-cache.php file points to is what is being used, no matter what you have "activated"."

    Not sure to whom that message was for. I do not have both plugins enabled. Super-cache supposedly is WP-Cache and then some. According to my WP-Supercace page, I have served 35 some WP-Cache pages, but 0 Super-cache pages.

    Now, can we have some helpful suggestions now?

  16. rio517
    Member
    Posted 5 years ago #

    This is what worked for me:

    Make sure the following line is in wp-config.php and it is ABOVE the "require_once(ABSPATH.'wp-settings.php');" line:

    define( 'WP_CACHE', true );

  17. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Rio517 - exactly what's in the troubleshooting section of the readme :)

Topic Closed

This topic has been closed to new replies.

About this Topic