WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

z-Lightview

Enables Lightview for images in posts and pages, including the WordPress image gallery.

1.3.0

Note: As of version 1.3.0 the plugin will (by default) automatically backup installed Lightview files during updates; however, you'll need to install these files just once more--my apologies folks, I have addressed this issue going forward to ensure you are not inconvenienced again.

  • Revised filters to better determine when Lightview should be used.
  • Updated bundled Prototype library to version 1.6.1. This should provide better support for Internet Explorer 8.
  • Revised Scriptaculous library to prevent it from trying to load additional, unnecessary add-ons (previously it would cause several 404 errors).
  • Created a settings page (under the main Settings menu) to manage where and how the plugin should use Lightview.
  • Added an option to prevent Lightview from being used on images linked to from external sites (configurable in the new settings page).
  • Added an option to backup Lightview's JavaScript, CSS, and image files during updates to the plugin (this will ensure you do not have to re-download Lightview in future updates). This is configurable in the new settings page.

1.2.1

  • Update to support PHP 4. This should fix the line 34 syntax error that would cause a fatal error when running in a PHP 4 environment.

1.2.0

  • First public release on the WordPress Plugins directory.

Requires: 2.8 or higher
Compatible up to: 2.9.2
Last Updated: 2009-9-16
Downloads: 4,245

Ratings

3 stars
3.4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
0,1,0