WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Youtube Profile Field

Automatically display your latest Youtube videos on your site. Comes with the shortcode [youtube-user] to be used in posts and pages.

3.1

  • Update to Youtube API v3 (the v2 API will stop working on April 20, 2015)
  • WordPress 3.9 and later: use the native WordPress video player
  • Channel ID can be used as username
  • Fix minor bug with unsafe HTML not properly being removed in the plugin settings
  • Width and height settings removed. Will default to the default embed width. For old users, their old settings will still work
  • Major speed and stability improvements
  • Minor bug fixes
  • Tested with WordPress 3.9

3.0.3

  • Use 4:3 aspect ratio for videos (same as WordPress)
  • Added Serbo-Croatian translation by Borisa Djuraskovic.
  • Bugfix: Correctly load translations
  • Tested with WordPress 3.7

3.0.2

  • Bug fixes

3.0

  • The videos are now embedded using oEmbed which means that WordPress can cache them
  • Many bug fixes - mostly bugs where parameters didn't work as indended
  • Code improvements
  • Youtube API version 2.0
  • Tested with WordPress 3.5

2.2.5

  • Add ?wmode=transparent to the iframe

2.2

  • HUGE code improvements
  • The ypf_show_video() function now takes an array of options instead of parameters
  • Both the shortcode and template tag now accepts more arguments (see FAQ)
  • You can no longer use the old embed code
  • Small bug fixes

2.1

  • Plugin completely rewritten
  • Uses the iframe embed by default (supports both HTML5 and Flash). Added option to use the old
  • Requires at least 3.1
  • Now removes the plugin options when you uninstall the plugin
  • If using the template tag, make sure to have echo in front of it.
  • A lot of bug fixes

2.0.3

  • Shortcode bug fix

2.0.2

  • show_video() has been renamed to ypf_show_video() - You'll have to update your template files if you use the template tag
  • Fatal error: Call to undefined method WP_Error::get_item_quantity() bug fixed
  • Shortcode bug fix
  • Code clean up and other bug fixes
  • No more 2.8 support

2.0.1

  • Support for full screen

2.0

  • 2.9 support
  • The plugin now uses the SimplePie included in the WordPress core
  • Plugin options panel
  • Can now be translated

1.0.5

  • Shortcode: Added the ID parameter to the shortcode

1.0

  • Initial Release

Requires: 3.6 or higher
Compatible up to: 3.9.1
Last Updated: 2014-4-23
Downloads: 7,392

Ratings

3 stars
3.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1