WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Yelp Widget Pro

Yelp Widget Pro makes it easy for you to add business listings to your website or blog via an easy-to-use and intuitive widget.

How do I upgrade to the Premium version?

You can update to the premium version of Yelp Widget Pro by clicking here. Once you upgrade you will be emailed a license key which will allow you to enable auto updates.

I've purchased the Premium version. How do I use it?

First you should remove the free version of the plugin by deactivating and deleting the plugin. Don't worry, none of your data will be lost. Next, download the premium version zip file from your WordImpress purchase history page or from the successful purchase email which includes your license key and download link. After that, goto the plugin settings and input your license key to activate.

Why should I use this plugin?

Use this plugin if you have a website that would benefit in displaying search results for a Yelp search term. For example, a travel website selling reservations could display the top resorts for a given destination. A business website could also display their yelp business listing in their sidebar by using the Business ID search option

How do I display only my business?

If you would like to display only your certain business then you must enter in your "Yelp Business ID" in the widget's ID input. The ID of the business is the last part of the Yelp URL of its Yelp page. Ex: http://www.yelp.com/biz/togos-sandwiches-san-diego-3, the id is togos-sandwiches-san-diego-3. This is the only parameter you need to set to use this method.

How do I disable the CSS

If you would like to theme the widget yourself you should disable the plugin's CSS output. To do that please visit the options page (Settings > Yelp Widget Pro) and check the appropriate option.

The plugin looks funny in my sidebar, what's the deal?

Some themes may have very small sidebars and CSS styles that conflict or alter the styles within Yelp Widget Pro. To correct any styling errors you can either disable the plugin's CSS all together or override the CSS selectors in use to make the widget appear how you'd like. CSS-related issues are not actively supported as there's too many variations between the thousands of WordPress themes available.

Requires: 3.5 or higher
Compatible up to: 3.8.3
Last Updated: 2014-1-18
Downloads: 10,441

Ratings

4 stars
4.5 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,1,1
100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1