WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

YD Network-wide Options

Automatically replicate any plugin setting network-wide: apply sitewide settings. Spread your settings or options on all your multisite blogs. Options

0.1.0

  • Initial release

0.1.1

  • Optional debug code

0.2.0

  • Bugfix: memory leak when replicating to a large number of blogs
  • Bugfix: possible unwanted recursion when updating an option
  • Improved settings page design
  • Debug messages for diagnosing memory problems
  • Dutch version

1.0.0

  • Final release 1
  • Bugfix: A single child blog should be enough
  • Bugfix: Blogs should not have to be public/immature/... to allow replication
  • New feature: Autospreading settings change is now an option (enable/disable update action hook)
  • New feature: Auto-apply default options when new blog is created
  • New feature: Can disable overwriting of existing options when updating from the settings page

1.1.0

  • Bugfix: Auto-apply default options when new blog is created (funded by Matt Hardy @ bbgqt.org)
  • New feature: default options are displayed in the settings page
  • German version

1.1.1

  • Bugfix: unserialize

3.0

  • WordPress 3.0 compatibility
  • Admin panel W3C compatibility issues
  • Minor bug fixes
  • Documentation upgraded to match WP 3.0 vocabulary
  • Upgraded French version
  • Upgraded funding credits
  • Name changed from YD WPMU Sitewide Options to YD Network-wide options
  • Widget settings buttons renamed to plugin settings (there is no widget)

3.0.1

  • Minor text changes

4.0.0

  • Added feature to replicate custom database tables used by some plugins
  • Checked overwrite option
  • Fixed bug in autospread(ing) option
  • Fixed debug_backtrace / PHP4 warning
  • Switched form submission to POST method
  • Added option for flushing URL rewrite rules on sub blogs
  • Added option to choose "master" blog for replication features
  • Added optional blog filtering options
  • Added option to ignore specific blogs
  • Tested WP3.0.3 compatibility, updated doc

Requires: 2.9.1 or higher
Compatible up to: 3.0.5
Last Updated: 2012-1-31
Downloads: 11,299

Ratings

4 stars
4.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
75,4,3 100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,2,2
0,4,0
100,1,1 50,2,1
0,1,0
33,3,1
0,1,0
0,2,0
100,1,1