WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Xtreme One Toolbar

This plugin adds useful admin links and resources for the Xtreme One Theme Framework to the WordPress Toolbar / Admin Bar.

NOTE: Only works with Xtreme One Framework version 1.5.3 or higher as the parent theme. This is a paid premium product by Inpsyde GmbH, available via marketpress.com.

Installation Steps

  1. Installing alternatives:
    • via Admin Dashboard: Go to 'Plugins > Add New', search for "Xtreme One Toolbar", click "install"
    • OR via direct ZIP upload: Upload the ZIP package via 'Plugins > Add New > Upload' in your WP Admin
    • OR via FTP upload: Upload xtreme-one-toolbar folder to the /wp-content/plugins/ directory
  2. Activate the plugin through the 'Plugins' menu in WordPress
  3. Look at your toolbar / admin bar and enjoy using the new links there :)
  4. Go and manage your framework settings :)

Note: The "Xtreme One Theme Framework" in version 1.5.3 or higher is required for this plugin in order to work. If you don't own a copy it yet, this premium parent theme has to be bought. More info about that you'll find here: marketpress.com

Also note: This plugin has NO settings page because I believe it's just not neccessarry. All customizing could be done via hooks, filters, constants and regular WordPress user roles & capabilities. As the plugin is indended for an admin/ webmaster use that's the way to go. This way we can save the overhaul of an options panel/settings page, additional database requests, uninstall routines and such. End result: a lightweight system that just works and saves clicks & time :-).

Multisite install: Yes, it's fully compatible but have a look in the FAQ section here for more info :)

Own translation/wording: For custom and update-secure language files please upload them to /wp-content/languages/xtreme-one-toolbar/ (just create this folder) - This enables you to use fully custom translations that won't be overridden on plugin updates. Also, complete custom English wording is possible with that, just use a language file like xtreme-one-toolbar-en_US.mo/.po to achieve that (for creating one see the tools on "Other Notes").

Requires: 3.6 or higher
Compatible up to: 3.8.3
Last Updated: 2014-1-22
Downloads: 1,568

Ratings

4 stars
4.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,5,5
100,5,5 100,5,5
100,1,1 100,5,5
100,5,5
100,6,6
100,4,4
100,5,5
100,1,1 100,1,1
100,1,1
100,2,2
100,2,2
100,2,2
100,2,2