WordPress.org

Ready to get started?Download WordPress

Plugin Directory

XML-RPC Modernization

This plugin updates the WordPress XML-RPC API to leverage the latest features of WordPress and move beyond the historical Blogger/metaWeblog/MT APIs.

This plugin brings XML-RPC API enhancements from the WordPress 3.4 release to previous versions of WordPress (3.3 and earlier). It also adds new user management methods.

It is derived from Prasath Nadarajah's GSoC '11 project to expand WordPress' web services, although the exposed API methods are not compatible (different parameter names/types/orders).

Methods

New Methods:

  • wp.newUser - create a new user
  • wp.editUser - edit user information
  • wp.deleteUser - delete a specfic user

3.5 Methods for pre-3.5 sites:

  • wp.getUser - get information about a specific user
  • wp.getUsers - retrieve a list of users
  • wp.getProfile - retrieve information about the requesting user
  • wp.editProfile - edit the profile of the requesting user
  • wp.getRevisions - retrieve revisions for a specific post
  • wp.restoreRevision - restore a post revision

3.4 Methods for pre-3.4 sites:

  • wp.newPost - create a new post (of any post type)
  • wp.editPost - edit a post (of any post type)
  • wp.deletePost - delete a post (of any post type)
  • wp.getPost - get a specific post (of any post type)
  • wp.getPosts - get a list of posts
  • wp.getPostType - get information about a specific post type
  • wp.getPostTypes - get a list of registered post types
  • wp.getTaxonomy - get information about a specific taxonomy
  • wp.getTaxonomies - get a list of registered taxonomies
  • wp.newTerm - create a new term in a taxonomy
  • wp.editTerm - edit a term in a taxonomy
  • wp.deleteTerm - delete a term in a taxonomy
  • wp.getTerm - get information about a specific term in a taxonomy
  • wp.getTerms - get a list of term associated with a taxonomy
Tags: , ,

Requires: 3.3 or higher
Compatible up to: 3.5.2
Last Updated: 2012-12-3
Downloads: 1,982

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.